1. Encountering issues with the Localization/Translations with 1.3.5? Please report them via the section linked below so that we can account for all of them and have them addressed. Thanks! Localization Bugs & Issues Section
  2. We have hub threads for known bugs/issues and statuses of fixes for Mobile, 3DS, and Console platforms (UPDATED):
    Click here for Mobile
    Click here for 3DS
    Click here for PS3/PS4/PS Vita/XBox 360/XBox One

PC [1.3.5.3] Terraria Inventory Editor

Discussion in 'Released' started by Shoot, Sep 26, 2014.

  1. tywilburn162001

    tywilburn162001 Terrarian

    I cant download, it says the owner has used up all traffic limit. Just a idea, use a different file host that doesn't do that.
     
  2. Tribulation

    Tribulation Official Terrarian

    It's not even updated yet. People just downloaded it in haste thinking it was and used up the limit.
     
  3. Stonerton

    Stonerton Terrarian

    you did a great job on 1.2.4.1, looking forward to the 1.3 version :)
     
  4. wish the download was on a site that would actually allow me to download the file instead of send me in an infinite loop back to the page its already on :/

    ge.tt always loops infinitely for me unless its a direct link to the actual file and not to their page
     
  5. Shoot

    Shoot Terrarian

    Hey guys,

    First off, I want to thank you all so much for your kind emails, tweets, and messages. I love you all

    I've gotten the new items in, as well as player saving and loading. I've still got to figure out some unknown values in the player file and check for new buffs but nothing that'll take too much time.

    I'm at the ophthalmologist now but have nothing planned but this today so I hope to get quite a bit of work done today.

    In the mean time, there is a truly incredible inventory editor by @YellowAfterlife that you can find here

    I'll keep you guys posted and thank you again for your patience
     
  6. Shadowlesswanderer

    Shadowlesswanderer Terrarian

    And thank you for taking the time to post this status update and update this program.
     
  7. Shoot

    Shoot Terrarian

    It's here!

    I've mostly added support for 1.3+ with some small problems.

    The hide info (hiding accessories, hiding equipment, etc) is not something I've truly wrapped my head around but it is something that the editor can go without and
    the Skin Variant is not rendered on the Looks tab. Aside from these two bugs that I know exist, the editor should be completely functional.

    I've changed where the file is hosted and it should be much better now, no more public file hosting sites for me.
    Here is the VirusTotal and

    Here is the download link

    I apologize in advance for any bugs you may encounter but please do report them so I can fix them!

    - Shoot
     
  8. Stonerton

    Stonerton Terrarian

    great work on the update, keep up the good work. there are still some items missing but aside from that it works great :)
     
  9. Glazzy

    Glazzy Terrarian

    Doesn't allow me to run it? help..
     
  10. DatAsianTho23

    DatAsianTho23 Terrarian

    im on 1.3 and i tried to get some of the new items to see what they were and it lets me save but when i go in-game the items aren't there
     
  11. Shoot

    Shoot Terrarian

    What exactly is it telling you?

    You have to save the item then save the player file once you're finished. You have to be in the main menu of Terraria to edit your players

    Let me know if it still doesn't work for you

    Missing items ;(
    There should be all of them there. I didn't manually check the list in the interest of time but that's odd.
    The item names are what appears in game.

    Let me know which item(s) is/are missing and I'll look into it
     
  12. MegaBlademaster12

    MegaBlademaster12 Terrarian

    I cant use the 1.3 editor for my character! I have used it on my character before, and cleared out my ENTIRE inventory, my ENTIRE piggy bank and safe and my equipment. ALl I get is "Well this is embarrassing... Value of "2700" is not valid for 'Value'. 'Value' should be between 'Minimum'
     
  13. Tyty

    Tyty Terrarian

    First of all, I appreciate your work. I would like to know everyone has to wait a specific number of seconds while typing the desired item name.
    The program freezes while it searches for the desired item. I would like to know if this is normal and accepted or not normal and an issue. Thanks.
     
  14. XiaoThePotato

    XiaoThePotato Skeletron Prime

    Most of the bugs you guys are speaking of, never happen in Terrasavr. Now, I'm not bashing on shoot's invedit or anything, nor promoting Yellow, but I'm just saying. The programs are completely different after all, but if you're THAT bothered, then use something else. Shoot's probably spent a ton of time updating this invedit program to 1.3 anyway, so be patient.


    EDIT: I've used it, and it works great for the most part. The item search delay is rather irritating when you need to spawn lots of things, and most of the bugs can be avoided with some knowledge about character file editing. The program runs just fine, doesn't crash or anything. And, you don't need internet do use it like you do with Terrasavr.
     
    Weaky likes this.
  15. Aldrea

    Aldrea Skeletron Prime

    Fix for the "Error" message popping up and causing that charachter to not be editable: Click the "Save" (Not Save As; very important) it unlocked my charachter and I could reuse the inventory, helping a ton with building. Useful!

    Also; the errors seem to be happening with 1.2 converted to 1.3 charachters, @Shoot. Hope this helps. =b
    --- Double Post Merged, Jul 4, 2015, Original Post Date: Jul 4, 2015 ---
    Anyone who complains about search delay; that's because this is running and searching files completely independent from any source other than the ones you've downloaded; TerraSavr does not do this because it is hosted by the internet. TerraSavr is annoying due to the fact it doesn't auto-save your .plr file; this is annoying due to search lag. No one is perfect; Accept it and move on.

    Good job Shoot!
     
    Last edited: Jul 4, 2015
  16. XiaoThePotato

    XiaoThePotato Skeletron Prime

    I'm not necessarily complaining, I'm just stating the strengths and weaknesses of both programs. To each their own, y'know?
     
    Aldrea likes this.
  17. Aldrea

    Aldrea Skeletron Prime

    I know. Wasn't really aiming it at you, it was a general post towards the haters xD Using you as an example, hope you don't mind.
     
  18. ScaryMoldyToast

    ScaryMoldyToast Terrarian

    I really hope this is the right thread to post for issues. I can't seem to save at all, I tried running as admin but nothing no error message. I tried making a new character and saving it but same thing doesn't save or appear.
     
  19. Aldrea

    Aldrea Skeletron Prime

    What do you mean, can't save? Is the file not showing, is it grayed out, is it crashing...?
     
  20. ScaryMoldyToast

    ScaryMoldyToast Terrarian

    File doesn't show at all.