Standalone [1.3] tModLoader - A Modding API

Discussion in 'Works-in-Progress' started by blushiemagic, Jul 7, 2015.

  1. kowalskiy

    kowalskiy Terrarian

    One question, I have not found any way to set the modloader folder anywhere else than on default route. Thing is I would like to change it to drive D instead of C (its a small capacity SSD and would like to keep it as clean as possible). I searched on the wiki and forums but didn't find anything (or maybe found it but didn't know to recognize it).

    Thanks in advance and Cheers for the great work!
     
  2. jopojelly

    jopojelly Retinazer

    You do that via Steam. After that, you need to read the readme.txt and do that manual install into that new folder that you moved your Terraria install to. (It's just copy and paste the files from the zip into that folder.)
     
  3. kowalskiy

    kowalskiy Terrarian

    I reinstalled terraria just in case. It's located in "D:\Steam\steamapps\common\Terraria". After this I extract the contents of the zip file and so far so good.
    But the folder where mods are stored keeps happening in "C:\Users\myself\Documents\My Games\Terraria\ModLoader\Mods" and this last one is the folder that I would like to move to D:, for instance, "D:\ModLoader\Mods"

    Not sure if that is what you meant but I hope I explained myself better now.
     
  4. jopojelly

    jopojelly Retinazer

    ok, you want to move the saves. You can launch the exe with `-tmlsavedirectory "D:\ModLoader"` command line arguments if you want to make a shortcut or a bat file.

    blushiemagic/tModLoader
     
    kowalskiy likes this.
  5. kowalskiy

    kowalskiy Terrarian

    Now that worked flawlessly. A big thank you!
     
  6. Foostinator

    Foostinator Terrarian

    heck
     
  7. Kreslavskiy

    Kreslavskiy Terrarian

    I cant even download it, when i start the download, it starts downloading normally, but in about 5 minutes it will start saying that the download will take two hours, then it just stops downloading. It doesnt get canceled, it just stops at 3.2 Mbs and says downloading 0.0 bytes/sec. So i wait a few more minutes and then the download gets cancled saying network error, then forbidden, with no option to retry the download. And at one point the title of the download was this,
    f0979102-860a-11e8-9377-3436e6e52791.xml
    Any idea what i should do?
     

    Attached Files:

  8. jopojelly

    jopojelly Retinazer

    You probably live in a country that doesn't like Github, or some other issue.

    Here is an alternate link: https://cdn.discordapp.com/attachme...880188088320/tModLoader.Windows.v0.10.1.5.zip
     
  9. davidguy207

    davidguy207 Terrarian

    my game freezes on loading mods.
     
  10. [REDACTED}

    [REDACTED} Terrarian

    Hello there! It appears than whenever I'm trying to create a world, the game crashes on me! Here's the report! Capture.PNG
    Please help me ASAP! Thanks!
     
  11. So cool
     
  12. Jofairden

    Jofairden Golem

    You don't have enough RAM. Post your total RAM amount.
     
  13. [REDACTED}

    [REDACTED} Terrarian

    How do i do that? And how do I know how much RAM I have?
     
  14. MegaBlastoise777

    MegaBlastoise777 Terrarian

    Hey, uhh after I downloaded Tmodloader, I tried to open vanilla Terraria through the file in the steam folder but it said "Error - Please launch the game from your steam client." but when I did, it opened the modded version. help me I am confusion.
     

    Attached Files:

  15. tesar45

    tesar45 Steampunker

    Very Nice!:)
     
  16. absoluteZero

    absoluteZero Terrarian

    um. it broke. i just now downloaded an update for thorium mod and it broke my modpack cuz apparently it clashed with luiafk. i tried reloading the mods without thorium and while doing so spirit mod decided it doesnt want to work. it suddenly had problems loading cuz it was made for a previous ver of tmodloader (0.10.1.4) even tho it worked just fine until today (in 0.10.1.5). help. plz.
     
  17. Ryeun

    Ryeun Eye of Cthulhu

    Then delete Luiafk.
     
  18. enjoiyourfate

    enjoiyourfate Terrarian

    Has anyone an issue where you create a character, load into a server and play. Then close the game completely and when you re launch the game and try to play you cannot click your character? this is happening to me even after deleting every file and reinstalling the game and mod. but it keeps happening
    --- Double Post Merged, Apr 25, 2019, Original Post Date: Apr 25, 2019 ---
    as an update to this, when i open the game and im looking at the players folder, the .bak files automatically disappear as soon as the game launches and then i cant log into my character anymore??????????
    --- Double Post Merged, Apr 25, 2019 ---
    as another update, disabled even my antivirus, Launched game > Created character but didnt load it > closed game completely > went back into game > cannot click character, unloadable and says 0MP. so not even getting into a game just closing and opening the terraria game itself is breaking the character somehow?
     
  19. enjoiyourfate

    enjoiyourfate Terrarian

    I FIGURED IT OUT. Its when i right clicked someones name in steam and hit join game it would break the character.
     
  20. WonnyK

    WonnyK Terrarian

    Hello everyone.
    I'm having a problem with server connection with my friend
    We're trying to play Calamity and other mods, but neither me or my friend can't connect to each other, it says that we're not using the same version of the game.
    What should we do? We're reinstalled game and tModloader with mods lot of times.
    Sorry for bad English tho.
    Thanks.