Standalone [1.3] tModLoader - A Modding API

Discussion in 'Works-in-Progress' started by blushiemagic, Jul 7, 2015.

  1. Proto Persona

    Proto Persona Brain of Cthulhu

    Well you could try this. Got to Documents>My Games>Terraria>ModLoader>Mods. You should find something called CalamityMod.tmod. Delete that file, and then run Tmod Terraria again.
     
  2. AaaaaOS

    AaaaaOS Terrarian

    The closest thing I could find was 'ModCompile" saw a couple things titled with 'windows' I deleted them (which was probably a bad choice). I tried launching Terraria up again but it still freezes at initiating calamity mod [fonts/HPBarFont.xnb]

    Im on a mac if that makes any difference.
    I think I'll head over to the Calamity download page and see if this has happened to any other people.
    Thank you for the help though. I really appreciate it.
     
  3. Proto Persona

    Proto Persona Brain of Cthulhu

    Ah. If you're on a mac I have no clue how to help. Try the Discord servers for Calamity and possibly TMod. Maybe other people have had a similar problem and can get back to you quicker.
     
  4. xRaiizy

    xRaiizy Official Terrarian

  5. Proto Persona

    Proto Persona Brain of Cthulhu

  6. xRaiizy

    xRaiizy Official Terrarian

    Because modbrowser always fails to download mods for some reason
     
  7. UnknownRX

    UnknownRX Terrarian

    I was using the tmodloader and I wanted to go to full screen and the game crashed then I tried to restart it multiple times and got a message that said "unable to create graphics device" so then I went to the configs and change full screen to false still no luck. does anyone know how to fix this? (note: I've looked at many tutorials and none helped)
     
  8. Katniss

    Katniss Terrarian

    Code:
    public override void PostSetupContent()
    {
                Main.itemTexture[ItemID.CobaltSword] = GetTexture( "Items/Vanilla/CobaltSword" );
                Main.itemTexture[ItemID.CobaltDrill] = GetTexture( "Items/Vanilla/CobaltDrill" );
                Main.projectileTexture[ProjectileID.CobaltDrill] = GetTexture( "Projectiles/Vanilla/CobaltDrill" );
                Main.itemTexture[ItemID.CobaltChainsaw] = GetTexture( "Items/Vanilla/CobaltChainsaw" );
                Main.projectileTexture[ProjectileID.CobaltChainsaw] = GetTexture( "Projectiles/Vanilla/CobaltChainsaw" );
    }
    
    Any ideas why it replaces textures for drills/chainsaws (projectiles) only after the respective drill/saw have been used by the player and then mod have been reloaded.
    (this is the only custom code for vanilla drill projectiles I have)

    @Edit

    nvm, looked in the source and found that I need to set:
    Code:
    Main.projectileLoaded[ItemID.CobaltChainsaw] = true;
    (it got overriden right before drawing)
     
    Last edited: Jun 14, 2019 at 3:40 PM
  9. sfraczak33

    sfraczak33 Steampunker

    Noice
     
  10. sfraczak33

    sfraczak33 Steampunker

    I bet their gonna make an update like if you got the mods off your character and the new mods on, you click on that ! thing and then it says Turn mods on. Would've been a cool thing if they did add it! :D
     
  11. Zenathano

    Zenathano Terrarian

    If this should be posted on another forum, please tell me. I'm trying to play with the NEWEST version of Calamity, as well as Tremor, Thorium, kRPG, and Spirit. When I try to load any world, it gives me this error:

    Index was outside the bounds of the array.
    at Terraria.ModLoader.GlobalItem.Instance(Item item)
    at Terraria.ModLoader.ItemLoader.UpdateEquip(Item item, Player player)
    at Terraria.Player.VanillaUpdateEquip(Item item)
    at Terraria.Player.UpdateEquips(Int32 i)
    at Terraria.Player.Update(Int32 i)
    at Terraria.WorldGen.do_playWorldCallBack(Object threadContext)
    at Terraria.WorldGen.playWorldCallBack(Object threadContext)

    Please note that none of my worlds were loaded with the version of calamity that expanded the world. I went from a very old version straight to the newest.
     
  12. onContentStop

    onContentStop Plantera

    This may sound weird, but try clicking and holding on the background sun before it gets to this step and keep holding it until the mods load. It worked for me and honestly I have no idea why.
     
  13. xRaiizy

    xRaiizy Official Terrarian

    i have a question that is even weirder

    what if you click and hold the moon instead?
     
  14. onContentStop

    onContentStop Plantera

    it deletes system32
    same thing as the sun.
     
  15. xRaiizy

    xRaiizy Official Terrarian

    cool, it's actually sad that there is no other easter eggs in menu