1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice
  2. For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.
    Dismiss Notice

Standalone [1.3] tModLoader - A Modding API

Discussion in 'Works-in-Progress' started by blushiemagic, Jul 7, 2015.

  1. ozoahameg

    ozoahameg Terrarian

    lol you and I have same problem,
    I was planning to buy original when the 1.4 update is released but thanks to Tmodloader not compatible with pirated game im forced to buy it earlier than planned

    my gaming trick is that i pirate the game 1st then if I liked it i buy it
    well terraria is now my 3rd game bought right after Minecraft and The forest LOL
     
  2. FC Dracsemi

    FC Dracsemi Terrarian

    Okay... I don't know if this is a problem with me or Tmodloader, but some mods I can not download, as in they show up on the modloader, but when I hit the download button, the download bar doesn't move at all for quite awhile. It seems to be around mods that haven't been updated for a minimum of 8 months or more.
     
  3. ozoahameg

    ozoahameg Terrarian

    yes many mods are not yet updated
    tahst why im scratching my :red: waiting for them to make it 0.11 compatible
     
  4. Nakano15

    Nakano15 Official Terrarian

    Hey guys, just wanted to report a little bug here:
    The CanChat() override on ModNPC (and maybe even on GlobalNPC too, I dunno), It actually works as intended if you directly right click the npc, but is ignored if you are using the smart cursor to talk to the npc, so you can still talk to that npc anyway.
     
  5. Alchemist

    Alchemist Terrarian

    Uh, whenever I attempt to download tModLoader, I get this garbage, is this just my crap internet, or is there actually something wrong? upload_2019-8-28_21-30-2.png
     
  6. Andya34

    Andya34 Terrarian

    Microsoft .NET Framework Error:
    Unhandled exception has occurred in your application...
    Details:
    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
    at Terraria.ModLoader.UI.ModBrowser.UIModDownloadItem.IconDownloadComplete(Object sender, DownloadDataCompletedEventArgs e)
    at System.Net.WebClient.OnDownloadDataCompleted(DownloadDataCompletedEventArgs e)
    at System.Net.WebClient.DownloadDataOperationCompleted(Object arg)
     
  7. ozoahameg

    ozoahameg Terrarian

    some of your mods might be conflicting or its outdated, try removing your mods and putting them 1 by 1
    or update the entire Tmod if its not the latest
     
  8. Vendetta14

    Vendetta14 Terrarian

    I have a problem with the tmodloader .... I tried reinstalling the tmodloader but the error remains the same
     

    Attached Files:

  9. ozoahameg

    ozoahameg Terrarian

    1) if your using crack terraria or a pirated version of terraria Tmodloader 0.11 wont work anymore its been made as respect for terraria about to end (i even lanned to buy this game whole when the 1.4 is released but thanks to tmod, i end up buying it earlier)

    2) your Tmod might be just bugging out or your using an outdated mod, or mods that is not supported for 0.11 tmod yet (i have to disable multiple mods i have due to bot bieing updated)

    3) FINAL SOLUTION == If none of the above is working or true, uninstall terraria along with Tmod and reinstall it again, its best to use the Tmod installer rather than doing it manually
     
  10. Vendetta14

    Vendetta14 Terrarian

    I tried to reinstall terraria (Steam) with the tmodloader installer (downloaded at the moment) deleting the mods folder, and the same thing still appears:

    System.IO.IOException: You cannot create a file that already exists.

    en System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    en System.IO.__Error.WinIOError()
    en System.IO.File.InternalMove(String sourceFileName, String destFileName, Boolean checkHost)
    en Terraria.ModLoader.Logging.GetNewLogFile(String baseName)
    en Terraria.ModLoader.Logging.ConfigureAppenders()
    en Terraria.ModLoader.Logging.Init()
    en Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)

    using tmodloader 10.1.5 if it works but not with 11.4 :(
     
  11. Andya34

    Andya34 Terrarian

    it's actually caused by imgur since that website is banned on my country. it would be good if there was a option to turn off loading images from imgur or better make this option default and add a option to turn on loading images with a warning that it will cause issues on countries that imgur is banned on. it's not crashing the game but makes browsing in the mod browser very slow since it tries to get images for about 10 sec every time you scroll down then error pops up.
     
  12. ozoahameg

    ozoahameg Terrarian

    ow i see well i think the creator of the Tmod is the only one who can fix that
     
  13. jopojelly

    jopojelly Retinazer

    Delete the logs folder. MyGames/TErraria/ModLoader/Logs
     
    ozoahameg likes this.
  14. ozoahameg

    ozoahameg Terrarian

    LOL i forgot this method but yes this works(sometimes) LOL
     
  15. Vendetta14

    Vendetta14 Terrarian

    I don't know why, but I tried using 11.3 and it worked. Then I put 11.4 and it worked too. WTF!!!
     
  16. ozoahameg

    ozoahameg Terrarian

    use 11.4 since it has less bugs
     
  17. TheGamingCaterpie

    TheGamingCaterpie Terrarian

    I upgraded to the new version, and am trying to start a new playthrough with my friend, but neither of us can progress making a world when it comes to a certain part. We both have the same modpack, shared through discord. Whenever we try and create a world, it gets a bit laggy but powers through. Then it gets to a point about halfway where it says, "Generating Ruines." Ruines spelled like that intentionally. After it gets to that part in the making, it just stays there and doesn't load. Terraria is still open, the background is moving, and I can move my cursor, but the bar to Generate the "Ruines" doesn't fill. It stays empty. Is there a fix for this? I'm using version 11.4.
     
  18. ozoahameg

    ozoahameg Terrarian

    you have tremor mod?
    if its the tremor ruins then yes its buggy thats why i dont play tremor (i stick with Calamity and Fargowiltas for addon mods)
     
  19. TheGamingCaterpie

    TheGamingCaterpie Terrarian

    I do have tremor, thanks for the help! I'll remove it now :)
     
  20. Lord Amazon of the Jungle

    Lord Amazon of the Jungle Skeletron Prime

    Why is this world still here today? Cos some guy thought it'd be a nice idea to add mods to Terraria even up to this day.