• Labor of Love is here! Visit our Labor of Love thread for a special message from the team, a look at brand new Labor of Love merch, and the changelog (minus a few surprises 😉)

Standalone [1.3] tModLoader - A Modding API

ozoahameg

Terrarian
um in not sure where can i ask this but i have a problem
whenever i use too much water in terraria my game cant finish saving, and gets stuck and suddenly pops out or just stuck forever until i use task manager to end it

the bug goes is like this
i play terraria and pour a ton of water on a container, then when i exit it stops saving my world and stopped responding
i can save it if i only place water little by little but if i pour in a whole ton of it like 500 blocks worth of water it buggs
i tried looking at the logs ad this is what it says

this is the last line of the logs where the but/error is stated


[21:07:34] [31/ERROR] [tML]: Unhandled Exception
System.IndexOutOfRangeException: Index was outside the bounds of the array.
at Terraria.IO.WorldFile.SaveWorldTiles(BinaryWriter writer)
at Terraria.IO.WorldFile.SaveWorld_Version2(BinaryWriter writer)
at Terraria.IO.WorldFile.saveWorld(Boolean useCloudSaving, Boolean resetTime)
at Terraria.WorldGen.SaveAndQuitCallBack(Object threadContext)
at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()
[21:07:37] [12/DEBUG] [tML]: Web Request: http://mirsar.io/Files/Public/Overhaul/OverhaulInfo.json


please help
 

NeoThyMighty

Terrarian
So I have this problem where (I also think it is a universal mod bug) I can't equip certain accessories without them freezing me in place.

The world works as intended so it's not an autopause but I still can't use items when I have equipped some of these items.
Some of the items iclude:
Deathbringer Fairy (Fargo's soul mod)
Memer's Riposte (AlchemistNPC)

I don't know how to fix this. I have scoured the internet and I can't find anyone who has had this glitch before. Does anyone have the mind to help me in my endeavours to conquer the terrarian world that I live in for the moment? (FYI I've never had this glitch before and I have over 2K hours total playtime)
 

traintitanic

Terrarian
So I get this lovely little box upon startup of the game:

1570564743054.png


I've uninstalled / verified game cache multiple times and this still occurs.
Please help.

EDIT: Verification allows for launch of game without mods, using the install JAR produces that error
 
Last edited:

Np1

Terrarian
It says that the mod browser encountered an error and I can't fix it. I reinstalled everything and I still don't know what is going on
 

Attachments

  • Screenshot (43).png
    Screenshot (43).png
    603.1 KB · Views: 346

ahehehe

Terrarian
Hi everyone, I just recently downloaded tmodloader yesterday. Didn't install any mods though, then I hop back on today and there was a new update which was 11.5, so I install that. Got a couple mods downloaded and tried running the game. I also installed Terraria Overhual and when the mod was enabled, the debug console was on the screen the whole time. Don't know if that's an issue or if it's just like that. After making my character and map loaded, I try to type into chat to disable the console configuration and the game crashes and I get this error. Any help would be great.
 

Attachments

  • terraria issue.png
    terraria issue.png
    31.3 KB · Views: 434

blushiemagic

Retinazer
tModLoader
v0.11.5 is now released:

QOL
-Auto-Update implemented on Linux and Mac (subsequent release should be available as auto-update)
-Mac manual install greatly simplified
-Linux manual install simplified, now distributed as .tar.gz instead of .zip
-First Launch Welcome Message
-Navigating from More Info back to Mods menu now preserves scroll position
-Clear button in modded hotkeys menu
-Updating disabled mods no longer forces it to be enabled
Fixes
-Fix issues with logs that prevented the game from launching
-Fix super fast scrolling issues
-Fix server side ModConfigs failing to save when edited in-game
-Fix Smart Select bypassing ModNPC and GlobalNPC CanChat. Thanks @DarkLight66
-Fix ModConfig DictionaryElement Key/Value types swapped issue
-Fix TmodFile leaving handle open on read exception.
-Fix ModNet progress UI
-Fix issue preventing mod compilation in Visual Studio ("Failed to resolve assembly")
-Fix duplicate copies of .tmod mods freezing the game
-Fix issue with hideResources
-Fix cancelled Mod Compile download issue
-Fix out of bounds error with NPCDefinition
-Fix recursive logging bug
-Fix DrawBody issue
-Fix empty enabled.json issue
-Fix "Publish using tmodloader" issue while attempting to publish a mod
-Main.Support4K no longer automatically disabled
-Fix Patreon link being clicked while game not active
API
-Update Migration Guide -- If you make mods, please consult this page for info on migrating to v0.11.5.
-All generic versions of XType methods in Mod are now Obsolete, use ModContent.XType instead. (Use using static Terraria.ModLoader.ModContent; to simplify code.)
-Move mod unloading onto background thread in client (consistent with mod loading)
-Mod.ExtraPlayerBuffSlots, allows mods to expand the number of buff slots during mod loading. Thanks @AnimeCatgirl
-ColorHSLSlider and ColorNoAlpha attributes for ModConfig Color
-Many namespaces have changed, in case you are doing reflection. (Look in Terraria.ModLoader.Engine, Terraria.ModLoader.Core, etc)
-Many PreX and OnX hooks no longer "short-circuit", allowing all classes to run even if a method in another mod returns a value that will prevent the later methods from running. Thanks @Mirsario
-Logs will now mirror to Debug Output window in Visual Studio
-ModTile.RightClick replaced with ModTile.NewRightClick. New method allows fixing issues with right clicks causing weapons to activate.
-Global/ModNPC.OnCatchNPC hook for when npc are caught in net. Thanks @direwolf420
-ExtractMod now extracts xml documentation file if present.
-ContentInstance.Register can be used to register a single instance of a class, to simplify proper mod unloading
-MonoMod updated to v19.10.05.02. Thanks @0x0ade
ExampleMod
-Example of Dynamic Localized Label for ModConfig (modded item in chat tag)
-Updated to show GetInstance usage.
 

NeoThyMighty

Terrarian
So umm... This is what happens when I play and it only happens with ridiculously OP accessories such as Berserker's Soul from Fargo's soul mod.
I don't know how to fix this. It seems impossible to fix since I've tried to redownload tmodloader and even the new version but it doesn't seem to work.
I need help pls :(
20191011115555_1.jpg
 

Pure7865

Terrarian
Hi everyone, I just recently downloaded tmodloader yesterday. Didn't install any mods though, then I hop back on today and there was a new update which was 11.5, so I install that. Got a couple mods downloaded and tried running the game. I also installed Terraria Overhual and when the mod was enabled, the debug console was on the screen the whole time. Don't know if that's an issue or if it's just like that. After making my character and map loaded, I try to type into chat to disable the console configuration and the game crashes and I get this error. Any help would be great.
Having the exact same problem, when I hit play it almost finishes loading but then it crashes and shows the same error message. Happening with the new update, did you get a fix for this?

EDIT: Are you using the Terraria Overhaul - Major redesign update! mod? Because if I disable all of my mods, the debug console disappears and only comes back when I re-enable the Overhaul mod.
 

Gojira_Tanaka

Terrarian
I am having a different problem with the latest Tmodloader... it gets stuck on the loading recipes bar, and clicking cancel just gets it stuck on that, not changing the screen at all
 

Trickje

Official Terrarian
So I am working on this mod "Economy" and I seem to struggle with adding new recipes for other mods. Is this something you can help me with or is it not what tmodloader is meant for?
 
after some intense removing and reinstalling i found that it doesn't work at all..the problem still here
1571212502668.png
1571212530013.png

these are list of mod i have used

the problem occurs when i tried loading into the map

any suggestion or solution?
 

Kazzymodus

Moderator
Staff member
Moderator

Destructiox

Terrarian
Also having this issue, only just updated from 10.1.15 to 11.5 and assumed it was because of that, but it also happened on 10.1.15. I updated Java just in case but still not having it. I'm guessing it's an issue with the mod server itself.
 
Top Bottom