• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Standalone [1.3] tModLoader - A Modding API

sonicreala

Terrarian
tmod seems to be making the game lag like nuts. Can't really click on anything, mouse takes forever to move, have to exit using Close Window. I looked it up and apparently a few other people who had this problem said it's tmod.
 

Majad

Terrarian
tmod seems to be making the game lag like nuts. Can't really click on anything, mouse takes forever to move, have to exit using Close Window. I looked it up and apparently a few other people who had this problem said it's tmod.
I've had this issue a few times too when I had my inventory open. If it was closed, it didn't slow down anymore.

I've managed to resolve it but it's by exiting the game and re-entering, which is quite frustrating.
 

Jake736282

Terrarian
I need help! I downloaded this without backing up my original terreria files! I still have terreria but all of my stuff is gone. how do I get it back?
 

SaltRager

Terrarian
I was having trouble earlier tonight on the Mod Browser, and I think the problem was that I was still in 0.10 instead of the latest version. Easy fix, so I downloaded the new version and replaced all of the old files with the new files in ModCompile, but now whenever I try to run modded Terraria, this message appears;

System.DIINotFoundException: Unable to load DLL 'CSteamWorks': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
at
Steamworks.NativeMethods.SteamAPI_RestartAppIfNecessary(Appld_tunOwnAppID)
at Terraria.Social.Steam.CoreSocialModuleInitialize()
at Terraria.Social.SocialAPI.Initialize(Nullable`1 mode)
at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)

I didn't have any troubles playing the 0.10 version, but when I installed the new files this problem occurred. I've looked around the internet for a while now unable to find any solutions to it, but here's hoping someone knows something.
 

augit

Terrarian
I was having trouble earlier tonight on the Mod Browser, and I think the problem was that I was still in 0.10 instead of the latest version. Easy fix, so I downloaded the new version and replaced all of the old files with the new files in ModCompile, but now whenever I try to run modded Terraria, this message appears;

System.DIINotFoundException: Unable to load DLL 'CSteamWorks': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
at
Steamworks.NativeMethods.SteamAPI_RestartAppIfNecessary(Appld_tunOwnAppID)
at Terraria.Social.Steam.CoreSocialModuleInitialize()
at Terraria.Social.SocialAPI.Initialize(Nullable`1 mode)
at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)

I didn't have any troubles playing the 0.10 version, but when I installed the new files this problem occurred. I've looked around the internet for a while now unable to find any solutions to it, but here's hoping someone knows something.
pirated terraria?
 

Sup3r87

Terrarian
what app do i open this with? when i try to run the installer it wants me to run it with an app, terraria nor stream shows up.
 

KDjdDJA

Terrarian
Hi guys. I must say right away that I am Russian who does not know English well (Everything from the translator) in general, I put TModLoader 11.0.4, and I get an error that there is not enough RAM. There are no mods yet, but I have 8 GB of RAM itself. I read somewhere that this is due to the fact that TModLoader is 32 bits, and I don’t know where to download the 64-bit version. Help me please.
 
Hey, my achievements keep resetting when I close the game. I keep modded Terraria in a seperate folder, which I think might be the cause. Any advice, from anyone who's had a similar issue?
 

NoEyes

Terrarian
Hi, i just wanted to say that one of my characters is not loading and i back-up-saved it via cloud. This is annoying. please fic this so that i can properly my game. fank you
 

sonicreala

Terrarian
I keep installing and uninstalling things, move folders around, but regardless what I do, the Mods screen get very laggy, and it crashes when I click Mod Browser.

HamstarHelpers.Components.Errors.HamstarException: Invalid modList
at HamstarHelpers.Internals.Menus.ModTags.ModBrowserTagsMenuContext.BeginModBrowserPopulateCheck(UIState modBrowserUi)
at HamstarHelpers.Internals.Menus.ModTags.ModBrowserTagsMenuContext.Show(UIState ui)
at HamstarHelpers.Services.Menus.MenuContextServiceManager.LoadUI(UIState ui)
at HamstarHelpers.Services.Menus.MenuContextServiceManager.Update()
at HamstarHelpers.Services.Menus.MenuContextServiceManager._Update(GameTime gametime)
at System.Action`1.Invoke(T obj)
at Terraria.Main.Draw(GameTime gameTime)
at Microsoft.Xna.Framework.Game.DrawFrame()
at Microsoft.Xna.Framework.Game.Tick()
at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
at Microsoft.Xna.Framework.GameHost.OnIdle()
at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at Microsoft.Xna.Framework.WindowsGameHost.Run()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Terraria.Program.LaunchGame_()
 

h4rdw0rk3r

Terrarian
Found the solution of lag, while playing in the world! Backup the original client and put Tmodloader Terraria Client without renaming into something else, like "Modded_Terraria", like i did...
 

Attachments

Bebomonky

Terrarian
Is anyone having an issue where TModLoader is just not wanting to launch up at all?
It will load up for 10 seconds saying that it's launching but then closes out for a few seconds (Shows no errors or anything to know if it crashed or even opened)
 

Bebomonky

Terrarian
Well never mind it started working again :/ I still do want to know what causes that, if anyone knows what I mean from what I said
 
Top Bottom