• PC NEWS: update is out! More info here. Report bugs here
  • Journey's End on Xbox and PlayStation!: Get all the info by clicking here. A new patch is in QA - expect some Gamepad love, the return of Red's Pick and more. Click here for Known Issues and FAQ. For any other bugs, report them (with as much detail as possible) here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

Standalone [1.3] tModLoader - A Modding API


So I'm slightly a scrub when it comes to installing mods and editing files. I just tried installing this but it keeps telling me Failed to start game.

I unzipped the download file. Copied the terraria.exe and terrariaserver.exe files into the patch folder. Used the patch bat. Copied the modded terraria.exe and terrariaserver.exe from the tmodloader folder into the folder I found the vanilla files, which replaced the original terraria.exe. And finally copied everything in the files folder into the vanilla folder.

Can anyone tell me what went wrong? I'm 99% sure I followed the directions.


Mounts and pets on multiplayer aren't working/are insanely buggy. This is true for all modded mounts and pets. For the player using them, they work and look fine, but to everyone else looking at them they look insanely buggy and teleport around.


Skeletron Prime
where is the steamapps folder? (sorry for all these questions)
That's okay:p
Assuming you use windows 7, press the start button on your keyboard, or in the bottom left corner of your screen. Then search for "steamapps". One of the first files will be your steamapps folder.
If you don't use Windows 7, then I can't help you. Searching google will probably give you the answer.
i think you installed tmodloader wrong... or you opened a wrong file...
you should ask the Tmodloader Devs
(@bluemagic123 and @jopojelly)
I downloaded it before the 1.3.2 update and it was working fine..but now a second terraria has also popped up in the files.
You clicked on the tmodloader server file
I did, but now the mod loader disappeared!


I wanted to create a Custom sky for the boss, using the codes from the Example Mod. The mod compiles, but the desired effect is not... I tried many times, with different effects, but nothing happens. At all. What can be the reason?

Jack Macleod

Eye of Cthulhu
I want to ask a question....... Is it possible to add the mod browser to Mac? (I ask this because it is an absolute PAIN to update mods)
P.S. This is just a question not a request nor me forcing you to add it
Top Bottom