Standalone [1.3] tModLoader FNA (32bit/64bit) (Branch of tML)

I can't start the server. Console writes "The file is not currently locked (see server.log for full trace)", but i don't have this file anywhere.
 

Attachments

  • WTF.PNG
    WTF.PNG
    32.3 KB · Views: 135
I'm not sure if it is 64bit, but there is a bug with torches in terraria. I'm not sure how it activates, but doing certain actions (like putting items in chests/magic storage) with the shift button while you have a torch can cause the game to bug out and you can only have the torch equipped. The only way to preform other actions is to go into your inventory, select the item and then use it. It's impractical in combat. Like I said, I'm not sure if it's Tmod Loader x64, but the problems started to occur after I installed it.
 
hey yall i dont know if I did things wrong but my mod browser says offline and if I have mods in the usual mod folder none of them show up
 
hey yall i dont know if I did things wrong but my mod browser says offline and if I have mods in the usual mod folder none of them show up
OKAY? well now it works but its such an outdated version of modloader NONE of the mods I would use on the 64 bit tmodloader don't exist and it asks me to update to the newest version of normal tmodloader.

For instance, calamity mod, thorium, varia, ancients awakened, elements awoken. all of those don't exist in the mod browser for some reason
 
I'm not sure if this is the right place to post this, but I'm using the latest version of 64bit TML and sometimes i get these odd crashes where the game will freeze momentarily before closing without any error message at all.

I assume the log below is the correct one? if not feel free to correct me haha. Sorry about that messy mod list.
 

Attachments

  • client.log
    30.8 KB · Views: 95
  • Mod List.txt
    3.6 KB · Views: 94
Hi,
I just went from the 32bit to the 64 bite version but i'm having an issue,

I uninstalled terraria and cleared my game folder then reinstalled the game and by following each step i copied the files from the "tML 64 0.11.6.2 FNA 20.0.4 Update.zip " file i found on the Mega thing to my terraria folder in the common folder
then by running the game trough steam or directly from the folder as an admin i get this :
ErrorText.png

i then tried to install a previous version that i found on the Mega thing ( tML 64 0.11.6.2.zip ) ( i uninstalled and cleand my things before)
but still the same error.
i even tried to use the terraria version found on the Mega thing but still no sucess.

i had no problem with the 32bit version before except you know the lack of memory thing

one intersting thing is that the tmodloaderserver exe seams to work properly since i see my mods loading correctly and the windows ask me to select a world.

So my best guess is that's a windows creation problem.

If anyone have the same issue and have a fix for it i'll be more than glad to get some help :D

Have a nice day/evening
 
So I'm getting a lot of screen tearing as well as the console message "Using EXT_swap_control_tear VSync!"
What does this mean and how can I rectify the screen tearing?
 
GvoNnVB.png


Welcome to the unofficial tModLoader 64-bit branch of tModLoader!
This is a fork of Original tModLoader, and it's only been made a possibility due to tModLoader being open source!

Important Notes


Description


Installation


Downloads


Links


Credits



V5PLK66.png
I don't know what of all folders called Terraria I should put this files. Should I put in the Terraria of Steam or Terraria of My Games? And I should I drop them like that or inside their on folder? Btw Mi computer uses Windows.
 
Hi,
I just went from the 32bit to the 64 bite version but i'm having an issue,

I uninstalled terraria and cleared my game folder then reinstalled the game and by following each step i copied the files from the "tML 64 0.11.6.2 FNA 20.0.4 Update.zip " file i found on the Mega thing to my terraria folder in the common folder
then by running the game trough steam or directly from the folder as an admin i get this : View attachment 266310
i then tried to install a previous version that i found on the Mega thing ( tML 64 0.11.6.2.zip ) ( i uninstalled and cleand my things before)
but still the same error.
i even tried to use the terraria version found on the Mega thing but still no sucess.

i had no problem with the 32bit version before except you know the lack of memory thing

one intersting thing is that the tmodloaderserver exe seams to work properly since i see my mods loading correctly and the windows ask me to select a world.

So my best guess is that's a windows creation problem.

If anyone have the same issue and have a fix for it i'll be more than glad to get some help :D

Have a nice day/evening
So either you have audio outdated driver or you need to do that special command.

So I'm getting a lot of screen tearing as well as the console message "Using EXT_swap_control_tear VSync!"
What does this mean and how can I rectify the screen tearing?

You can ignore, screen tearing because you run above 60 FPS, either get Frame skip off or subtle or adjust your monitor refresh rate

I don't know what of all folders called Terraria I should put this files. Should I put in the Terraria of Steam or Terraria of My Games? And I should I drop them like that or inside their on folder? Btw Mi computer uses Windows.

Steam, my games only contain the save file
 
So either you have audio outdated driver or you need to do that special command.


Hi, thank for the quick answer,
So i updated my audio drivers but unfortunatly i'm still getting the same error message with both version ("tML 64 0.11.6.2 FNA 20.0.4 Update.zip" or "tML 64 0.11.6.2.zip ").

And i didn't find the special command in your previous answer.

Thanks anyway :D
 
1586977623310.png

Is this extra large size packaged with the modloader or did it stay from the mod after I deleted the Terraria folder in My Games, and reinstalled Terraria on a different drive?
 
I can't start the server. Console writes "The file is not currently locked (see server.log for full trace)", but i don't have this file anywhere.

Can you help? The first screen with mods, the second without mods, everything worked before.
 

Attachments

  • With mods.PNG
    With mods.PNG
    32.3 KB · Views: 112
  • Without mods.PNG
    Without mods.PNG
    42 KB · Views: 113
Soo, is calamity doomed for all time if i try to use it with other mods? its prob my favorite but it seems that getting stuck while making the world wet happens when it run with any other large mod, same as Tremor and the statues.
 
Soo, is calamity doomed for all time if i try to use it with other mods? its prob my favorite but it seems that getting stuck while making the world wet happens when it run with any other large mod, same as Tremor and the statues.

nevermind the update 20 min ago fixed it, now my issues is thorium while making the bat chamber and tremor while making the dungeon.
 
Hi, thank for the quick answer,
So i updated my audio drivers but unfortunatly i'm still getting the same error message with both version ("tML 64 0.11.6.2 FNA 20.0.4 Update.zip" or "tML 64 0.11.6.2.zip ").

And i didn't find the special command in your previous answer.

Thanks anyway :D
So from the troubleshooting guide, we have this which might fix your problem:
Code:
System.AccesViolationException: Attempted to read or write protected memory.
Why this happens: WASAPI can’t initialize your audio client.
Solution:   
1. Press Win+R to open Run. Type SystemPropertiesAdvanced and press the OK button.
2. Press the Environment Variables... button
3. In the User variables section, press the New... button
4. in front of "Variable name" type “SDL_AUDIODRIVER” In front of "Variable value" type directsound or winmm.
5. Press OK buttons recursively.
6. Start Terraria and the error shouldnt happen, if it does happen, please write a message in the support channel.

If that still doesn't work, do that:
1. Open cmd in administrator mode.
2. Run the following command: “netsh winsock reset”
3. Restart your pc

nevermind the update 20 min ago fixed it, now my issues is thorium while making the bat chamber and tremor while making the dungeon.

Tremor was alway broken on 0.11, even with normal tML (hence why it got yeeted off mod broswer)

View attachment 267165
Is this extra large size packaged with the modloader or did it stay from the mod after I deleted the Terraria folder in My Games, and reinstalled Terraria on a different drive?

64bit exclusive feature

Can you help? The first screen with mods, the second without mods, everything worked before.

Sound like anti-virus?
 
So from the troubleshooting guide, we have this which might fix your problem:
Code:
System.AccesViolationException: Attempted to read or write protected memory.
Why this happens: WASAPI can’t initialize your audio client.
Solution:  
1. Press Win+R to open Run. Type SystemPropertiesAdvanced and press the OK button.
2. Press the Environment Variables... button
3. In the User variables section, press the New... button
4. in front of "Variable name" type “SDL_AUDIODRIVER” In front of "Variable value" type directsound or winmm.
5. Press OK buttons recursively.
6. Start Terraria and the error shouldnt happen, if it does happen, please write a message in the support channel.

If that still doesn't work, do that:
1. Open cmd in administrator mode.
2. Run the following command: “netsh winsock reset”
3. Restart your pc

Hello,

Soooooooo, still no sucess .
i keep getting the same error, i tried both directsound and winmm.
I've done the command thing but still no change.

Buuttttt, great news it turn out it was my graphic card driver wich wasnt up to date so updating it solve my problem and the games running smothly !!!


Thanks a lot for the help and for the Tmodloader too :D

i have just one final question , can i use mods files (.tmod) from anywhere or do i need a specific 64bit version ?

Thanks again for all your work :D

Have a wonderfull day
 
Hi,my game stopped working for some reason...
Terraria without tml 64 bit doesn't start either...
I attached the dxdiag,msinfo and photos of what happens when I try launching the game
I played fine a few days ago,the only thing that I did was update my windows from the pre latest release to the latest,but it did that by itself...
I fixed the memory acces thing by reinstalling microsoft xnx framework or how it was called,which was affecting the normal terraria too,but now I get a different error with each other
 

Attachments

  • new modded errors.png
    new modded errors.png
    415.4 KB · Views: 231
  • normal terraria.png
    normal terraria.png
    1,020.1 KB · Views: 202
  • old modded errors.png
    old modded errors.png
    1.4 MB · Views: 196
  • DxDiag.txt
    74.6 KB · Views: 160
  • msinfo.txt
    973.8 KB · Views: 430
Back
Top Bottom