• Switch 1.4: New patch released Jan 18, details are here. Read the full release details here. Report bugs here.

tModLoader Cannot use 1.3 items in recipes or buffs, or really anything.

Status
Not open for further replies.

Athrisir

Terrarian
I'm trying to make a recipe using Luminite Bars and fragments, but when building the mod I get an error saying 'Terraria.ID.ItemID' does not contain a definition for 'SolarFragment'

This happens with every 1.3 item, buffs included. The same error each time. Do I need to update tmodloader or something?
 

Caseratis

Plantera
I highly doubt you tried every 1.3 item. It's just that a lot of the 1.3 id's are different from the names. I think the fragments are FragmentSolar. You should use visual studio because it makes suggestions.
 

Athrisir

Terrarian
I highly doubt you tried every 1.3 item. It's just that a lot of the 1.3 id's are different from the names. I think the fragments are FragmentSolar. You should use visual studio because it makes suggestions.
I would use VS but mine refuses to read .cs files. I'll try reinstalling it. While I haven't tried every 1.3 item, the ones I've tried to use have not worked. Would you know the ids for the ancient manipulator, luminite bars, and the shadowflame debuff? Those are the only ones I cannot work around.

edit: autocorrect is a :red:
 

ALPHAlockedX

Terrarian
the id for ancient manipulator is LunarCraftingStation, and the id for solar fragment is FragmentSolar
[doublepost=1504036300,1504036284][/doublepost]and luminite is LunarBar
 
Status
Not open for further replies.
Top Bottom