**REPORTED** Chests causing invalid housing

Discussion in 'PC Bug Reports' started by Omns, Aug 26, 2015.

  1. Omns

    Omns Terrarian

    I made a house in terraria that was 4x15 including walls, floors, ceilings. It included a workbench, chair and light source. I even got an npc to stay in the house, however when I put chests into the house it made the house invalid.

    House with no chests and npc: http://i.imgur.com/2AYKPfP.png
    House with chest and no npc: http://i.imgur.com/cHK9QMl.png

    I did not change anything but add the chests and it made the house invalid. I am not sure if this is a bug or that chests take up space but it is weird.

    BUT I made some houses with the workbench and the chair on the right and it didn't have this problem.

    House with chest and npc: http://i.imgur.com/hqZn4I1.png

    I am not sure what is the cause of this issue or if it is an issue at all. I feel like it might be the placement of the 1 block but I tried other ways of placing them and that was the only way to have multiple houses stacked up on each other on the left side.

    Here is a picture of the overall setup with me trying to put the demolitioner into a house with chests on the left side.
    http://i.imgur.com/dvIB2MD.png
     
  2. Thorfinn

    Thorfinn Terrarian

    Right. That one block for them to stand on in the rain or at night can't be occupied by a chest. Some things can sit on or above that one valid block (has to be at least one tile from the wall) and some can't. A table can rest on it, but if you put a piggy bank on the table right above that block, it is no longer valid housing. If the bank is on the side of the table above the platform, it's valid.
     
  3. Omns

    Omns Terrarian

    Why does the right side have no issues with the chests though. Half the houses should be invalid but the merchant and the dryad are valid.
     
  4. Sigma90

    Sigma90 Brain of Cthulhu

    Could you please provide some bigger screenshots, if possible? I'd like to check the surroundings of the house. Preferably without you and the dinosaur in it, so we can see the whole house and make sure there are no gaps as well. :)

    There are a number of things that could invalidate the housing: gaps in the walls, no light source, missing table/chair... but looking at this, I'm going to take a guess: Is there Crimson / Corruption near the house? It's possible that during the span of placing those chests, it crept up and invalidated the house. Too much Crimson/Corruption will invalidate housing, and this includes all naturally occurring blocks. (It does not include bricks, Flesh blocks or wood.)

    If you use the ? tool to check the house, does it give you any information, or does it just say "This is not valid housing"?
     
  5. Omns

    Omns Terrarian

    In the last picture I took a picture of the whole setup and it should I did the ? tool on the house that the demolitioner was in and it says is not a valid housing.

    Here is a better picture: http://i.imgur.com/pYtOk5B.png
     
  6. Sigma90

    Sigma90 Brain of Cthulhu

    I'm inclined to agree with @Thorfinn -- it looks like the chest being on the only solid block is causing the problem. 1.3 introduced a mechanic whereby NPCs aren't supposed to block chests. Given this bug report I assume that means that NPC don't regard a block with a chest on it as being solid and so won't stand on it. Of the houses on the right that are occupied, none have a chest on the solid block.

    To check, you could try removing the one chest on the solid block and see if the housing is valid again.

    Aside from that, everything else looks OK, so I'm out of ideas, sorry. Hopefully someone can confirm for sure for you.
     
  7. Omns

    Omns Terrarian

    It looks like he is right. It is just weird that the merchant and the dryad are able to occupy houses with chests on it.
     
  8. Sigma90

    Sigma90 Brain of Cthulhu

    The chests for the Merchant and Dryad aren't on top of the solid block in the house. That's probably the key difference.
     
  9. Omns

    Omns Terrarian

  10. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    The layout is slightly different in Dryad and Merchant's houses which is likely influencing it. I've confirmed the issue is a combination of a number of factors; changing the layout of the house even slightly removes it (one additional height in the room, for instance). There does seem to be an issue though, and it is reported.
     
  11. Thorfinn

    Thorfinn Terrarian

    That is kind of goofy. Have you tried relocating the merchant and dryad, then after they've moved, try to put them back? I've had situations where it was reported as "This house is already occupied", but once you move them elsewhere, it says, "This house is invalid".
     
  12. Omns

    Omns Terrarian