1. For issues you find with the Console 1.3 release, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    A FAQ with notes and workarounds can be found HERE. Please check this first to see if this helps your issue.

Official Console 1.3 Update Feedback Thread

Discussion in 'Console General Talk' started by ClearConscious, Dec 13, 2017.

  1. Cyberra

    Cyberra Eye of Cthulhu

    I feel rather glad that the biggest pain in the backside I've come across has been my Xbox 360's disk tray jamming shut. Haven't really experienced any of the major bugs except for the SE lag issue, and the last time was just after the last patch. The biggest annoyance in the game for me is the multiplayer tally counter reset bug. I haven't even had anything turn invisible lately.
     
  2. Cjjedik

    Cjjedik Terrarian

    I don't know if anyone has suggested this before, but one way to possibly improve the inventory UI would be to make the "tab" that you are on at the moment larger to take up most of the screen, rather than have them be the same size no matter what.

    In other words, if you are in your inventory, then the inventory would take up most of the screen, then if you switch to the equip tab that would take up most of the screen. This way, it would bring focus to what you are doing and make it easier to see.

    Another very slight addition would be two button indicators to tell the player what to press to get to what tabs. For example to get from the inventory to crafting, it would show "LB" or "L1".
     
  3. Shadowhawk141

    Shadowhawk141 Terrarian

    Let's hope the team can solve this bug as soon as possible but even more important without any other unforeseen things broken.
    For us as players but also for the team.
    I wish them all the best.

    At the moment the resetting map is the most annoying bug but we're still having fun.
    Btw, did they buff Duke Fishron? Ugh we can't remember him being this hard on Xbox 360 lol.
     
  4. Cyberra

    Cyberra Eye of Cthulhu

    Duke Fishbreath enrages now if you get away from the ocean, the way plantera does if you leave the underground jungle. It's no longer feasible to use the run-and-shoot-backward trick to taking him down. And for expert mode he's had a major AI change that makes him much, much harder.
     
  5. Proto Persona

    Proto Persona Brain of Cthulhu

    Not so much buffed him, as just made you have to fight him near the ocean. Duke's enrage was added as part of patch 1.3 to the PC version as well. It's an intentional change, possibly because they found the "run-and-shoot-backward trick" to be too easy. That said in 1.3.1 they increased the range at which he enrages, so currently on console he might be too difficult.
     
    Desutaa likes this.
  6. Unit One

    Unit One Moderator Staff Member Moderator

    @Shadowhawk141, I've heard from another member that they think the map on the most recently played single player world gets reset after joining a splitscreen multiplayer game and the host saves & quits before the non-host leaves.

    Example:
    Player A uses Character A and plays for a bit on a single player world. Player B hosts a multiplayer splitscreen world and Player A joins using Character A. Player B quits and saves the world before Player A leaves the world. Whatever single player world Character A was last on has had the map reset. I am not sure if closing the game and reopening before joining the splitscreen world makes a difference.

    See if you encounter the same thing. And if so, then a workaround may be to have the character you'll be using enter into a single player world that you don't care if the map gets reset before joining a splitscreen world.
     
    Shadowhawk141 likes this.
  7. ED209

    ED209 Plantera

    Is it normal to have a maximum number of training dummies in a map before they no longer have "ghosts"? I've built a series of underground farms utilising the slime mount/dummy system, but some of the dummies are just background items, they're not responding to weapon strikes. Is this the same on PC? Or is it yet another console glitch?
     
  8. r4v1n6

    r4v1n6 Official Terrarian

    Hmm, as I recall there's a limit of 100 target dummy entities (each dummy should have an entity associated which responds to damage) active at the same time in a world. I think that was discovered by @ZeroGravitas. I also recall there was a bug in the early 1.3.x builds that caused the entities to become disassociated with it's dummy, making it impossible to build where the entites are located (T-MEC had a mod which could fix that).

    I doubt you have 100 active target dummies, so the console version may currently have limitations that the pc version doesn't have.
     
  9. ED209

    ED209 Plantera

    I had over 100 as I was using them as a rail to bounce across under the collection tunnels of each underground farm, so if there was no dummy limit there would have been ~400 placed dummies in the map.

    Thanks for the info, I've updated my farms accordingly.
     
    r4v1n6 likes this.
  10. ED209

    ED209 Plantera

    So now I can't even play the game AT ALL because this keeps happening:
    [​IMG]
    Every time I open the game it prompts me with the user agreement, before showing this screen again and again. It keeps showing the achievements in game, which causes it to show this screen. Every slight movement causes it to show this screen, including re-favouriting my maps and characters, as it's forgotten them all. I've even tried resetting the default settings on my PS4, but that did nothing.

    How can Pipeworks get so much wrong? How are they still in business with such a spectacular failure on their hands? And I see in the home page that they're pottering about with a mobile update instead of fixing the piping hot mess that they unleashed on us. I've got very little time to myself and I've spent a lot of it playing this game, only to find out that it's probably all been for nothing. @ClearConscious any ideas on what I can do? Or are you going to stay as silent as ever?
     
  11. r4v1n6

    r4v1n6 Official Terrarian

    Movement of what? The console? Since I don't own a PS4 I don't know it's quirks very well, but this sounds to me like an impending harddrive failure.
    I recommend making backups of everything that you care about to a fresh USB Memory (if you have older backups already, I recommend you keep them in case the files has already gotten corrupted.)

    Sorry to hear about your troubles. :(
     
  12. ClearConscious

    ClearConscious Community Manager Staff Member Pipeworks Studio

    Have you submitted a bug report?
     
  13. Shadowhawk141

    Shadowhawk141 Terrarian

    I'm not sure if what your saying is true because I use two different characters for my two worlds.
    One world is my personal single player, the other is the world my son and I play in splitscreen, I always select singleplayer in the menu.
    Last couple days we have only been playing in our splitscreen world and every time we start the map is completely reset.
    When we stop playing we both go to our spawn points and I choose save and exit.
     
  14. ED209

    ED209 Plantera

    I suppose I should get into the habit of doing those, but when there are so many bugs it's a real pain, as the forms themselves are a pain.
    --- Double Post Merged, Jun 12, 2018, Original Post Date: Jun 12, 2018 ---
    I can't even find how to do this.
     
  15. ED209

    ED209 Plantera

    @ClearConscious I've just found this:
    [​IMG]
    Luckily it's not the world I've spent 6 months perfecting, but I don't know which file it is/was. This all happened after a close-application crash (CAC from here on). These freezes and crashes almost always happen after the cavern ice glitch; it seems to be a "gateway bug", and I was about to start testing whether it's just the standard cavern ice background that's causing it, or whether its corrupt/hallow variants are also causing it, but now I can't even open the game I can't.

    I've also just found that the corrupted file is 8.43MB the same size as all player and map files, but again, I don't know which one.

    What would happen if I do the following?:
    1. upload everything onto a USB,
    2. go onto PC and delete the corrupted file,
    3. download the data back onto PS4,
    4. start the application
     
    Last edited: Jun 12, 2018
  16. ClearConscious

    ClearConscious Community Manager Staff Member Pipeworks Studio

    Sending you a PM.
     
  17. ED209

    ED209 Plantera

    @Loki @ClearConscious

    The corrupted file seems to be the one with my user history, such as volume settings, preferences, achievements etc. When I tried pressing "upload all" on the PS4, it uploaded it but then failed because of the corrupted file. I then used the one-by-one option and uploaded everything but the corrupted file.

    My question is this: If I now delete everything Terraria-based from the PS4 and re-install it, should that fix the issue?
     
  18. Loki

    Loki Consigliere Staff Member Re-Logic Administrator

    I think CC is trying to get ahold of those files for seeing if there is or could be a fix (globally) - beyond that, I would have to defer to PW on whether or not what you are suggesting will work or not. Beyond my knowledge by a good mile. :)
     
  19. I was in the underworld, and I went to defeat the wall of flesh. In the battle I used the rod of discord around a demon building and then fell into deep lava, my ufo cannot fly in lava and I had a rod of discord debuff so I died. Anyway, I returned to spawn point and realised the wall of flesh was still there so I went down my hellevator and chased it down to the point where it dragged me back into battle where I killed it.
    The question is was it because I died in lava and not by the wall of flesh that it didn't despawn or is it a glitch or is it not supposed to despawn?
     
  20. sharkman0101

    sharkman0101 Skeletron

    Bosses seem to have a tendency to not despawn sometimes, even moreso in multiplayer.

    Me and my brother we both fighting Queen Bee, we died and my brother quit. I didn't stop playing, and about 2 minutes later, Queen Bee chased me to my house and came for my soul once more. Unluckily for her, it was her demise that was planned, not mine.
     
    Ultimate snowman 46 likes this.