• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

PC Corsair K55 keyboard not displaying RGB properly while in-game

Nathant999

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Both
Operating System
Windows 10
Terraria Version
1.4.0
Controls Used
Keyboard/Mouse
This issue has been present in both 1.4.0.1 and 1.4.0.2 for me. When I launch the game, my Corsair K55 keyboard and Corsair Glaive mouse both go black while the Re-Logic logo is on screen, which I assume is supposed to happen. When the Terraria title screen loads, the mouse appears to properly display color (it changes with the background, and when in game it corresponds to what's happening in game), however the K55 keyboard does not. While Terraria is running, my keyboard remains unlit; it doesn't even display the color I have set it to display normally. This issue persists the entire time the game is running. Exiting the game returns both the mouse and keyboard to the normal color, and I have noticed no issues with either of them displaying RGB outside of Terraria.

I have already checked iCUE (Corsair's software for RGB), and Enable SDK is turned on in the settings. I have a friend who also has a Corsair K55 keyboard, and he experiences the same issue.

EDIT: This issue is still present as of 1.4.0.3.

EDIT 2: This issue is still present as of 1.4.0.4.
 
Last edited:

Esmigalha

Terrarian
This issue has been present in both 1.4.0.1 and 1.4.0.2 for me. When I launch the game, my Corsair K55 keyboard and Corsair Glaive mouse both go black while the Re-Logic logo is on screen, which I assume is supposed to happen. When the Terraria title screen loads, the mouse appears to properly display color (it changes with the background, and when in game it corresponds to what's happening in game), however the K55 keyboard does not. While Terraria is running, my keyboard remains unlit; it doesn't even display the color I have set it to display normally. This issue persists the entire time the game is running. Exiting the game returns both the mouse and keyboard to the normal color, and I have noticed no issues with either of them displaying RGB outside of Terraria.

I have already checked iCUE (Corsair's software for RGB), and Enable SDK is turned on in the settings. I have a friend who also has a Corsair K55 keyboard, and he experiences the same issue.

EDIT: This issue is still present as of 1.4.0.3.

EDIT 2: This issue is still present as of 1.4.0.4.
I got you homie!

Go to my previous post:

PC - [1.4.1.1] My keyboard lights go dead when I launch the game.
 
Top Bottom