• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.4 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

**REPORTED** Crash during credits (Specific scene)

Aqre

Official Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Single
Operating System
Windows 10
Terraria Version
1.4.1.1
Controls Used
Keyboard/Mouse
Terraria crashes when I reach the part where the Tavernkeep and the Dryad are parting ways and the moment the Tavernkeep steps in the portal, the game crashes. The crash report is in the spoiler below.
15-Oct-20 5:20:18 PM
System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'Texture2D'.
at Microsoft.Xna.Framework.Helpers.CheckDisposed(Object obj, IntPtr pComPtr)
at Microsoft.Xna.Framework.Graphics.TextureCollection.set_Item(Int32 index, Texture value)
at Microsoft.Xna.Framework.Graphics.SpriteBatch.RenderBatch(Texture2D texture, SpriteInfo[] sprites, Int32 offset, Int32 count)
at Microsoft.Xna.Framework.Graphics.SpriteBatch.Flush()
at Microsoft.Xna.Framework.Graphics.SpriteBatch.End()
at Terraria.Main.DoDraw(GameTime gameTime)
at Terraria.Main.Draw(GameTime gameTime)
at Microsoft.Xna.Framework.Game.DrawFrame()
at Microsoft.Xna.Framework.Game.Tick()
at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
at Microsoft.Xna.Framework.GameHost.OnIdle()
at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at Microsoft.Xna.Framework.WindowsGameHost.Run()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)
My specs:
Version: Windows 10 Home (10.0.1.19041 Build 19041) x64 Based PC
Processor: AMD FX-9800P RADEON R7, 12 COMPUTE CORES 4C+8G, 2700 Mhz, 4 Core(s), 4 Logical Processor(s)
Controls Used: Standard Mouse (Logitech) and Keyboard (Not sure what brand)
Installed Memory (RAM): 16.0 GB (15.5 GB usable)


Let me know if you need any more info! :)
 

Sigma90

Brain of Cthulhu
Thanks for the report! And Zilem, I saw your report too but was waiting to check it myself. As there's been more than one report, I'll log this for a fix.

@Aqre and @Zilem - were you watching the credits from the main menu or after defeating Moon Lord? (Any other info that you have to help narrow down the cause would also be appreciated!)
 

Zilem

Official Terrarian
@Sigma90
I Watched The Credits from the Main Menu
I have not fought Moon Lord in 1.4.1 yet, due to this

Hmm.... Well Texturepacks rested to none enabled for after the 1.4.1 and 1.4.1.1 updates
Not sure if it is Related to that issue with settings, as nothing else in setting resat between updates
 

Sigma90

Brain of Cthulhu
Thank you for the info - I added it the report.

Hmm.... Well Texturepacks rested to none enabled for after the 1.4.1 and 1.4.1.1 updates
Not sure if it is Related to that issue with settings, as nothing else in setting resat between updates
Some players experience their settings being reset after each update. That might be what affected you.
 

Aqre

Official Terrarian
Thanks for the report! And Zilem, I saw your report too but was waiting to check it myself. As there's been more than one report, I'll log this for a fix.

@Aqre and @Zilem - were you watching the credits from the main menu or after defeating Moon Lord? (Any other info that you have to help narrow down the cause would also be appreciated!)
Yeah, I watched it from the main menu. I do have Texture Packs on so maybe I should disable them all and try watching credits again. I'll edit this post if taking off texture packs fixes it.
EDIT: Yep, I got the same exact error and crashed at the same exact time. Texture packs have no effect.
 
Top Bottom