• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

tModLoader Custom Player Sprites Mod

FoxyFullmoon

Terrarian
Try loading the file through a program like paint, and then saving it again as png.

Edit:. Also, pay attention, because some gears that partially shows the head may
place a model of the normal player head, I'm still looking for what is causing the issue
so the only fix at the moment is use a vanity gear that shows the modded head.
I tried saving it with paint and still no luck. I also removed all my gear to see if that would change it back, it still was default.
 

Nakano15

Duke Fishron
I tried saving it with paint and still no luck. I also removed all my gear to see if that would change it back, it still was default.
That is very weird, here the head is being swapped normally, and I just tested a while ago, maybe the problem is with the image file.
 

FoxyFullmoon

Terrarian
That is very weird, here the head is being swapped normally, and I just tested a while ago, maybe the problem is with the image file.
I'm using the fox head directly out of N Terraria. Would that be the problem? Maybe a different encoding or something. But my ear and tail images work fine so it's weird.
 

Nakano15

Duke Fishron
I'm using the fox head directly out of N Terraria. Would that be the problem? Maybe a different encoding or something. But my ear and tail images work fine so it's weird.
Maybe a different encoding might work and...
Aren't you the one who made the race textures?
 

Haku Wuffamute

Terrarian
Hello again.
I couldn't quite understand your explanation on multiplayer functionality. Would players I play with see each other's sprite appropriately if you had someone install the mod AND the skin/folder the same as you or is whatever you do is client-side only?

If its not possible, then would you mind telling me how to replace sprites? Just wanting to make a simple mod that replaces the sprites I use and so my friends and I can use them if I sent the mod to them.
 

Nakano15

Duke Fishron
Hello again.
I couldn't quite understand your explanation on multiplayer functionality. Would players I play with see each other's sprite appropriately if you had someone install the mod AND the skin/folder the same as you or is whatever you do is client-side only?

If its not possible, then would you mind telling me how to replace sprites? Just wanting to make a simple mod that replaces the sprites I use and so my friends and I can use them if I sent the mod to them.
To the other player see your sprite, the other player will need to have the skin installed, but I does not remember if I tested it on multiplayer.

I've tried making the mod download the skin through multiplayer, but ended up freezing both my pc and the other tester's pc, so I had to remove texture downloading from the mod.
 

Lithium

Spazmatism
Attempting to change to any skin causes this error. (and a crash to desktop)
error.png

Note: I have autopause on, and I used the menu at the bottom of the screen.
 

Nakano15

Duke Fishron
Attempting to change to any skin causes this error. (and a crash to desktop)
View attachment 158656
Note: I have autopause on, and I used the menu at the bottom of the screen.
I will investigate the issue.
[doublepost=1486188537,1486187989][/doublepost]Hum, maybe It's related to the skin you are using, which parts of the character your skin changes?
 

Lithium

Spazmatism
I will investigate the issue.
[doublepost=1486188537,1486187989][/doublepost]Hum, maybe It's related to the skin you are using, which parts of the character your skin changes?
It happens with your default skin pack- Goblin, Skeleton, and Raccoon.
I'm trying to make my own, and that doesn't work, either. I've tried removing everything from the folder except your skins, and it crashes then, too. Same goes for disabling autopause.
Haven't yet tried it with no mods enabled except it. I'll probably do that later.
 

Nakano15

Duke Fishron
It happens with your default skin pack- Goblin, Skeleton, and Raccoon.
I'm trying to make my own, and that doesn't work, either. I've tried removing everything from the folder except your skins, and it crashes then, too. Same goes for disabling autopause.
Haven't yet tried it with no mods enabled except it. I'll probably do that later.
The crash is not happening here, can you share the list of mods you have installed?
Maybe it's a conflict.
 

Lithium

Spazmatism
The crash is not happening here, can you share the list of mods you have installed?
Maybe it's a conflict.
Very Short Respawn Time (by System- original by jopojelly)
Wormholes (by hamstar)
Summoners Association (by jopojelly)
Helpful Hotkeys (by jopojelly)
Boss Checklist (by jopojelly)
Dye Easy (by goldenapple)
Base Mod (by GroxTheGreat)
Vanilla Tweaks (by goldenapple)
Stats Config (by Zocklukas)
WeaponOut (by Flashkirby99)
Recipe Browser (by jopojelly)
Which Mod Is This From? (by goldenapple)
The Luggage (by jopojelly)
Spirit Mod (by Phoenix Blade and the Spirit Mod Dev Team)
Cheat Sheet (by jopojelly, gorateron)
GRealm (by GroxTheGreat)
Thorium Mod (by DivermanSam)
RPG Classes (by Hiccup251)
WorldGen Previewer (by jopojelly)
Item Customizer (by thegamemaster1234)


I'll try disabling all of them except this one and give it a go.
EDIT: It does work. It must be a conflict. I'll start with the big gameplay mods first.

EDIT 2: It's WeaponOut that's causing the conflict. If you're not aware, that's a mod that adds your currently selected weapon in your character's hand.

Edit 3: Is it possible to have certain parts of your body not be tinted by skin color- like horns, for example?
 
Last edited:

Lithium

Spazmatism
Double post, but I've discovered a bug. I tried tinting the player's head (Player_0_0.png) darker, but it doesn't show up at all. Apparently, the game isn't loading that file, because it's formatted correctly, and it's definitely there.

Just to make sure, I scribbled all over the texture, and those didn't even show up at all.
 

Nakano15

Duke Fishron
That issue is getting way weirder everyday.
The problem is that for me it works very well, send to me the Player_0_0.png file, so I can check out if there is something wrong,
if you want to keep mystery about your texture, you can do so through private message.
 

Lithium

Spazmatism
That issue is getting way weirder everyday.
The problem is that for me it works very well, send to me the Player_0_0.png file, so I can check out if there is something wrong,
if you want to keep mystery about your texture, you can do so through private message.
Here it is(with scribbles removed).
Paint.net might've messed up color depth or something, so I'll see if I can get it to work with that.
Edit: It was set to 32-bit, going to try it on Auto-Detect, which changes file size.
Edit 2: Color depth doesn't seem to affect it.
 

Attachments

Last edited:

Lithium

Spazmatism
Dude, the skin loaded here, I believe some of the mods are interfering on the head drawing.
Nope. Even with CPS as the only mod loaded, it doesn't show up.
It might have something to do with there being too many skin files loaded- the skin i'm using is supposed to turn all the skin on the player black, and all the other files load before the head. It's possible that it might start working if I remove files.
I've got to go soon here, though, so this'll have to wait.
 

Nakano15

Duke Fishron
Nope. Even with CPS as the only mod loaded, it doesn't show up.
It might have something to do with there being too many skin files loaded- the skin i'm using is supposed to turn all the skin on the player black, and all the other files load before the head. It's possible that it might start working if I remove files.
I've got to go soon here, though, so this'll have to wait.
Ah, do notice that if your pc is slow, the sprite may take a bit long to load.
Beside would be weird since it's the first sprite... But not the first one to be loaded...
 

Lithium

Spazmatism
Ah, do notice that if your pc is slow, the sprite may take a bit long to load.
Beside would be weird since it's the first sprite... But not the first one to be loaded...
Well, all the sprites except the head load within a few seconds, but I don't think it's loading if it's not there after five minutes.
 

Nakano15

Duke Fishron
Well, all the sprites except the head load within a few seconds, but I don't think it's loading if it's not there after five minutes.
I'm not sure how to help with that issue then, if no other texture pack loads it's head sprite, then the problem is something obstructing head loading, if only your texture pack wont load, then the problem is the sprite.
Be sure to check out the properties of the image, and see if the image is not blocked.
 
Top Bottom