• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tAPI [Discontinued] tAPI - A Mod To Make Mods

Status
Not open for further replies.

Stalker

Terrarian
Uh, i'll waiting this mod for tAPI it will be really cool.
But i have some questions.
¿Does the content change or have some diferences if its launched for tAPI? Or will be same as TConfig.
Maibe is hard to port from TConfig to tApia. Anyway, Nice work!
 
Could somebody help me, I've got a problem. I followed TheHuckleberryWill's basic item tutorial, and already something's gone wrong. A screenshot of the error and my code will be provided with this post. Please ignore the titles of the screenshot files and the caps in the title of the files as well. Thanks.
Hello. I followed the same tutorial and had the same issue. I solved it by adding a .cs file with the same name as the .json in the Items folder and a ModBase.cs (which I found off a TemplateMod and had to alter a little since tAPI must have changed since that was uploaded) in the main folder of the BasicItem Mod.

On that note, I'm having some trouble with making a placeable item. My .json file seems to be fine, the mod compiles, I can see it in the crafting menu, but cannot place it after I craft it... Obviously I'm missing something and I get the feeling it might have something to do with the .cs file for the item. I would appreciate it if someone could point me in the right direction (to a tutorial, or an example perhaps).

Edit: Never mind. After some toying around I figured it out :dryadsmile:
 
Last edited:

Trogdor

Terrarian
im afraid i can't seem to find it on the original post if you could send me the link to the page on the original post that would be appreciated
 

Everest

Mechanic
Could somebody help me, I've got a problem. I followed TheHuckleberryWill's basic item tutorial, and already something's gone wrong. A screenshot of the error and my code will be provided with this post. Please ignore the titles of the screenshot files and the caps in the title of the files as well. Thanks.
Try adding an empty cs file (for example, "Empty.cs") to your mod's folder and try to build again.
 

chikai116

Terrarian
After testing these issues, I am unable to reproduce either in base tAPI. Try disabling all mods and attempting these things again and they are not an issue. Perhaps there is a mod interacting with them somehow?
The second one I cannot reproduce either.
I turn off all Mod, the piggy crash happen every time I click LootAll, regardless the content inside, even nothing click LootAll will crash.
I also heard that clicking LootAll will have a lot of "sound of receive an item"
upload_2014-10-19_12-49-53.png
 

Arkamirade

Skeletron Prime
As long as the item and it's image are in the same folder, it does not need the "texture" line.
Put the image and JSON in the same place and remove the "texture" line and see if that works.
Try adding an empty cs file (for example, "Empty.cs") to your mod's folder and try to build again.
Tryed both of these and the mod built itself, however in-game I can't craft the item that I coded. I created an empty .cs file called Empty.cs and it allowed me to build the mod, but as I said I couldn't craft the item. Any more ideas? Thanks.
 

Redstorm

Terrarian
Tryed both of these and the mod built itself, however in-game I can't craft the item that I coded. I created an empty .cs file called Empty.cs and it allowed me to build the mod, but as I said I couldn't craft the item. Any more ideas? Thanks.
Why i when create .cs file.I have crafted this item[DOUBLEPOST=1413712604][/DOUBLEPOST]
Tryed both of these and the mod built itself, however in-game I can't craft the item that I coded. I created an empty .cs file called Empty.cs and it allowed me to build the mod, but as I said I couldn't craft the item. Any more ideas? Thanks.
Example: Dark Sword.json,Dark Sword.cs,Dark Sword.png
 

Arkamirade

Skeletron Prime
Hello. I followed the same tutorial and had the same issue. I solved it by adding a .cs file with the same name as the .json in the Items folder and a ModBase.cs (which I found off a TemplateMod and had to alter a little since tAPI must have changed since that was uploaded) in the main folder of the BasicItem Mod.

On that note, I'm having some trouble with making a placeable item. My .json file seems to be fine, the mod compiles, I can see it in the crafting menu, but cannot place it after I craft it... Obviously I'm missing something and I get the feeling it might have something to do with the .cs file for the item. I would appreciate it if someone could point me in the right direction (to a tutorial, or an example perhaps).
I've been spending months surfing the internet for tutorials and all I found was TheHuckleberryWill. I would also love to be pointed in the right direction too. I tryed what you said. The mod compiles, but ever since I got Tapi r11 it has come up with an error everytime I load it up or I reload mods. At first it was, to me, purely aesthetic. But now whenever I play a world with my mod, the game crashes. I'll attach some screenshots. If you wouldn't mind checking them out, then that would be helpful. Thanks!
 

Attachments

jordan

Skeletron
I've been spending months surfing the internet for tutorials and all I found was TheHuckleberryWill. I would also love to be pointed in the right direction too. I tryed what you said. The mod compiles, but ever since I got Tapi r11 it has come up with an error everytime I load it up or I reload mods. At first it was, to me, purely aesthetic. But now whenever I play a world with my mod, the game crashes. I'll attach some screenshots. If you wouldn't mind checking them out, then that would be helpful. Thanks!
Have you got a texture for Basic Element item?
 

Arkamirade

Skeletron Prime
Have you got a texture for Basic Element item?
I do indeed. It's saved as a png with a colourless background, if that helps. 44 x 44 size, sorry for all the details but I'm keen to start modding and to do so I need to be able to make a basic item, or I'll have trouble making anything else.
 

jordan

Skeletron
I do indeed. It's saved as a png with a colourless background, if that helps. 44 x 44 size, sorry for all the details but I'm keen to start modding and to do so I need to be able to make a basic item, or I'll have trouble making anything else.
Can I please have a screenshot of your main folder, your items folder and your basic element json file (the actual contents)
 
Status
Not open for further replies.
Top Bottom