• PC NEWS: 1.4.2.3 update is out! More info here. Report bugs here
  • CONSOLE 1.4 NEWS: On Aug 25 Journey's End was submitted to Microsoft and Sony! The timing of the review process is a bit unpredictable, so we cannot give you a specific "launch date" just yet. Click here for more info. The plan is to have the update on Switch out later this year. Stay up to date with console news here
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

tModLoader DiscordRP - Rich Presence for Terraria

Grinjombo

Terrarian
I'm having an issue while using the Calamity addon, though that may not necessarily be the problem...

Basically, I get the rich presence while on the main menu, but upon loading the world, I lose it...
 

Grinjombo

Terrarian
do you have both mod on the latest version?
Yep, just check them, both are updated. After 3 hours playtime now, it shows up occassionally, and mostly my buddies can see it more than I do. If I tab out and come back it shows up for a bit then goes away. If I enter new biomes it comes back, then returns to 'tmodloader'
 
Yep, just check them, both are updated. After 3 hours playtime now, it shows up occassionally, and mostly my buddies can see it more than I do. If I tab out and come back it shows up for a bit then goes away. If I enter new biomes it comes back, then returns to 'tmodloader'
because your friend can see it more than you, it might be your Discord's problem (might be from settings etc.).
and I think Discord Rich Presence might have some problem if your discord (not your terraria) has some connection issues.
 

uber

Terrarian
having the same issue, when i get into terraria it says that im on the main menu but once i get in the world it goes to saying "playing tModLoader" instead
 
having the same issue, when i get into terraria it says that im on the main menu but once i get in the world it goes to saying "playing tModLoader" instead
do you use Windows? and do you use original tModLoader or 64 bit one?
I might try to solve this if it's original tModLoader
 

OwenBowen222

Terrarian
I'm having the same issue. I think it might be an issue with tModLoader being on steam, since it isn't considered Terraria but rather its own game, not entirely sure though.
 
I'm having the same issue. I think it might be an issue with tModLoader being on steam, since it isn't considered Terraria but rather its own game, not entirely sure though.
I can't really find a way to reproduce that.
Annotation 2020-06-15 092307.jpg

the only thing that stays being "tModLoader" is the screen share button .-.
 
@OwenBowen222 @JRMC @uber @Grinjombo
I might just found the cause
some of them:
- you are opening Discord with administrator privilege
- you are using BetterDiscord

So to make DiscordRP showed the status, you should use original Discord and without administrator privilege

I'm still try to find other possible causes though
 

OwenBowen222

Terrarian
@OwenBowen222 @JRMC @uber @Grinjombo
I might just found the cause
some of them:
- you are opening Discord with administrator privilege
- you are using BetterDiscord

So to make DiscordRP showed the status, you should use original Discord and without administrator privilege

I'm still try to find other possible causes though
I disabled BetterDiscord and I don't run it as administrator and it still persists. If you do know any other causes let me know, because this mod is pretty cool and I want to use it.
 

Ibby

Terrarian
My Discord Rich presence keeps flickering on and off. Like it will show everything then I switch to an empty slot on my hotbar and it will stop working on discord. I don't use BetterDiscord nor have discord with administrative privileges on. Maybe its an only an issue with 64bit tmodloader?
 

OwenBowen222

Terrarian
My Discord Rich presence keeps flickering on and off. Like it will show everything then I switch to an empty slot on my hotbar and it will stop working on discord. I don't use BetterDiscord nor have discord with administrative privileges on. Maybe its an only an issue with 64bit tmodloader?
Couldn't be, I'm getting the exact same issue without 64bit.
Unless the steam version is 64bit by default, idk.
 
My Discord Rich presence keeps flickering on and off. Like it will show everything then I switch to an empty slot on my hotbar and it will stop working on discord. I don't use BetterDiscord nor have discord with administrative privileges on. Maybe its an only an issue with 64bit tmodloader?
hmm, that's a bit strange, if you are on an empty slot, it should be only the small image is missing, not the entire rich presence .-.
 

Walpar

Terrarian
i take back what i said, since 32bit is now the official steam version i can actually use discordrp
 
1.2.2 Update
- Other mod developers now can easily add their mod status
- Reorder priorities for beehive and jungle temple
- Renaming some typo
 
Top Bottom