1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice
  2. For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.
    Dismiss Notice

tModLoader Extensible Inventory - Limitless, paginated inventory

Discussion in 'Released' started by hamstar, Aug 20, 2018.

  1. Gemuki

    Gemuki Skeletron Prime

    Well, so as of now by enabling and reloading ExtensibleInventory on it's latest version (as of this post) i can't seem to play modded without it due to an error.

    Error log shown below.
    [​IMG]

    I really just regret updating and wish i saw it coming but no.
    ______________

    EDIT
    : I have currently rolled back to 1.2.2 till the next version after 1.2.2.1 manages to have this fixed.

    EDIT 2 : Seems that Mod Helpers 4.2.3 was the cause, rolled back towards 4.2.2.1 and it sucessfully loads. Hamstar, please try and find a fix for this.​
     
    Last edited: Mar 2, 2019
  2. hamstar

    hamstar Steampunker

    Update to Mod Helpers v4.2.3.1. Sorry, this error is sudden and arose mysteriously.
     
    Last edited: Mar 2, 2019
    Gemuki likes this.
  3. Gemuki

    Gemuki Skeletron Prime

    Thank you for the fix, i'll inform you in-case 4.2.3.1 messes up.

    EDIT : The fix works correctly as reloading Extensible Inventory works without the error so it should be fixed correctly, thank you once again.​
     
    hamstar likes this.
  4. hamstar

    hamstar Steampunker

    If anyone is still having any UI issues, would you be willing to help me track that annoying issue down by using a special debug version?
     
  5. JErn

    JErn Terrarian

    [​IMG]
    Error appear after loading the map when enabling the latest version of this mod with Mod helper v4.2.3.2
     
  6. hamstar

    hamstar Steampunker

    Tell me if the v1.2.3.3 update fixes it (available on the mod browser).
     
  7. JErn

    JErn Terrarian

    yeah it fix but i didn't find it updated in mod browser(downloaded from this post). Still showing v1.2.3.2
     
  8. Squall98

    Squall98 Terrarian

    upload_2019-3-11_17-18-32.png
    :/ need update please
     
  9. hamstar

    hamstar Steampunker

  10. Terraria 2

    Terraria 2 Terrarian

    The same error, Cant load the worlds using 1.2.3.3 and 1.2.3.2.
    Backup to 1.2.3 - works ( i used it last time )
     
  11. Squall98

    Squall98 Terrarian

    [QUOTE = "hamstar, post: 1722323, member: 71687"] Utilisez-vous la version 1.2.3.3? [/ QUOTE]
    Oui

    upload_2019-3-11_19-17-4.png
     
  12. hamstar

    hamstar Steampunker

    Could anyone try out this (unreleased) version and tell me if this fixes the problem?
     

    Attached Files:

  13. Terraria 2

    Terraria 2 Terrarian

    Crash again.


    [​IMG]
     
  14. hamstar

    hamstar Steampunker

    How about this version? This is more or less a full revert.

    You know what to do with downloaded .tmod files, right?
     

    Attached Files:

  15. Terraria 2

    Terraria 2 Terrarian

    Sure. And again crash.
    May be conflicts with some mods? I use a lot. Also proof 1.2.3 ->
    [​IMG]
    [​IMG]


    Error:
    [​IMG]
    [​IMG]
     
    Last edited: Mar 11, 2019
  16. Squall98

    Squall98 Terrarian

    crash again
    upload_2019-3-11_19-52-16.png
     
  17. hamstar

    hamstar Steampunker

    Alright, please help test this last one, and if it fails, I'll just do a full revert for now. This is just weird.
     

    Attached Files:

  18. Squall98

    Squall98 Terrarian

    yes WORK
    upload_2019-3-11_20-2-42.png
     
  19. Terraria 2

    Terraria 2 Terrarian

    I tyred of mod reloading yet) But last v1.2.3.4f works. Great for you to help users at 2 p.m.
     
  20. hamstar

    hamstar Steampunker

    Excellent! If you don't mind, could you also try this version and tell me if it gives any errors? This will confirm where the actual problem is, and let me make an official mod browser update.
     

    Attached Files: