FAQ for Common 1.3.1 Bugs: PLEASE READ BEFORE POSTING!

Discussion in 'PC Bug Reports' started by Leinfors, May 29, 2016.

  1. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    FAQ for Common 1.3.1 Bugs and Concerns

    Table of Contents:
    Active

    1. Broken Texture Streak Against Background
    2. Multi-Color Wrench and Actuator Cutting
    3. Lock On Arrow Appearing/Persisting Without Gamepad
    4. Issues with Slayer of Worlds Achievement
    5. Automatically Using Items From Hotbar When You Drop Items While Autopaused
    6. Phasesabers Break Weapon Racks

    Fixed
    1. Game doesn't respond to mouse click on start up
    2. Water Physics Ceasing to Function
    3. Cannot Rename Chests With Autopause On
    4. Weather Status Failing To Change Server-side
    5. Some Worlds Failing To Load in 1.3.1.1

    Hello everyone!

    Continuing in the vein of the 1.3 issues FAQ, I'm going to keep a thread with the most common bug reports in 1.3.1; as with last time, this is to be both informative, to save you the trouble of reposting the same bugs that have been posted time and time before, as well as to offer potential workarounds for some of these issues. Also as before, this is NOT a thread for posting new bugs. This is only for discussion of the listed bugs!

    With that all said, lets take a look at the most common issues of this version . . .

    Active Issues

    1. Broken Texture Streak Against Background

    Another bug that is limited to specific users, this is one that results in a band of distorted colors across the background. This crops up in different colors and in different biomes; many people report it showing up on the title screen. There is no known cause of this issue, so we suspect it may be a specific hardware/software issue with Terraria; if we can diagnose a common thread here, that would be the best lead towards fixing the issue for those users who encounter it. None of us have yet to encounter this bug personally, and we don't have a workaround at this time.

    Broken Wall.png


    2. Multi-Color Wrench and Actuator Cutting
    An oft reported "bug", the Multi-Color Wrench indeed does not have the ability to cut actuators, despite having the Wire Cutters as an ingredient. This was an intentional design decision, so it is not a bug per say. However, it is being given reconsideration as to whether it will gain the ability to cut actuators after all (even if it potentially remains unable to place them). There is no final decision on this yet, so stay tuned for more details in the next hotfix update.


    3. Lock On Arrow Appearing/Persisting Without Gamepad
    For those of you unfamiliar, there is a Lock On feature for Gamepad support; one of these modes will show a small yellow arrow above potential targets. While Lock On is not possible with a Keyboard/Mouse combo, if you are using a Gamepad and switch to K/M, this arrow may persist anyway . . . sometimes only for a brief moment, sometimes for longer, and even re-appearing. Some users seem to report seeing it even though they aren't using a Gamepad at all. For now, you can just ignore the arrow, and if you have a controller hooked up, removing it and rebooting Terraria will cause it to go away for most users.


    4. Issues with Slayer of Worlds Achievement
    Since the 1.3 hotfixes, there have been recurring issues with the Slayer of Worlds achievement. This includes:
    - The inability to unlock the achievement at all
    - Unlocking the achievement early, usually at 13/14 bosses killed (people having not killed Duke Fishron)
    - The achievement "relocking" after being unlocked (only in-game, this doesn't effect your Steam achievements)
    Common trends with this issue tend to involve the Wall of Flesh for some reason; the achievement will sometimes unlock (or relock) when fighting the Wall of Flesh for a second time. This issue is still under investigation.


    5. Automatically Using Items From Hotbar When You Drop Items While Autopaused
    There is a known issue that is getting reported more and more often now (though its been reported for over two weeks), where upon dropping an item from your inventory while Autopaused, you will use the item in your active hotbar slot. The issue is actually far more prevalent, and effects consumables and weapons, but is now infamous for its use in the "multiple fishing line" bug, where by exploiting this bug, you can throw out multiple fishing lines at once. Obviously, the core issue is the Autopause bug itself, and upon resolving it, the resulting downstream bugs (such as the Fishing Bug, as well as some additional bugs the Multiple Fishing Bug causes) will be fixed as well.

    Fishin.png


    6. Phasesabers Break Weapon Racks
    Phasesabers, if placed on Weapon Racks, will cause serious tile/visual bugs if you attempt to remove them. The exact cause of this is known, and has to do with how Phasesaber are identified in the game's data; in the current game, Phasesabers are the only accessible item coded in this way, and this resulted in an oversight in how Weapon Racks handle them. If you DO place a Phasesaber on a Weapon Rack, its best to leave it in place and not to attempt to remove it or the Weapon Rack. Doing so will result in a buggy weapon rack that will probably be stuck there, and can even cause crashes. This issue does NOT apply to Phaseblades.

    It is also possible, under specific circumstances, that this issue will apply to pre-1.3 versions of basic Ore tools and weapons (Copper through Platinum, Swords/Pickaxes/Axes/Hammers). These items were also coded the same was as Phasesabers before 1.3, and if you crafted these items before 1.3, or placed them on Weapon Racks, they can cause the same issue. As with Phasesabers, I recommend that you do NOT attempt to remove them . . . just leaving them in place is the best solution for now. Versions of these weapons/tools crafted now will not cause the same issue.


    Fixed Issues

    1. Game doesn't respond to mouse click on start up
    One of the most commonly reported issues, yet still somewhat rare in that most people do not encounter it. If you find that the game does not respond to any sort of clicking with your mouse on the menu screen, try hitting any key on your keyboard. In virtually all cases, this will immediately solve the issue, but only for this gameplay session. Every time you reboot the game, you will have to press a button with the keyboard again. Additionally, some users have found that alt+tabbing out of the game will cause the problem again, requiring them to once again hit a button on the keyboard.

    Is tentatively considered fixed as of the 1.3.1.1 Hotfix.


    2. Water Physics Ceasing to Function
    An uncommon and very difficult issue to replicate, there seems to be a chance that water physics will spontaneously break, resulting in water that will not move, flow, or fall. We have yet to determine any consistent way of causing this bug to occur, and we are not yet certain whether it is limited to certain users or not. If anyone has discovered a consistent, reliable method of reproducing this issue at will, it would be very helpful knowledge towards diagnosing the exact cause of the issue and how to fix it!

    Is tentatively considered fixed as of the 1.3.1.1 Hotfix.


    3. Cannot Rename Chests With Autopause On
    Users with auto-pause on cannot rename chests in 1.3.1 when in single-player; the "pause" is interfering with the input to the name field. This is a known issue, and should be resolved in the near future, but in the mean time, you can temporarily turn off auto-pause to name chests.

    Is tentatively considered fixed as of the 1.3.1.1 Hotfix.


    7. Some Worlds Failing To Load in 1.3.1.1
    For a few players, some worlds have been failing to load in the 1.3.1.1 hotfix. These worlds were not corrupted, but would give a "Load Failed!" error after attempting to play them. The cause of this issue HAS been identified and fixed on our side, and I've personally verified on several of these worlds that they are now fully functional again, with no harm done to them.

    Is tentatively considered fixed as of the 1.3.2 Hotfix.


    8. Weather Status Failing To Change Server-side
    There is an issue with certain types of servers with some weather related issues. The root cause is that, while weather could still change while on servers (it could rain or stop raining, etc), the server was not properly receiving this message. The most obvious form this bug took was that weather-related mobs would have faulty spawning behavior. If the server was activated while there was no rain in the world file, no weather related mobs would EVER spawn, even if it was raining. If the server was activated while it was raining in the world file, weather related mobs would spawn constantly, even if it was not raining at the time.

    Is tentatively considered fixed as of the 1.3.2 Hotfix.
     
    Last edited: Aug 14, 2016
    SteveisNoob, CathodeCat and Mihn like this.
  2. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Okay guys, now that 1.3.1.1 is up, (if you haven't seen it, check it out here) I'd like to help make sure that some of the major issues are fixed on your end.

    First up on the list, the broken texture streak.
    @terrarien, @ASquishedFishPattyOnABun, @Choir, @JanusXLII, @TerraAssassin, you've all encountered #3 on the above list, the broken textures. After confirming that you've updated to 1.3.1.1, let me know here if the issue is still happening to you at all! This was NOT something we could replicate on our end, so its difficult to be sure our fixes for it definitely worked. :)

    Will continue to post as I gather relevant information and posters throughout the day.
     
    JanusXLII likes this.
  3. Choir

    Choir Pixel Pirate

    Hi,

    2. Water Physics Ceasing to Function
    It happened to me when I "moved" (breaked tiles containing) a lot of water, I thought it was because my computer wasn't powerfull enought. In previous versions, water instantly moved (a freeze during 1/2 seconds, then all water in the underworld or in the firsts cavities). Will need some tests in 1.3.1.1.

    3. Broken Texture Streak Against Background
    It happened to me only once, and when I launched the game for the 6th or 7th time in a row. Maybe this could help ? If I encounter the bug again, be sure you'll be aware of it. :p

    4. Cannot Rename Chests With Autopause On

    Strange. I always use autopause, and I can rename chest ... Well, I had to use the on-screen keyboard in 1.3.1.0, but now, in 1.3.1.1, it works perfectly with a more classic keyboard. (Except if the OP is out of date, well, in that case ...)
     
    Leinfors likes this.
  4. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    The OP is out of date, but only barely; 1.3.1.1 just came out an hour ago. But I'm watching to make sure the community is no longer getting the issues fixed in 1.3.1.1 before striking them from the list. Its good the Autopause/Renaming bug is working for you; this is one I personally confirmed myself, but I'm still willing to let it stand for a bit until the community has had time to respond! :D
     
  5. TerraAssassin

    TerraAssassin Skeletron Prime

    After updating to 1.3.1.1, I didn't find the broken texture streak across the background of any of the biomes and the title screen again, so I presume the update helped fix the error.
     
    Leinfors likes this.
  6. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Thanks for the info! Keep me posted too; if the issue doesn't show up again for a few days, then I'll be happy to pronounce it exterminated!
     
    TerraAssassin likes this.
  7. CathodeCat

    CathodeCat Terrarian

    Problem #1 is solved by v1.3.1.1. Thanks so much!
     
    Leinfors likes this.
  8. JanusXLII

    JanusXLII Terrarian

    After starting and restarting Terraria atleast three times since the update, I haven't seen the Broken Texture Streak. So, so far it seems to have fixed it. If it comes back though, where should I post this time? In the Bugs forum or Tech forum?
     
    Leinfors likes this.
  9. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Posting here would be fine, or in the original bug report you created for the issue. No need for a new report! :)
     
    JanusXLII likes this.
  10. JanusXLII

    JanusXLII Terrarian

    Last edited: Jun 4, 2016
  11. Catnose

    Catnose Terrarian

    So still more bugs? Are we going to need 1.3.1.2? I wouldn't mind if it deletes bugs...
     
    JanusXLII likes this.
  12. beng130

    beng130 Terrarian

    I had the issue with the texture streak across the background but the water in that area turned invisible with blue streaks. I added a screenshot when I saw it. Oh yeah and it also messed with the title but when I restarted once it went away.
     

    Attached Files:

    JanusXLII likes this.
  13. terrarien

    terrarien Terrarian

    I've met this same bug a few days ago, and i've met it right now (in both menu and the game). Version is 1.3.1.1.
     

    Attached Files:

  14. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Alright, so the visual background bug definitely still seems to be around, so that one is confirmed still alive.

    However, I've seen no reports of #1 (Can't click on launch) and #2 (Water physics failure), so we are tentatively considering them to be fixed. I'll move them to a closed section of the FAQ and take them off the immediate list!

    I've updated and reorganized the list, as well as adding a new entry.
     
  15. EoxBoy

    EoxBoy Terrarian

    Hello, I just experienced 1st graphics glitch, but it went away after I restarted the game.
     
  16. Terraria202

    Terraria202 Terrarian

    I have just started to encounter the color streek problem and I am in 1.3.1.1. The streek only appears when I am in the corruption or at night on title screen 1465832722966983420687.jpg
     

    Attached Files:

  17. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Alright, thanks for the info. :)
     
  18. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    I've updated the list with 2 new entries (now #7 and #8), and moved one resolved entry to the fixed tab (naming chests with autopause on).
     
  19. lade1rex

    lade1rex Terrarian

    I encountered the streak bug during startup, when it occured for the corruption on the title screen.

    [​IMG]


    Oddly, I also encountered an issue where the water would flicker, though I wasn't able to get a photo of it simply due to the way it was happening.
    The water would swap between being Solid to smaller cubes, to being simple dots to being completely invisible, letting me see the background and all creatures and objects within the water.
     
    Leinfors likes this.
  20. Legeoma

    Legeoma Terrarian

    So, will the "Phasesabers Break Weapon Racks" be fixed? Is there anything i can do for now to remove that? Cause i don't want to have that rack there... it will ruin the mood in the house. Plus, if you right click that bugged rack while you're close enough to it, your character freezes in place and the cosmetic items dissapear and you see only the armor and if you try to fly (if you have wings) it will show the wings flapping but your character is still frozen in place. Then if you stop right clicking, it goes back to normal.