FAQ for Common 1.3.1 Bugs: PLEASE READ BEFORE POSTING!

Discussion in 'PC Bug Reports' started by Leinfors, May 29, 2016.

  1. CathodeCat

    CathodeCat Terrarian

    Use TEdit.
    FYI: Weapon Rack Glitch
     
  2. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Its very hard to remove it via legitimate means. @Lazure and I spent a solid 20 minutes one day trying, and I think we FINALLY got it to stay gone on a server with the right combination of broken backwalls, placing blocks over top of the remnants of the old weapon rack, and other such schenanigans. Most of our efforts didn't work, and it had a tendency to revert. However, this crashed our game a few times, so I'd be very VERY careful trying to do this. Make backups of your world first!
     
    Jofairden likes this.
  3. ManaUser

    ManaUser The Destroyer

    I've just experienced the broken texture streak bug for the first time playing on a laptop I don't normally use. It only happens sometimes, and so far I've only seen it in the night/corrupt version of the title screen. So it's not really a concern for me, but Is there anything specific I can do, or info I can provide to help diagnose the problem?
     
  4. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    At this time, no. May contact you after 1.3.2 hits, but I have a few people on that list already, so I'll let you know. :)
     
  5. Vagrant

    Vagrant Terrarian

    I'm experiencing a variant of bug #5 while using the controller setup with Autopause On.

    i.e. : Say I pick up an Aglet(or any accessories). I open my inventory, move my selection box directly on the Aglet, close inventory... When I open my inventory again, the game will equip the Aglet without asking.

    I've run into this bug a few times, sometimes leaving me confused as to why I can't double jump or rocket boot anymore. Then I open my inventory and notice the swapped accessories.

    I think Autopause and Controller make a nice pair. I would get regularly wrecked if it wasn't for Autopause.
     
  6. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Interesting. I'll get back to you on that in the morning, I've got to retest it when I have some time. Thanks for keeping an eye out for recurrences! :)
     
  7. Vagrant

    Vagrant Terrarian

    Got some new info for you.

    I can reproduce this issue 100% now. It's very simple. The accessory swapping bug occurs when I open a chest while I have an accessory highlighted in my inventory. That's it.
     
  8. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    @ManaUser, have you see recurrence of the broken texture streak since 1.3.2 hit?

    @Vagrant, thank you for bringing this to light. The issue is not limited to accessories, but applied to armor, mounts, hooks . . . anything equippable. Very specific and difficult to replicate bug, but we've got it logged now thanks to you! :)
     
  9. ManaUser

    ManaUser The Destroyer

    So far no, but haven't played much on that laptop since the update. I'll let you know if I do.
     
    Leinfors likes this.
  10. Jofairden

    Jofairden Terrarian

    Hmm also interesting, I noticed the moon will flash weirdly similar to how the texture bands do, but in-game. For @Leinfors , when I had a mod of mine REPLACE cloud textures, the bug disappears. When the mod unloads (so vanilla textures again), the bug reappears.
     
    Leinfors likes this.
  11. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    The tricky thing is, the bug still doesn't happen to the majority of users.

    I'm not going to say (because I don't know) that the bug has nothing to do with faulty textures, but it raises the question of why it isn't showing up for ALL players. I've spent hundreds of hours in game between the development cycles of 1.3.1 (when the bug appeared) through now, and it doesn't happen to me.

    What that tells me is that there is some specific hardware/software trait (on the user side) that is triggering an issue or failure in the texture (on the game's side). Its not a game cache issue (the normal go-to cause for corrupt textures), but the textures themselves aren't corrupt either (or everyone would have it). The trick is isolating where the issue is happening, and in response to what user-side trait (whether it be a type of graphics card, drivers, or what).

    Its one of the biggest issues on my agenda, and I'm just waiting for the right time to pursue it further, as I need the time of more technically savvy individuals to track this down specifically.
     
  12. Jofairden

    Jofairden Terrarian

    Yup. It's tough. I know for sure something goes wrong, it wouldn't do it otherwise. My gtx 770 should easily have enough power :p But yeah, the clouds turn into the bands, again when I replace the clouds the bug disappears, so maybe it's worth noting the bug may come from just the clouds. I never really looked into the main menu's code, but maybe I should just to see if I can find the bug cause in there. I find it quite annoying as it happens a lot to me. Maybe worth asking people's pc specs from those whom report this bug? You might find a connection between hardware.
     
  13. Vagrant

    Vagrant Terrarian

    @Leinfors Dropping by to say, for the record, that the issue I mentioned above is now fixed in 1.3.2.1. That was fast. :D Thanks for the hard work.
     
    Leinfors likes this.
  14. ManaUser

    ManaUser The Destroyer

    So for what it's worth I got back on that laptop where I saw the streak bug earlier. I even restarted the game a few times since the title screen is where I saw it before, and so far so good. I have not seen the bug again since the update.
     
  15. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    You are very welcome, but we couldn't have done it without your helpful report! :D
     
  16. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    @Gorateron, could you provide a link to the mod in question? If its a private mod that you don't publish on the forums, would you consider PMing me about it?
     
  17. Vagrant

    Vagrant Terrarian

    *pulls out Bug Net to show bug"

    I'm sorry to disturb this thread again, but I'm afraid the Autopause Inventory swapping I reported previously is still there but with a twist.

    This time, it's not for chests... You guys fixed it last hotfix. It's when I read a Sign while there's an item highlighted in the inventory, just like it did with chests. I'm still using a controller too with Redigit's default setup.

    Found out about this while I was play-testing my own adventure map as I double-checked the signs for formatting error. :)
     
  18. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    @Vagrant, when you say reading a sign, do you mean you click the sign to open up the text window? Could you give more specific steps (step by step) from start to finish to indicate how to replicate the issue?
     
  19. Vagrant

    Vagrant Terrarian

    Yes, that's exactly what I meant.

    - Play with a controller with Autopause On
    - Get an extra accessory
    - Open inventory, highlight the extra accessory.
    - Close inventory
    - Walk up to a Sign, press B (Interact/Grapple). That's when it happens again.

    It's pretty much a replica of the previous glitch, except this time it's Signs instead of Chests.
     
  20. ManaUser

    ManaUser The Destroyer

    I don't have a compatible controller, so I can't test it myself. But how about other interactive objects? Dressers for instance (either storage or clothing color mode), or regular switches and such? How about NPCs?