FAQ for Common 1.3.1 Bugs: PLEASE READ BEFORE POSTING!

Discussion in 'PC Bug Reports' started by Leinfors, May 29, 2016.

  1. Vagrant

    Vagrant Terrarian

    I just tried all that. Good call because Dresser Color Mode does the same. Following the same method above, just replace Signs with Dresser Color Mode and your highlighted accessory will swap.

    All the others are ok (Dresser Storage, Switches, NPCs...)
     
  2. ManaUser

    ManaUser The Destroyer

    I suppose gravestones probably do it too (they seem functionally identical to signs)... I'm trying to think if anything else has a pop-up menu like that... Is trading with a merchant OK? Or how about the stylist's Hair Style service?
     
  3. Vagrant

    Vagrant Terrarian

    Tombstones : not ok. So now it's Signs/Tombstones/Dresser Color Swap. I imagine Announcement Boxes do it too, didn't check, but they are like Signs.
    Merchants: ok
    Stylist Hair Style: ok

    If you think of anything else, I can test it.
     
  4. EisaGaming

    EisaGaming Terrarian

    i don't download terraria 1.3.2 or 1.3.1 before the big bacon'crismon removed better 1.3.0.8 i have better
    --- Double Post Merged, Jul 30, 2016, Original Post Date: Jul 30, 2016 ---
    That a texture of blocks bug
     
  5. Vagrant

    Vagrant Terrarian

    Got something new for the Autopause item swapping bug. This one's pretty deep tho.

    - Use a controller with Autopause.
    - Put a Mount/Pet/Light/Grapple/Minecart in your 1st hotbar slot. (I have Drill Mount)
    - Open inventory, click the Grapple icon to see the optional accessories window.
    - Close inventory.
    - Now open any container or read any signs (just like above). Item from Hotbar 1 will swap with whatever is in the optional accessories window. (So, my Drill mount in hotbar 1 gets swapped with my equiped UFO mount.)

    The odds of me finding this were very slim, as you really need to have that item in Hotbar 1. Any other won't do it. That's because when you open a container/read a sign, highlighting box is always reset back to Hotbar 1 slot.
     
  6. DerpyProgrammer

    DerpyProgrammer Terrarian

    There is a Wall of Flesh bug in multiplayer that when you die by the Wall of Flesh, let it go to the other side of the map and nobody dies, exit the world and when you enter again on multiplayer and throw the Voodoo doll the Wall of Flesh does not spawn again. Please fix it soon, I can't enter on hardmode because of this
     
  7. ManaUser

    ManaUser The Destroyer

    Not offense, but I have to ask because I've made this mistake myself: I you sure the guide has respawned?
     
  8. DerpyProgrammer

    DerpyProgrammer Terrarian

    Yes, it respawned
     
  9. Jofairden

    Jofairden Terrarian

    Hmm is this still being updated? The Broken Texture Streak Against Background seems to have been fixed around august, according to Yoraiz0r (haven't experienced the bug myself either since that time, used to have it nearly always)
     
  10. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Actually, that's very useful data. While I've seen no new reports in the current, literally none of our team ever got that bug, so it was a frustrating one to "pronounce fixed". We have to rely entirely on user reports, but they seem to be pointing in the right direction.

    I'll probably update this list later today or this week. :)
     
  11. Jofairden

    Jofairden Terrarian

    Alright. Well, I'll just provide some evidence as well I guess, otherwise I could blatantly say stuff is fixed.
    [​IMG]
    I had this bug myself happend way too often and haven't seen it since around august =P
     
  12. Sigma90

    Sigma90 Brain of Cthulhu

    @Leinfors, maybe you could add the Living Flame dye bug to the list of known issues? It's reported quite often.
     
  13. Clavernever

    Clavernever Terrarian

    Please excuse me for not giving any of the required bug reporting feedback (like a screenshot), that's because when I experienced the bug I didn't think I'd have to post a report.
    So:
    About a day or two ago I got the water physics bug, it is still alive as of Terraria 1.3.4.
    I don't know how the common bug worked or looked, but I found mine was while digging a hellevator-like two blocks wide vertical shaft through a small body of water.
    Upon digging the bottom of the cave lake the water fell for about three-five blocks of the tunnel while gradually fading and remained that way. The issue repeated on multiple lake caves all the way down to hell and persisted after multiple deaths (haha difficult mode is indeed difficult, congrats devs), I'll check the world today to see if it's still there after restarting the game.
     
  14. squeaker_child

    squeaker_child Terrarian

    hey, so, I had this character that I worked really hard on and stuff. so, I was going somewhere and I paused the game. when I got back, I got the bluescreen error. but, when I had solved that, and opened terraria, my character was... gone. there was just a blank slot with the name but no stats or anything. (same with the world) Is this ever going to be fixed? also, today when I tried playing terraria everything was fine, until I tried to save and exit. nothing happened. It just closed the settings menu. also, If I try opening achievements, the same thing happens. thanks fer da help pls
     
  15. squeaker_child

    squeaker_child Terrarian

    dude, you do know you can take screenshots, right?
     
    diekonradish likes this.
  16. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    This is two issues, one of which is fixable through Terraria, the other is not.

    First, your corrupted character. While sometimes, character corruptions happen for no understandable reason (an issue we would like to be able to address better in the future), there are some well known causes of it that there is nothing we can do to prevent. One such cause is a power outage or PC crash while your data is saving. Any interruption during a saving process, in any program, has potential risks, and the same applies to Terraria. If your PC bluescreened on its own at a critical moment, then yes, that could have resulted in a corrupt save, and we can't prevent that. We may be able to develop a more robust backup system, but the initial corrupted file is not a fault of Terraria in this case, nor can we restore it after the fact.

    The issue with the controls likely means that, either accidentally or deliberately, your keybindings were changed in such a manner that they are now non-functional. The solution to this is pretty easy; simply delete your input profiles.json file. If you are on PC, you can find this by going to Documents>My Games>Terraria. Deleting the file will restore your controls to the default, and the next time you launch Terraria, it will create a fresh file with the newly reset keybindings.
     
  17. Hello! I found a bug using the weapon the Terrarian. When using these accessories: Betsy's Wings, Feral Claws, Mechanical Glove, Power Glove, Fire Gauntlet, and Celestial Stone, all with the Violent modifier, the Terrarian is uncontrollable, it whips around at extreme speed all around you in a fraction of a second and then goes back to you. However if you wedge it against a solid object it will create a catastrophic storm of the green orbs. I found this randomly, but I thought you guys might wanna know! :D
     

    Attached Files:

  18. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    I love that bug.

    And yes, its long since been reported. Extremely high melee speed increases breaks the functionality of a number of yoyos.
     
    Sigma90 likes this.
  19. TheTachanka27

    TheTachanka27 Terrarian

    bug.png bug 2.png idk if i can post it here, but... i think i might have found a bug.
    Basically, i standed at the very edge of an block and turns out i could place blocks on the block i was standing and i could walk trough that block.
     
  20. Hrangmund 7

    Hrangmund 7 Terrarian

    I am using meteor armor with negative dye and a few pixels on the helmet are not dyed. Capture 2017-05-22 18_39_43.png