• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

tModLoader Fargo's Mutant Mod: Summons and Souls

I get bored of games if I don't have a goal. The moment I found out it takes over 1000 crafting steps I was excited. Zero to hero to god lol.
IIRC, it's even a bit more than 1000 if you use Dragon Ball Terraria. Which I do. Which is awesome.

It makes finding everything even more fun than usual, because in the back of your mind, you know... what you picked up is probably a small piece of future godhood.
 

Fargowilta

The Destroyer
Hello, it's me again!

Reporting an issue which seems to have appeared apparently linked to the latest Thorium mod update, though the game states it's a problem with Fargo's mod. Basically, with (last updated) Thorium being used alongside Fargo's mod, the game won't be able to load Fargo's mod properly and will cause it to disable itself. This initially happened with my entire mod list active, so I took off all of my mods and tried only with Fargo's and Thorium active, and sure enough, it did the same thing.

I'm adding the client log. Please let me know if I should also/instead inform the Thorium team of this, in case the problem is on their end.

EDIT: As a side note, it's telling me Fargo's mod was made for an older version of tMod Loader, but I've been using it with 0.11.8 for like two months without issue, so I'm not sure what it's going on about there.
Just chiming in to say that I'm having the exact same problem as the above user, I had been using these mods together with no issues, but it seems like Thorium's update today broke being able to use it with any of the Fargo mods. Keep getting an error about the wrong version of TModLoader even though my TML verison didn't change. Only change was updating Thorium. It automatically disables all Fargo mods and won't let me load them. If I knew how to downgrade Thorium I'd just do that in the meantime because I can't play without my Fargo mods :(
Yeah I'm having the same problem as @ShadeTheSilent and @ExArch3r . I updated mods from the Mod Browser that needed it, Thorium included, and during the reload it gave me the same issue. Says that Fargo's mod needs v0.11.7.8 while I'm running v.0.11.8 and it had been playing just fine before I updated Thorium.

Here's a screenshot of that message:
View attachment 307574

EDIT: One of the moderators on the Fargo's Soul mod have acknowledged the issue and suggest disabling one of the mods or downgradingThorium until a hotfix can be released. Here's the link they left to downgrade Thorium if that's the option you choose. Release v1.6.3.13 · SamsonAllen13/ThoriumMod
Same problem as these 3 ^
This thorium issue should be fixed by tomorrow, or maybe in a few hours..
 

Domrinth

Terrarian
IIRC, it's even a bit more than 1000 if you use Dragon Ball Terraria. Which I do. Which is awesome.

It makes finding everything even more fun than usual, because in the back of your mind, you know... what you picked up is probably a small piece of future godhood.
I just realized that DBZ was one of the mods for cross content and I never even played it. Tons of fun honestly.
 

mirabilis

Terrarian
Hello. I'm playing with Thorium and Fargo's Souls with the DLC addon. I crafted the Cyber Punk enchantment for the special ability, but it doesn't seem to work. When I press the Thorium special ability key (I tried the default binding and custom bindings), it plays the sound from the ability but does not activate its effect. I originally thought this was a conflict with my current Maestro set, which also has a special ability, but taking it off results in the same behavior. Has anyone gotten this working in their game, or is it a bug in need of fixing?
 

ShadowTiger

Duke Fishron
just got on today and tried to play, though, the mutant mod works, the souls mod does not. every time I try and load it, it says it is incompatible.
Actually I think I'm having the same issue. The only major content mod I'm using is the Calamity mod, and I have three out of four of the Fargo related mods enabled and working, but the Souls mod (The one I really wanted to use, haha.) has been updated but requires another version of tModLoader. I think I'm using the official Terraria 1.3.5 tModLoader, not the 64 bit version that someone made. This time.
 

marter1000

Terrarian
So when I play eternity mode should it be disabling vein mine after save exiting?
I just cant use it in eternity mode and im not sure what's going on.
 
Im having a bit of a problem. So apparently whenever I equip the bionomic cluster, I get that weird camera effect you get when you hold the rifle scope. Idk how to fix it, and I cant toggle it off because I am using controllers instead of a keyboard.
 

Kreeto

Terrarian
I'm not sure if its a compatability issue or a bug but I can't dual wield ranged weapons when I use the sniper's soul unless I'm missing something? (I meant to say that instead of using the second weapon it just scopes and no longer shoots with the second weapon)
 
Last edited:

xDragonWarrior09

Official Terrarian
Hey, I'm not sure if this is a bug or not, but The Crucible of the Cosmos and Elemental Assembler does not have the chance to not consume ingredients as the Alchemy Table has.
 

Ghast

Terrarian
I'm having some sort of issue with the wall of flesh in eternity, it seems that the Divine Rays that the eyes shoot always aim directly at me with no hope of me dodging, even if I use advanced movements like tdbz flight and such, what am I doing wrong?
 

Koros

Terrarian
Incompatibility with Thorium and Fargos souls DLC is breaking piercing.
All my Piercing projectiles despawn when hitting the first target.
Melee weapons deal damage per frame not per swing.
 

Themius

Terrarian
I am running into the issue where any of the enchantments/souls that has the Lich Enchantment as a resource, including the Lich Enchantment, will cause my character freeze. I have already confirmed the items that make the enchantment do not cause this issue and that my Thorium version matches what is on the Thorium wiki. Ideas?
 
Top Bottom