Mobile Fishing issues!?

Discussion in 'Mobile Bug Reports' started by I’m Confused (eternally), Jul 11, 2018.

  1. I have 2 issues with my fishing on mobile:
    1. I usually cannot fish. I have bait, large bodies of water, and several rods but I cannot get it to work. I have tried tapping, swiping, flicking and the like but still no luck. It usually just triggers my web slinger (I have tried it without this in inventory) and I am standing close to the water, but not in it. I can’t get crates or complete quests!

    2. My sword has taken on the characteristics of a fishing rod (40% fishing power). I don’t know if I can fish with it because I cannot fish, but it has bait displayed in on the sprite and says the fishing stuff in the description. I cannot use it to fight. I have a few pictures showing 3DB30291-2ADF-49D4-B8BA-0B817BC492B0.jpeg 2A249109-A12D-4E5A-8FF1-0479205ECD5D.png 5C65E5D6-5193-439B-ACD9-66CF394BCA17.jpeg 1st image = trying to swing sword
    2nd = info in inventory (requires bait to fish??!!)
    3rd = number of bait available (I have some in my inventory.)

    Also, if you fish a crate in pre hardmode and open it hardmode, does it give you hardmode ores? Just wondering.
     
  2. Tetegre

    Tetegre Terrarian

    About the Fishing:
    When you tried to fish, did you tap the air above the water or the water itself? Tapping the water should trigger the fishing rod.
    Try sending screenshots os your bodies of water.
    About your Night's Edge:
    Try dropping it and pick it up again.
    I had that problem many times and sometimes some items also turned into bait but dropping and picking the item up again usually fixed it.
    Sometimes using the item that got a fishing pole turned it into a firefly and set it free, so trying to use it is not recommended.
    Please tell me, if it worked or not.
    Also, opening crates which were fished in Pre-Hardmode in Hardmode will have a chance of giving you Hardmode ores upon opening.
     
    Last edited: Jul 12, 2018
  3. It’s not an issue with the Bodies of water. The ocean doesn’t work. Even if I stand on the ocean with water walking boots. I am also tapping the water, not the air. Fishing does occasionally work, but very rarely. When it does I can use the rod just fine by tapping the way i Normally do.
     
  4. Tetegre

    Tetegre Terrarian

    Hmm... That's weird. If I understand right, it only has a chance of working, you did not do anything before it worked.
    What about the sword? Did it turn normal again?
    Also: Did you bother contacting the 505games support before? Maybe they can help you more than I can do here (as no one else replied to your problem).
     
  5. Unit One

    Unit One Moderator Staff Member Moderator

    Hi there @I’m Confused (eternally), welcome to the forums.

    For your fishing issue, what works for me on the iPad/iPhone: with the fishing rod selected, tap NOT in water and drag INTO water. But another member, TerraNova, says that what works for him is to tap IN water. See what works best for you.

    For your weapon having fishing power, it looks like you accidentally triggered the bait/critters glitch.

    Be careful when you are swapping items in your inventory. Always try to move an item to an empty spot in your inventory. If you need to move something to your hotbar, move the hotbar item to an empty spot, then move whatever you need to that empty hotbar spot.

    That is also how items like your weapon can display that they suddenly have fishing power, if you swap them with a fishing pole in the inventory.

    This is a generic reproduction, it can also happen with other bait/fishing poles/tools/weapons/critters:
    • In your inventory, swap your bait with your pickaxe
    • Save and exit
    • Open the same character (doesn't matter what world you go into). You'll notice that your pickaxe now displays a "bait power"
    • In your inventory, swap the bait and pickaxe back
    • Save and exit
    • Open the same character (world doesn't matter)
    • At this point with some tools or weapons, if you try to use it (swing it) the tool/weapon will be consumed, disappear, and the bait will fall on the ground. Not all combinations consume the tools/weapon.

    How to get the "bait power" or "fishing power" OFF of an item that shouldn't have it:
    • Move the item to an empty space in your inventory
    • Save and exit
    • When you open that character again, it should be fine.
    • If it’s not, then put the item in a chest, close the chest, then open it and get your item again.

    A fun one to try:
    • In your inventory, swap a critter with a stack of blocks
    • Save and exit
    • Open the character
    • Swap the critter and blocks back
    • Save and exit
    • Open the character
    • Try to use the blocks in the air and you'll get critters falling
    • [​IMG] Click to enlarge

    To avoid these glitches, don't swap anything with bait, fishing poles, or critters. Move your weapons and tools to empty spots in your inventory.