• PC NEWS: 1.4.2.3 update is out! More info here. Report bugs here
  • CONSOLE 1.4 LAUNCHES SEP 30: The official launch date for Journey's End to arrive on Xbox and PlayStation is September 30th! Click here for more info. The plan is to have the update on Switch out later this year. Stay up to date with console news here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

Mac Frame rate issues on macOS: bestiary, mannequins and some armor sets

nightintunisia

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Single
Operating System
Mac Other
Terraria Version
1.4.0.4
Controls Used
Keyboard/Mouse
I know macOS and Linux aren't fully supported right now, but I've had some frame rate issues that other Mac users might have come across, so I thought I'd share this.

First of all, I'm running the game on a 13-inch 2019 MacBook Pro. I'll include full specs at the end of this post. I use the following settings within the game: low quality, trippy lighting, frame skipping: on, resolution 1650x1050. The game usually runs fine, at 60 FPS most of the time, with the occasional drop to 50-55 when I'm underground in an area with lots of torches.

Here are the issues I've encountered so far:

• Whenever I try to open the bestiary, I get severe frame rate issues (it instantly drops from 60 to about about 12 FPS, and it remains like that for as long as I have the bestiary open). This happens on both new and old (pre-1.4) worlds.

• Mannequins cause frame rate issues, too. If I have three or four mannequins on the screen, I get around 20 FPS (compared to 60 FPS when there are no mannequins around).

• Armor sets with visual effects are practically unusable right now, unless I wear something different in my vanity slots (to disable the visual effects of the set itself). Wearing a full set of nebula armor, for example, causes the game to run at 10 FPS. Same goes for solar flare armor and many others. When I wear a familiar wig as a vanity item, however, the visual effect goes away and the game runs fine.

From my experience, if you're running 1.4 on a 2019 MacBook Pro, you should avoid placing mannequins and wearing any armor sets that trigger some sort of visual effect (try wearing vanity items to disable the effects).

Full specs:
macOS Catalina (10.15.5)
1,4 GHz Quad-Core Intel Core i5
16GB RAM
Intel Iris Plus Graphics 645 1536 MB
 

Pedrorc94

Terrarian
Had the same issue with the Bestiary, Can't tell about the other ones. Did you have any Frame rate drop when the Slime Rain event occured?

Thanks!
 

Pedrorc94

Terrarian
You know, I just realize about the armor effects and its true. Effects does cause frame drops. I removed the Adamantite armor and the frame rate were normal again. Will try the vanity item slot.

Thanks!
 

nightintunisia

Terrarian
You know, I just realize about the armor effects and its true. Effects does cause frame drops. I removed the Adamantite armor and the frame rate were normal again. Will try the vanity item slot.

Thanks!

Wearing at least one item in the vanity slots (familiar wig, for example) definitely helps.

About the Slime Rain: haven't had any problems so far, frame rate remains close to 60 FPS for the duration of the event.
 
Top Bottom