• PC 1.4.3: An eye for an eye, the Terraria x Don't Starve Together Crossover Update! Get all the details here. Found some bugs? Report them with as much detail as possible here.
  • Xbox & PS 1.4: Get all the info on the Journey's End update by clicking here. Known Issues and FAQ can be read here. For any other bugs, report them (with as much detail as possible) here.
  • Switch 1.4: Journey's End will launch on Switch January 4, 2022! More details here.
  • Mobile News: Stay up to date with the latest mobile news here. Report mobile bugs here

Tool Game Launcher 3.2.1.5

Status
Not open for further replies.

BON JOVI

Terrarian
when i've downloaded game launcher, then downgrade my patch, and then pressed "Launch"... nothing happens. Can somebody tell me why? And how to fix?
 
i'm wondering, should this thread even be kept at the top of the forums? it no longer works in the desired way, downgrade cannot downgrade, and it isn't needed for any current mods (standalones can be easily played without the launcher, since they come with their own .exe launch application).
Also, Eikestar put in the OP "for terraria 1.3+" it is apparent that it is not fully compatible with 1.3+ as it requires the user to almost always frequenly try and get it to actually install, not to mention that most of the time it doesn't even recognize 1.3 as a valid terraria assembly.

EDIT: Also worth noting is that it is almost certainly discontinued, seeing as it has been over a year since it last got a patch.
 
Last edited:

panzerfaust

Terrarian
This worked for me after ages, just to prove you were helpful i made this account to say thank you :3
so im assuming this only works for version 1.2.4.1?
[doublepost=1465185075,1465184966][/doublepost]
when i've downloaded game launcher, then downgrade my patch, and then pressed "Launch"... nothing happens. Can somebody tell me why? And how to fix?
The downgrade feature does not work as of right now (Sadly:sigh:) I think they are working on this for 1.3, but idk.
 
so im assuming this only works for version 1.2.4.1?
[doublepost=1465185075,1465184966][/doublepost]
The downgrade feature does not work as of right now (Sadly:sigh:) I think they are working on this for 1.3, but idk.
actually, it seems they are not working on this at all, the last update was long before 1.3 even released.
 
Such a shame. I was really looking forward to using some old mods.
[doublepost=1465189219,1465188984][/doublepost]for anyone who wants to just play old versions without mods or anything, here's a link to a site with downloads for some of the versions for terraria (although many links are missing) ------------ > <---------------
i would highly recommend you remove the link, as posting links to illegitimate copies of the game is both against the rules and illegal, just a heads up for you.
 
Last edited:

panzerfaust

Terrarian
i would highly recommend you remove the link, as posting links to illegitimate copies of the game is both against the rules and illegal, just a heads up for you.
Is it? Thank you very much for informing me. Is it illegal for all versions, or just Current versions. Like a link for 1.3.1 would be illegal while a download for 1.2.4.1 would not
 

Dude

Skeletron Prime
As the official Terraria forum, it is forbidden to speak of pirating the game.
Do you have a time to re-do the installer for a GoG release? here is a img of GoG files should look: (ignore those red ones, my terraria is pirated one ~;( )

<Image Removed by Staff>
 
Last edited by a moderator:
Do you have a time to re-do the installer for a GoG release? here is a img of GoG files should look: (ignore those red ones, my terraria is pirated one ~;( )
well first. talking about a pirated version isnt allowed, second, this launcher is most likely discontinued, and third, even if here was a GoG version, you would not be able to use it as pirated versions are far different from the GoG version.
 

Willexwun

Terrarian
Listen. All I really want is to play Omnir's Nostalgia on mac, and If I need to make my own version of GL then I will. Unless someone will make a TMod version.
 

panzerfaust

Terrarian
Listen. All I really want is to play Omnir's Nostalgia on mac, and If I need to make my own version of GL then I will. Unless someone will make a TMod version.
Same here. I'd do anything to play those old mods. I have been browsing through the mod forums recently but sadly no alternate mods to GL :sigh:. Hopefully soon though.
 
Same here. I'd do anything to play those old mods. I have been browsing through the mod forums recently but sadly no alternate mods to GL :sigh:. Hopefully soon though.
the only problem with it is that its not easy to allow using old versions due to copyright and legal stuff, so unless the dev for this returns from the dead, its unlikely there will ever be a downgrade mod.
 
Status
Not open for further replies.
Top Bottom