• PC 1.4.3: An eye for an eye, the Terraria x Don't Starve Together Crossover Update! Get all the details here. Found some bugs? Report them with as much detail as possible here.
  • Xbox & PS 1.4: NEW PATCH released Dec 7 - read the details here. Get all the info on the Journey's End update by clicking here. Known Issues and FAQ can be read here. For any other bugs, report them (with as much detail as possible) here.
  • Switch 1.4: Journey's End will launch on Switch January 4, 2022! More details here.
  • Mobile News: Stay up to date with the latest mobile news here. Report mobile bugs here

Having problems with loading worlds with different difficulties

josujosu12

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Both
Operating System
Windows 10
Terraria Version
1.4.3.2
Controls Used
Keyboard/Mouse
So I am able to load any world, any size, but the moment I attempt to load a world that's not on journey difficulty it doesn't let me do anything, please help i have no idea what to do. I already tried unistalling and reinstalling 3 times, and verifying game integrity.
 

Sigma90

Brain of Cthulhu
Welcome to the forums josujosu12!
Journey characters can only load Journey worlds. And classic / mediumcore / hardcore characters can only load Normal, Expert and Master worlds. It sounds like you might be mixing them up and using a Journey character to load a non-Journey world?
 
Last edited:

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Could you clarify the issue? "doesn't let me do anything" . . . what does this mean precisely?

Is it stuck on the world loading screen? Does it load into the game, but you are frozen? Does the menu fail to let you open them at all?

Have you tried making a brand new world that is not Journey, or does this only apply to old worlds? Sigma's scenario is also a good question too.
 
Top Bottom