• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

Host & Play: System.NullReferenceException

smok3

Official Terrarian
Hey all,

Been using 1.4's Host & Play on Steam for weeks and not had any issues. However ever since a few days ago, I decided to install TModLoader via Steam out of curiosity. Somewhere somehow, that had messed up the vanilla game and resulted in a broken "Host & Play" for my vanilla Terraria experience. Launching the servers via the .bat files still works, however the main Terraria.exe's Host & Play will always result in this null ref error (Single player still work too). I had done a full reinstall including full wipe of saved data in "My Saved Games" multiple times to no avail. TModLoader had been uninstalled as well. Had seen a few threads of people having these issues but there are no solutions apart from just "oh problem solved" with no solutions given. Anyone knows what went wrong and how could I solve it?

Attached below is the crash log.
System.NullReferenceException: Object reference not set to an instance of an object.
at Terraria.Main.DedServ()
at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)


Solutions tried,
  1. config.json file wiped
  2. Full wipe & Clean Installation (Reboot every uninstall & installation)
  3. New world & character creation
 
Last edited:

AlphaBits

Terrarian
I've had the same issue without any mods. Troubleshooting guides on the forums do not have anything for System.NullReferenceException troubleshooting. It seems this issue may be exclusive to the Steam version of Terraria?

I've attempted all the same solutions and wanted to post here to bump this issue up. So far no one has presented a solution and I have received no response on any requests for support.

The issue seems to lie deeper in Terraria than I expected...
 

Sheny77

Terrarian
Oigan todos,

He estado usando Host & Play de 1.4 en Steam durante semanas y no he tenido ningún problema. Sin embargo, desde hace unos días, decidí instalar TModLoader a través de Steam por curiosidad. De alguna manera, eso había estropeado el juego de vainilla y resultó en un "Host & Play" roto para mi experiencia de vainilla Terraria. El lanzamiento de los servidores a través de los archivos .bat todavía funciona, sin embargo, el Host & Play principal de Terraria.exe siempre dará como resultado este error de referencia nula (un solo jugador también funciona). Hice una reinstalación completa, incluida la eliminación completa de los datos guardados en "Mis juegos guardados" varias veces sin éxito. TModLoader también se había desinstalado. Había visto algunos hilos de personas que tenían estos problemas,

A continuación se adjunta el registro de fallos.
System.NullReferenceException: referencia de objeto no establecido en una instancia de un objeto.
en Terraria.Main.DedServ ()
es Terraria.Program.LaunchGame (String [] args, boolean monoArgs)


Soluciones probadas,
  1. archivo config.json borrado
  2. Instalación completa de borrado y limpieza (reinicie cada desinstalación e instalación)
  3. Nuevo mundo y creación de personajes
Hola me llamo la atención tu comentario ya que si también me está dando el mismo error en mi juego cuando se cargó el juego el mundo que había creado desapareció me indicaba "mundo desconocido error" entonces cree otro mundo pero haber cuánto tarda en volver a aparecer el mismo problema Y no juego en Steam lo tengo solo descargado por otros medios
 

Attachments

  • IMG_20210319_010614596.jpg
    IMG_20210319_010614596.jpg
    5.6 MB · Views: 53
Top Bottom