• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

PC Is it normal to get 30 fps with this specifics ?

hello thanks in advance so i am getting a medium of 30 fps on large worlds (somewhy 50-45 on small worlds which i dont use) while my friend having almost the same specifics is getting 60 fps even when using a super modpack here are both our specifics (there is a slight difference):
intel pentium quad core 1.6 GHz(total speed is 2.56 ghz) 4 gb ram and intel hd graphics 64 bit windows 10 laptop
intel i3 one core total speed 2.56 ghz 4gb ram intel hd graphics 64 bit windows 10 desktop
please help thanks for reading again :)
 

Grumpy Squid

Duke Fishron
I'll need to know a bit more about your system specifications and theirs in order to address the discrepancies in frame rate. I'd like you and your friend to do the following and get me two screenshots each:

  • Press Windws+R on your keyboard.
  • type "msinfo32" without the quotes and press enter.
  • Take a screenshot of the main window so that it can be uploaded it here.
  • Then click the plus button next to "components" on the left hand side.
  • Then click on "Display" take a screenshot of this window as well.
  • Upload all 4 screenshots (2 from you, 2 from your friend) here.
  • If you can not get your friend to get you these screenshots I should still be able to troubleshoot your issue with just the two screenshots from you just fine.
 
I'll need to know a bit more about your system specifications and theirs in order to address the discrepancies in frame rate. I'd like you and your friend to do the following and get me two screenshots each:

  • Press Windws+R on your keyboard.
  • type "msinfo32" without the quotes and press enter.
  • Take a screenshot of the main window so that it can be uploaded it here.
  • Then click the plus button next to "components" on the left hand side.
  • Then click on "Display" take a screenshot of this window as well.
  • Upload all 4 screenshots (2 from you, 2 from your friend) here.
  • If you can not get your friend to get you these screenshots I should still be able to troubleshoot your issue with just the two screenshots from you just fine.
Thanks for fast respond i cant upload any file because when i try to i get an error "You do not have permission to view this page or preform this action" please help me :(
EDIT : i have some news i let task manager open while playing and CPU was 100-90% even that terraria is only using 50% which i find weird and GPU 50-60% (terraria is using almost all the 50-60% of GPU) and ram 1.3 GB ram is used by terraria and one other thing on my phone terraria 1.2 latest version is running always 60 fps even that my phone has only 2 gb ram and octacore 1.2 ghz CPU can you please explain these to me ?
 
Last edited:

Grumpy Squid

Duke Fishron
It's a bug on the forums that the staff is looking into now. For now you should still be able to upload the image to an image sharing site like imgur and then link the picture here using the insert image button or just giving me the link.

As for your question, I'm not sure what exactly your question is. Though I will try to clarify the best I can. Terraria is far more CPU intensive than GPU intensive, it cold be your CPU is bottle necking your GPU from using any more resources than it can. An application will use as much RAM as it needs to (up to 4GB if it's a 32 bit application, which, Terraria is) so if it isn't using more, than at the moment it doesn't need more. RAM won't have a factor in how fast the game runs.

As for Terraria's mobile counterpart, it is an entirely different engine with different assets running on entirely different architecture and micro-architecture. Attempting to compare the two will end up seeming like trying to compare apples to oranges.

I will be able to make more clear the issue, when I have the screenshots with the information I need.
 
i got a good idea i exported it then copied and pasted the main page and the display page here they are :
OS Name Microsoft Windows 10 Pro
Version 10.0.17134 Build 17134
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name YOUSSEFPC
System Manufacturer HP
System Model HP Notebook
System Type x64-based PC
System SKU Y0W38EA#BH4
Processor Intel(R) Pentium(R) CPU N3710 @ 1.60GHz, 1601 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date Insyde F.21, 10/27/2016
SMBIOS Version 2.8
Embedded Controller Version 64.40
BIOS Mode UEFI
BaseBoard Manufacturer HP
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Mobile
Secure Boot State Off
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = "10.0.17134.1"
User Name YOUSSEFPC\Youssef
Time Zone W. Central Africa Standard Time
Installed Physical Memory (RAM) 4.00 GB
Total Physical Memory 3.85 GB
Available Physical Memory 1.56 GB
Total Virtual Memory 9.83 GB
Available Virtual Memory 7.42 GB
Page File Space 5.98 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware No
Hyper-V - Data Execution Protection Yes
Name Intel(R) HD Graphics
PNP Device ID PCI\VEN_8086&DEV_22B1&SUBSYS_81F1103C&REV_35\3&11583659&0&10
Adapter Type Intel(R) HD Graphics, Intel Corporation compatible
Adapter Description Intel(R) HD Graphics
Adapter RAM 1.00 GB (1,073,741,824 bytes)
Installed Drivers igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igd12umd64.dll
Driver Version 20.19.15.4963
INF File oem15.inf (iCHVM_w10 section)
Color Planes Not Available
Color Table Entries 4294967296
Resolution 1366 x 768 x 59 hertz
Bits/Pixel 32
Memory Address 0x90000000-0x90FFFFFF
Memory Address 0x80000000-0x8FFFFFFF
I/O Port 0x00003000-0x0000303F
IRQ Channel IRQ 4294967292
I/O Port 0x000003B0-0x000003BB
I/O Port 0x000003C0-0x000003DF
Memory Address 0xA0000-0xBFFFF
Driver c:\windows\system32\drivers\igdkmd64lp.sys (20.19.15.4963, 7.06 MB (7,399,896 bytes), 5/3/2018 5:07 PM)
 

Grumpy Squid

Duke Fishron
Alright so, the framerate you mentioned in the original post is about what I would expect your specifications to get. It's also similar to what other people running your setup get.

The only thing I'd be able to recommend is to play on a small world.

The reason why your friend might get more could be because his cpu is on a more efficient microarchitecture. Though In general pentiums are very slow compared to the I3 line. Even the oldest I3 running Intel Hd graphics (Clarkdale I3-530) runs 50%-125% faster than your CPU.

But in summary, yes, that is the framerate you could expect to get on your Cpu and iGpu. Sorry.
 
Last edited:
Alright so, the framerate you mentioned in the original post is about what I would expect your specifications to get. It's also similar to what other people running your setup get.

The only thing I'd be able to recommend is to play on a small world.

The reason why your friend might get more could be because his cpu is on a more efficient microarchitecture. Though In general pentiums are very slow compared to the I3 line. Even the oldest I3 running Intel Hd graphics (Clarkdale I3-530) runs 50%-125% faster than your CPU.

But in summary, yes, that is the framerate you could expect to get on your Cpu and iGpu. Sorry.
alright i'll try to upgrade my pc thanks for the support
 
Top Bottom