• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

**REPORTED** Keyboard Unresponsive

Broken Pixel

Official Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Single
Operating System
Windows 10
Terraria Version
1.4.0.3
Controls Used
Keyboard/Mouse
Keyboard is unresponsive in-game. Holding the space-bar and then trying to move sometimes works. Restarting laptop fixes issue for just that play session.
Keyboard input does work at the main menu when building a character or setting up bindings.

Playing with an Alienware 15 R3 laptop using a Logitech G610 keyboard.
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
We are looking into this issue, its very difficult to reproduce for anyone who doesn't have it, and since the programmers don't have it, its a lot of guesswork. We are investigating further. :)
 

Broken Pixel

Official Terrarian
The issue does appear to be cropping up more and more from just the googling I've done. It's unfortunate the game is unplayable on PC for me, but I'll make do with other ports for the time being. Good luck working the bugs out. Love the game.
 

Nanjo

Terrarian
I have the same problem. Mouse work fine, but my kewyboard dont work. I can't move, jump, or open the inventory, except if i push the key that i want to use and at the same time tab.
My keyboard works fine out of terraria. I tried un-install and install, and dont work.
I need to fix this issue, i want to play with my friends.
 

Mr. Hotdog

Terrarian
I have the same problem. Mouse work fine, but my kewyboard dont work. I can't move, jump, or open the inventory, except if i push the key that i want to use and at the same time tab.
My keyboard works fine out of terraria. I tried un-install and install, and dont work.
I need to fix this issue, i want to play with my friends.
I had the same issue, and this fixed it for me:
-Open the game folder and find Terraria.exe
-Right click, properties, compatibility tab
-Check 'Run this program as an administrator'
-Restart your PC

Hope this helps.
 

Nomadic

Terrarian
We are looking into this issue, its very difficult to reproduce for anyone who doesn't have it, and since the programmers don't have it, its a lot of guesswork. We are investigating further. :)
As someone else who's been having this bug intermittently, it's occurred twice for me in the middle of the game when I left Terraria autopaused on the menu screen in the background for a longish period (maybe 10-15 minutes?) while I was doing other things in my browser, and then found on returning to the window to continue playing that I could no longer use the keyboard. So that might be something to look into for potentially reproducing it. (This is the GOG version in windowed mode, with a pretty standard Microsoft 600 wired keyboard.) It's only happened with those longer periods on pause, I can do stuff in other windows briefly without any problems returning to the game.

It's also happened a couple of times immediately on launching the game as well; not sure if that potentially also could be connected to going to another window while I leave Terraria in the background to finish loading. It's too intermittent to be sure, but so far making a point of minimising all other windows before launching Terraria and then not touching anything until the loading has finished and the menu comes up has seemed to help avoid experiencing the bug on launch.
 

Mschol

Steampunker
have the same issue
deleting config.json or adjust terraria.exe to run as administrator doesnt work for me..
reboot solution is/seems temporary
using a corsair K95 platinum on windows 10 pro build 1903

initialy i had the problem only sometimes after alt-tabbing or getting the window out of focus
now everytime i start it just doesnt respond (but rapidly pressing A and D in sucession does minimaly move the character (at least the moving animation starts, i dont think its really moving)
 
Last edited:

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
We have ONE tester who is able to reproduce this (by alt+tabbing out multiple times), and that is our current lead. Its definitely related to something unique to certain PCs, as the entire rest of our team has never once gotten this issue.

So we're just going to have to keep looking.

As an aside, apart from @Nomadic, are the rest of you using GOG version?
 

Mschol

Steampunker
I'm using the steam version of the game; (disabeling steam overlay doesnt make a difference)
i dont also have the game on gog, otherwise i would test that one too
if there is anything we/i can do to assist in finding leads, please do tell :)
i'm running the game in a window (fullscreen on 3x 1440p is a bit overkill)

noticed the following: just pressing A or D doesnt work, pressing them in rapid succession results in walking to the right barely (a step at a time)
but holding down A and just pressing ESC or TAB (and releasing again) => walks left, same works for right, with D pressed
 
Last edited:

Nomadic

Terrarian
Not sure what else if anything might be significant system-wise, but I'm on Windows 10 Pro version 1903, the system language is UK English and the keyboard is also UK layout, and I have Avast antivirus running. My Terraria is running in an 800x600 window with borderless window disabled.
 

Broken Pixel

Official Terrarian
To clarify my setup. Game is set as borderless window. I am using dual monitors. So for instance game on one monitor, YouTube the other. I don't know if maybe dual monitors might be a factor. I don't alt tab between windows at all and the issue occurs everytime I load the game. Again a system reboot fixes the issue, however for only that play session. I never encountered this issue before Journeys End update.
 

PogoTer

Terrarian
I have just run into this problem, I'm also on Steam version, Windows 10.

As someone up thread mentioned, this occurred for me when I had loaded the game but alt+tabbed to another window to finish watching a YouTube video, I'd say about 10 minutes, before loading into the world.

*POSSIBLE FIX*
Looking at another forum with this reported issue, this series of steps fixed it for me:

Press CTRL+ALT+DEL and select Task Manager to open the Task Manager window
ALT+TAB back into Terraria
 
Last edited:

ShadowOfDarkness

Duke Fishron
@Leinfors It appears I have just now caught the problem. I did activate Xbox Game Bar (I knew I shouldn't have..) and now my controls are all broken like everyone else. Getting Task Manager to super-kill Xbox Game Bar doesn't seem to help, nor does re-mapping every control in-game. Restarting the game doesn't fix it either.

I'm Windows 10, Steam version, 1.4.0.4.

EDIT: However, I logged off my computer's user, relogged into Steam (and Discord) and launched Terraria and now it's fine. I didn't even fully restart the computer, as I was doing something on another user on this computer and didn't want to log out of it, so I simply tried a log-out and that was fine.

As a general rule I try to keep as little running on my computer as possible. Whatever keeps my Windows 10 running, Discord, Steam, DropBox, possibly Firefox (my favorite browser) and that's about it. I do sometimes use the Xbox Game Bar for recording things, which seemed to cause the issue this time... but if you remember I just recently made a post about the favourited item slots and I had a video... that video came from the Xbox Game Bar.
 
Last edited:

Lunatic Lobbyist

The Destroyer
This is a very odd bug, considering I've never encountered this myself (nor heard of this bug) before 1.4's launch. But now it's happening frequently and somewhat consistently as well, up to 1.4.0.4.

The only pattern I can identify is: This only occurs after I've opened Terraria previously while running the PC after awhile. After the 3rd-5th time opening Terraria and working perfectly, upon the following session suddenly no inputs function in-game properly, if at all. Restarting the PC of course solves the problem temporarily, until the next cycle above repeats. Alt+tabbing is something I occasionally do while in-game, but not often. I can say if I've ever alt-tabbed while in Terraria 1.4, it wasn't until a couple sessions later that I ran into this bug.

Needless to say it renders Terraria 100% unplayable once it strikes, and makes testing fan-made content I make and for others a lot more time-consuming. I haven't personally encountered anything like this before in other games or applications using Windows 10. While I see people online (including devs) saying it's not happening to them, I'm curious if many of them simply haven't re-opened Terraria enough times for it to occur.

I'm also posting this at this time to confirm this bug is also happening with my friends and family (4 people on 4 different PCs), who comprise of all the people I know personally playing 1.4. Their experiences with this bug appear to be identical to my own. So at least in my small circle, this bug has a 100% appearance rate.


Much luck in sorting it out.



*POSSIBLE FIX*
Looking at another forum with this reported issue, this series of steps fixed it for me:

Press CTRL+ALT+DEL and select Task Manager to open the Task Manager window
ALT+TAB back into Terraria
I tried this, and it works!! :happy:

EVERYONE experiencing this bug should try this out. Better yet -- not only after doing this did the inputs perfectly function again, but the following time I opened Terraria, it was STILL fixed! I was afraid it would revert to the bug in the following play session, but it was still working!

Thanks a ton for this, as this fix is a LOT less time-consuming than restarting the entire system just to play Terraria. In the meantime before this bug is fixed officially, this incredibly helpful temporary fix deserves to be stickied/featured somewhere.
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Thanks for that followup workaround, I have a thread around here somewhere with a user who is trying to avoid resetting their PC due to technical concerns, that might be useful for them!

We are still investigating this issue, we have a general idea of what the cause is, but the source of it is rather difficult to isolate.

In essence, Terraria is launching with a specific, unknown key input constantly being sent to the game by some external source (either a keyboard/peripheral, or a program, or something like that). This input is what is leading to the issues, and the problem is finding a way of either blocking it, or making it not impact the functionality in Terraria.

Its definitely not 100% on our end. 0% of the dev team has ever experienced it, and of our tester team, less than 10% have encountered it once, and of those, only 2 had encountered it before launch (and because they couldn't reproduce it reliably, we couldn't follow up, as it only impacts them once every few weeks). None of our testers ever had this issue hit them reliably.

Suffice to say, we have a tester who can force it to happen now with the proper steps, the issue is just going to be trying to trace the stray input back to its source and figure out what is sending it. Easier said than done, since its being detected as an unknown input on Terraria's end.
 
Top Bottom