• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Lanboost's mods (Unlimited Buff limit, 4+Quality of life, Auto Buff etc) sources included!

Angel 4

Terrarian
Alright, so... a few things here. I really dig the mods, me and a buddy saw one and instantly thought "sweet, a LuiAFK replacement!". Sadly, certain parts don't work for whatever reason (like Calamity Zerg Buff in your buff list. BOTH of them. Because your buff list adds each mods buffs to its own line and then your mod adds Calamity buffs as well that make the Calamity buff line entirely useless save the... 3(?) that aren't in your line). Alternatively, is there any way to either condense or hide the mods to not cause a chunk of the screen to be covered by the buffs?

There's also a different issue on the buff list side of things, and I am unsure what caused it after updating you last time. When we first started using your mod, it had a huge buff list page that could fit on screen after I moved it. After updating, the list is much smaller and cannot be moved for whatever reason. Alternatively, it is no longer calibrated properly to where the mouse cursor is in relation to the activate/deactivate buttons you have on the list. I am unsure what caused this, but my friend (who has the same mods as I am the server host) doesn't have this issue. I have tried fully deleting the folder, I have reinstalled TModLoader, even went through and changed game resolutions to see what could have caused it. I am still just entirely unsure what caused that.

First image is just a block of the Calamity and SacredTools (Shadows of Abaddon) buffs. That's not even as many buffs as the base game XD
Second image shows the cursor issue in relation to the buff list.


1574022170224.png

1574022745802.png
 

Lanboost

Terrarian
can u at least upload Unlimited Buff Slots .tmod for me, even i dont understand how to mod. i wll figure that somehow... oooohhh

update.. nvm i found it Lanboost/TModLoader_LansAutoJoinTeam XD
silly me, i dont use github so i didnt find it 1st
I am sorry but the current version of that mod wont even work on that old tmodloader version, my old version probably would...but then again, you can just update and get all features, unless you give me a compelling argument to not update this is all I can do for you.

Alright, so... a few things here. I really dig the mods, me and a buddy saw one and instantly thought "sweet, a LuiAFK replacement!". Sadly, certain parts don't work for whatever reason (like Calamity Zerg Buff in your buff list. BOTH of them. Because your buff list adds each mods buffs to its own line and then your mod adds Calamity buffs as well that make the Calamity buff line entirely useless save the... 3(?) that aren't in your line). Alternatively, is there any way to either condense or hide the mods to not cause a chunk of the screen to be covered by the buffs?

There's also a different issue on the buff list side of things, and I am unsure what caused it after updating you last time. When we first started using your mod, it had a huge buff list page that could fit on screen after I moved it. After updating, the list is much smaller and cannot be moved for whatever reason. Alternatively, it is no longer calibrated properly to where the mouse cursor is in relation to the activate/deactivate buttons you have on the list. I am unsure what caused this, but my friend (who has the same mods as I am the server host) doesn't have this issue. I have tried fully deleting the folder, I have reinstalled TModLoader, even went through and changed game resolutions to see what could have caused it. I am still just entirely unsure what caused that.

First image is just a block of the Calamity and SacredTools (Shadows of Abaddon) buffs. That's not even as many buffs as the base game XD
Second image shows the cursor issue in relation to the buff list.
Thanks for the bug report, I can indeed confirm that resizing etc did not work, this should now be "fixed" in the new version, the Calamity extension has been deprecated and removed from the mod browser, feel free to remove it. The weird issue with the panel not aligning with the tooltip and the "invisible" buttons I cannot reproduce but hope the new behavior of the resize fixes this issue.


The mod has also been given a config, access to debuffs

The save code hasn't been very well written so it might destroy the player owned buffs, but hopefully it works, feel free to take a screenshot on the buffs, then update, and if any issues enable debug mode and restore the owned buffs.


And about the condensing of buffs that will probably not be implemented in this mod, maybe in a separate mod sometime in the future
 

Angel 4

Terrarian
Roger that, an after thought came to mind in possibly condensing it: could you make it so the perma buffs are just listed under a singular thing akin to the banners? i.e. when you mouse over the banners it shows a list of all banner effects you are in range of, so maybe something like that could work. (I am also entirely alright with adding a supplemental mod, me and my friends have most of yours installed now as is).

Edit: it sadly did not fix whatever issue causes my bug... I still don't know what caused it, just that it happened directly after one of the more recent updates... So ya, still can't move the window and still have to search around for where the actual button is... Legitimately unsure what happened since nothing changed outside of an update. Pretty sure I mentioned my friends didn't have this issue either, and we are running the exact same mods as I am the server host. So somehow it's just affecting me lol.
 
Last edited:

Speeder

Terrarian
The shared-map mod seemly LOVES to crash... Easiest way is to play for a while, quit the server, go to another world, then come back to the server I was, this causes too much data to be sent through the socket, making the sockets API complain. But a couple times the whole game crashed because the shared-map mod used all the memory (literally, crash with out of memory error).
 

Angel 4

Terrarian
That makes me curious if that's what occasionally slows down the server I host... But I haven't experienced any crash based on it. I have noticed that it is a bit glitchy though, like if a friend goes through an area I have already explore it shades it back out in a weird way as if he were lag stepping through the zone lol. (leave small black lines in his wake essentially).
How many people are on that world, if I may ask? To get a generalized "limitation" of the mod and number of people before possibly having that happen? ^^;
I am curious and ask because I host the server for me and my friends.
 

Speeder

Terrarian
That makes me curious if that's what occasionally slows down the server I host... But I haven't experienced any crash based on it. I have noticed that it is a bit glitchy though, like if a friend goes through an area I have already explore it shades it back out in a weird way as if he were lag stepping through the zone lol. (leave small black lines in his wake essentially).
How many people are on that world, if I may ask? To get a generalized "limitation" of the mod and number of people before possibly having that happen? ^^;
I am curious and ask because I host the server for me and my friends.
I had it crash on me when was just me and my wife, but was large world and I logged out and back on with 3 different chars.
 

Angel 4

Terrarian
I actually just tested a thing on the server I am hosting for me +2 friends. We deactivated the Shared Map mod to see if that takes away the strange severe lag we have been having. Instantly we are noticing a difference XD
So ya, my system *might* be a bit better than yours to prevent an outright crash (no this is not a bragging statement) but it was still noticeably causing issues. Just never really thought it could be the data overflow from sharing the map data between 3 people. Go figure, eh?
Hopefully this gets smoothed out, but I can't honestly say I understand even a bit of that particular mod. It's just super nice to share the map ^^;;

Thanks @Speeder for bringing it up. Wouldn't have thought about it or tested it let alone found out it was the cause of a lot of our issues.
 
Top Bottom