• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Magic Storage

kiwiwikikwi

Terrarian
Once I place a crafting interface I can't mine it. Same issue in single player and a different multiplayer world. I'm assuming this is a bug?
 

Polymus

Terrarian
This has probably been asked already, but what's the possibility of adding in Quick Stack option to the Storage Heart(s)? At the very least while inside it? o:
 

Truthowl

Terrarian
Same as @kiwiwikikwi said. Once placed I cannot pick up the crafting interface. I only play single player so I don't know if it's the same in multiplayer. Am I missing something or is this a bug?

tModLoader v0.11.5
Magic Storage v0.4.3.5
Terraria v1.3.5.2
 
Last edited:

Speeder

Terrarian
I got a bunch of "out of index" erros on the UI (not internals it seems) when using the crafting, most often when adding new statations to it.

On my world, that was mostly unmodded (no big content mods) I added workbench, then alchemist table, then imbuing table, as soon I added the imbuing table I got that error.

Later I tried various mixes and always got that error until I settled to having only the alchemist and imbuing tables, no workbench.

It USUALLY worked, but I still got that error seemly at "random" while crafting items.
 

Barefoot Beast

Terrarian
I saw that white listing/ blacklisting features were on the to do list. Sounds great! I would like to request a simple config option to only allow stackable items to enter the storage system. I'm may be wrong, but I assume this would be a good deal easier than blacklist by individual items. Thanks for the fantastic mod!!!
 

A_stranger

Terrarian
Hi! .. I have a small recommendation ..
I would like that for a next update of the mod they would add that the creation screen or that of saving objects would fit your screen (resolution) .. I mean that the size could be adjusted to a little smaller or larger ... because not it is possible in low resolutions it is not possible to use the saving or creation boxes the user interface is not visible .. thanks! : D and.. srry this is google translator..
 

Legowaffles

Terrarian
I was unable to mine the Storage Crafting Interface after removing the connected Remote Storage Access.

This is clearly because of the Crafting Stations inside it.

Due to Locators being a PITA to make, I ended up making a replacement Storage Heart in order to remove the crafting stations and thus mine the Storage Crafting Interface. Which brings me to my suggestion:
  • Make it possible to open a Storage Crafting Interface without a connected Storage Heart or Remote Storage Access or. . .
  • Make it impossible to remove the Storage Heart or Remote Storage Access whilst a connected Storage Crafting Interface has crafting stations in it.
 

dracokazenare

Terrarian
So I dunno if this is recent or not, but everytime I run the modloader with magic storage installed, it totally resets my modloader back to the "Fresh install" state. Granted this isn't just right after opening and closing the game, it works just fine for a few months but then it just factory resets my modloader, resetting my mod controls and my game settings as well, so it kinda just destroys all my hard work over months in just a few hours. My characters and worlds stay as they are, keeping any structures and items in my inventory or equipped to my characters. It works just fine for multiplayer worlds, but it only does this to me on single player. If you know what's going on and/or how to fix it, please let me know
 

Polasnas

Terrarian
Hello.
I have one problem with mouse buttons. I'm left-hander, so they are default reversed. But in this mod's interface the buttons aren't reversed.
So, coud anybody say, how can I change the mouse binds in this mode, should I eddit code or something?
 

Elragu

Terrarian
best mod :D , tho It would be cool if items u already havewould show on the crafter easier , like a green background to show what you already own in ur storage :eek: to make collecting everything a heck of s lot easier :3 and to know what u have crafted b4 instead of wondering do i have this already? but srsly this is great
 

binbinhfr

Terrarian
I searched on the forum, but I found no answer, and I still cannot figure out what is the use of the "search mod" field instead of the "search name". When I type the name of a modifier, it does not find anything... Can someone give an example ?
 

VoidExile

Terrarian
Hey there. could you please add a hide recipe button that works with vanilla and modded items? This would be insanely useful for dealing with the clutter
 

Chopper7729

Terrarian
I have a crash to report. The game crashes when I open up the storage menu

Screenshot (19).png


EDIT: Nevermind it crashes when I hover my mouse over the window.
 
Last edited:

Isaac_HL

Official Terrarian
why the mod doesn't work now?, i mean a months ago it was working without problems, but now it doesn't appear on the mods list, can somebody tell me why?
 

Sexy sax man

Terrarian
Me and my friend are on our server with calamity and thorium installed. No issues whats so ever. So we added magical storage. Wonderful mod. Makes storing things and crafting so much easier. But every time we get on the server , and we all leave and come back , theres a giant hole in the center of our world. Plz help :(
 
Top Bottom