1. For issues you find with the Console 1.3 release, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    A FAQ with notes and workarounds can be found HERE. Please check this first to see if this helps your issue.

**REPORTED** Martian Madness won't start

Discussion in 'PC Bug Reports' started by PHELiOX, Jul 3, 2015.

  1. PHELiOX

    PHELiOX Terrarian

    I've met over 10 times in several maps that after a martian probe fled, the event won't start. It also has one exception, the event start once.

    And the spawn rate of martian probe seems unstable, I often met with 2-3 probes, then nothing for 1-2 hours, even changing maps.

    Besides, because of the game crash with steam, I played in multiplayer game single (with serval options, steam friend, invite only, none).

    ---------------------------

    I think I need to add more info to avoid misunderstanding. And just now another probe fled from me with nothing.

    I know how to start the event normally, and it won't start. Another detail is ufos are appearing in the sky, then nothing happened. Maybe they were afraid of me.

    --------------------------

    Some update, I accidentally start a singleplayer game and the martian event start fine, for 3 times. I guess the problem only happened in multiplayer mode. Consider the monster flashes in the server, maybe it's some internal lag I guess?
     
    Last edited: Jul 3, 2015
  2. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    @PHELiOX, try to look for probes in the sky; they spawn more often in the Space biome.

    To get an invasion, you are supposed to hurt but not kill, or let them scan you.
     
  3. CanSteam

    CanSteam Retinazer

    wait, so if you completely ignore them an invasion wont spawn?! all these pointless invasions were for nothing...
     
  4. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    If they scan you, they will still spawn an invasion.

    You can either kill them or stay well away to avoid it.
     
  5. PHELiOX

    PHELiOX Terrarian



    Yeah, I said I complete martian event once. In the others didn't start, the martian probe get red and fled out of the screen, but nothing happened.
    --- Double Post Merged, Jul 3, 2015, Original Post Date: Jul 3, 2015 ---
    The right way is to flee from the probe or kill it, otherwise the event will start and crush you if you are not prepared.
     
  6. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Have you tried closing your server and restarting it, then trying?
     
  7. PHELiOX

    PHELiOX Terrarian

    I met this in several worlds, both old worlds and new expert worlds. It happened all the time, same character btw.

    Every start of the game will reset the server.
     
  8. Azu

    Azu Retinazer

    I am having this issue too with my friends.
     
  9. ShadowBoo

    ShadowBoo Terrarian

    I've heard of this before, although this issue I've only seen happen with Multiplayer.

    To my knowledge, some of the events like invasion messages, boss defeat messages, and progression messages like the one you get after killing Plantera sometimes won't trigger for whatever reason. I think the same thing is happening to you.

    One could call it....MARTIAN MADNESS.
    Please kill me.
     
  10. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    The issue with Martian Probes not triggering invasions has been reported, thank you for the post!
     
    Azu likes this.
  11. PHELiOX

    PHELiOX Terrarian

    Thanks for recording , I played 1.3.0.3 for a while and it didn't happened in single player mode, in multiplayer mode I met the probe once and it started fine, for now.
     
  12. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    I actually have a single player world where this is happening; if anything, multiplayer worlds work better for me in this regard.
     
  13. Azu

    Azu Retinazer

    My friend found a probe and it flew off, and he saw saucers in the background, but the event never started. Strange...
     
  14. ShadowBoo

    ShadowBoo Terrarian

    Make sure he's near his original spawn (not the bed). Also, if that was in Multiplayer, tell him to enter Single Player and see if the Progress Bar appears for the Martian Madness event.
     
  15. Sgt Cheddar

    Sgt Cheddar Terrarian

    I'm having a problem when i started the martian saucer was a little gem thing and couldnt be killed and the only way to get rid of it was by leaving the game and joining again, it had the same property's as the boss itself firing rockets but nothing else just a little gem shape
     
  16. ShadowBoo

    ShadowBoo Terrarian

    Could you by chance, get a screenshot of this potential bug happening? It does have a health bar, right?
     
  17. ibakedpotato

    ibakedpotato Spazmatism

    You relog and it happens
     
  18. TheFriendless1

    TheFriendless1 Terrarian

    The same things happening to me.
    --- Double Post Merged, Apr 24, 2018, Original Post Date: Apr 24, 2018 ---
    I did your your suggestion but it didn't help.