Resolved Massive slowdowns in

Discussion in 'PC Bug Reports' started by LexIgnis, Jul 3, 2015.

  1. LexIgnis

    LexIgnis Terrarian

    Description: After updating to the latest hotfix, when playing the game I'll experience *massive* slowdowns. It doesn't seem to be linked to FPS since that is still around normal, but I could be wrong. Was fine with the initial release, and older versions. Friends I play multiplayer with don't experience the same issue, happens in multiplayer and singleplayer worlds.

    WebM Video:
    Yes, it really looks like that in game (minus the artifacting ofc)


    • CPU: i5-540m
    • RAM: 4GB DDR3-1600
    • GPU: Nvidia NVS 3100m 512MB
    • OS: Windows 7 64-bit


    • Quality: Low
    • Resolution: 720p
    • Frameskip: Off
    • Multicore Lighting: Off
    • Autosave: Off
    • Steam BuildID: 681547

    Nvidia Control Panel:

    • Triple Buffering: On
    • V-sync: On (Tried off as well, to no effect)


    I'm at a loss as what the issue could be, I've tried multiple solutions I've found online to no avail. I actually use Linux as my main OS, but installed Win7 on a spare HDD I had laying around just to play this game.
    Last edited: Jul 3, 2015
  2. Cylek

    Cylek Steampunker

    Try turning on Frameskip and see if that helps, if not, well they added a bit too much for your laptop to handle, sorry.
  3. LexIgnis

    LexIgnis Terrarian

    That's what I don't understand. It worked absolutely perfectly before the hotfix, and the hotfix only really added a few things, it shouldn't have effected performance this badly. I can run Fallout: New Vegas at ~30fps just fine on low settings, it shouldn't have this much of an effect on the game. Enabling frameskip did fix it however.
  4. Cylek

    Cylek Steampunker

    Well that's good, you don't seem to be the only one affected by performance drops however, thanks for the reply about the Frameskip option.
  5. LexIgnis

    LexIgnis Terrarian

    Thank you for the fast reply!
  6. Cylek

    Cylek Steampunker

    Glad I could help, and take a bit of pressure of the mods.
  7. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    What's interesting is that the update actually toggled the Frameskip option for some users; that's why it worked before, but not so well after. Switching it back to On should help. :)