Mac Mod library won't work


Official Terrarian
Ok so I recently moved to a Mac after moving from my other house, got home and started playing some modded, or tried to, anyways.

I run tmodloader and everything looks normal at this point, I get to the title screen, and try to download some mods.

Now the problem part begins, I click on the mod browser, it says "Loading data" and carries on to "populating browser", now it gets stuck here and doesn't do anything else, the loading icon is running and I can get back to the title menu.

The base game runs fine, like, I can play
I tried uninstalling the game on steam and installing it again, doesn't work.
Any solutions?


  • 1640974748478450018239440775508.jpg
    2.5 MB · Views: 37
finally, I was able to download the mods and then place them in my mod folder, the problem now, my in-game mod library won't load them.
I ran tmodloader and got to the title screen, clicked on mods, 'reload mods' and tmodloader stopped responding. pls help


  • Captura de pantalla 2022-01-01 a las 22.26.15.png
    Captura de pantalla 2022-01-01 a las 22.26.15.png
    5.9 MB · Views: 39
Top Bottom