• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

My game wont launch.

cooljkfire

Terrarian
I have tried verifying the game files, installing it on other hard drives and no matter what I do it wont work. Whenever I launch it it gives me the same error, Microsoft.Xna.Framework... It goes on basically saying the files wont load properly or I have missing content. I have checked for updates and it is up to date.
 

p0pola

Terrarian
Hi, I may have the same problem. Here is the full error. Please help :)

Unhandled Exception: System.BadImageFormatException: Could not load file or assembly 'Microsoft.Xna.Framework.dll' or one of its dependencies. is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)
at Terraria.WindowsLaunch.Main(String[] args)
 
Top Bottom