• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

Standalone N Terraria Mod: RPG, Races, Classes, Quests, and other things.

Nakano15

Duke Fishron
Hello Nakano, just a question: did you planned to bring back the cut content from NT5 to NT6, like the bunny and slime race?
Actually not, beside there's the... Well... Some kind of bunny race, in It.
I don't know If It's playable though, would need to check in the character creation.
As for the slime race, there isn't even a sprite for It, so I didn't even added.
 

Sacri Pan

Terrarian
Actually not, beside there's the... Well... Some kind of bunny race, in It.
I don't know If It's playable though, would need to check in the character creation.
As for the slime race, there isn't even a sprite for It, so I didn't even added.
Hello again!
The wiki say there is a bunny race but removed for NT6 and unsure about re-implentation! (to be honest, I got interssed for N Terraria especially for playing as a bunny, because I think bunnies are cute and underrated and underrused in the game. :D )
 

Nakano15

Duke Fishron
The wiki is not 100% accurate. A good example of that is the fact that the first paragraph says that they are small creatures. Since N Terraria 5, I guess, they aren't small.
 

Nakano15

Duke Fishron
I launched a new patch for the test version, fixing a number of issues, and adding a new extra thing.
Update 2
Fixed UI padding.
Reduced the blink rate of fallen stars on the floor.
Added a descriptible horror.
I'm sure you'll love it.
Fixed the animations of an Angry Bones variant.
Fixed High Voodoo Demon not being recognized correctly by the mod.
Fixed a number more of spritesheet problems in the mod.
Dead Branch is now more rare.
Hunt quests that tells you to kill any kind of monster, will no longer show either an empty text, or an s.
Critters will no longer get health boost.
The main quest "Temple Raider" will no longer jump from I to III. the Temple Raider III quest has been renamed to Temple Raider II.
Probably there were a Temple Raider II quest, but was removed for some reason.
Fixed drop rate being way too generous due to magic find.
Bunny Race made disponible. Play at your own risk.
I'm very sure you guys will like seeing a familiar face in the mod, but I don't think you'll be happy to find It.

By the way, as I said in the wiki, the Bunny Race playable switch is on, but I didn't tested It, so you may try It at your own risk.
Beside, If there's something weird with the race, other than It's sprites, I can see If I can fix the problem.
 
Create a shortcut of the mod executable, then go on it's properties, and add " -server" at the end of the target directory.
I don't recommend you to play the mod on multiplayer though, because It's extremelly broken.
this isnt working, its saying invalid path
edit: the server bat is missing and the one from the non test version isnt working
 
Last edited:

Nakano15

Duke Fishron
Create a .bat with this code then, at least for me is working.
Code:
start "N Terraria 6 Server" "N Terraria 6.exe" -server
exit
 

Nakano15

Duke Fishron
That's a case of "You loaded the mod on the wrong game version" or "You installed on the wrong place". If you want to play
N Terraria 6+ on the latest Terraria version, you need to install the "test" version.
 

Nakano15

Duke Fishron
And what version of the mod are you using? There's several versions of the mod, each version has their different clients necessary for running.
At least since Terraria 1.3, older N Terraria seasons will have problems loading because some of the content files were moved.
 

terrarian10

Official Terrarian
And what version of the mod are you using? There's several versions of the mod, each version has their different clients necessary for running.
At least since Terraria 1.3, older N Terraria seasons will have problems loading because some of the content files were moved.
6+
 

Nakano15

Duke Fishron
If you're trying to run the mod on Terraria 1.4 instalation, you need to use the "test" version.
Be sure to install the mod on Terraria folder. If you install somewhere else, the mod will give error when trying to load content.
 
Top Bottom