1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice

tAPI NeoMods

Discussion in 'Released' started by Neojin, Feb 5, 2015.

  1. Neojin

    Neojin Terrarian

    The Slabs are recolored, slightly altered versions of the Stone Slab. So they do bear some resemblance, lol. I'm not a great spriter, and the slabs do look a bit off. They're just my best attempt to fulfill a request I received. I may try to improve them during some down time.

    The Conveyor and Express Conveyor don't have recipes, but the Creeping Conveyor does. This is because the Creeping Conveyor was ported from MiraiMai's Never Enough Devices and I kept her original recipe in place. The Conveyor and Express Conveyor were my creations and I'm not so good at coming up with recipes. It's usually one of the last things I do, or gets done once someone suggests a recipe I like.

    Having the Wet Debuff applied when the Wet Rain option is set to false is a bug. I have fixed it and uploaded the new version.

    Thanks for the bug report and the comments!
     
  2. Roka Josh

    Roka Josh Skeletron Prime

    How do you detect if a player is near a crafting table in your mod?
     
  3. TheBilateralGamer

    TheBilateralGamer Spazmatism

    Hmm... I've been thinking about recipes you could use, and I think I've figured them out! Regular conveyors could be 5 Wires, 2 Chainz (lol), and an iron brick (idk if that's the name, but its the block you make with iron ore and stone). Express conveyors could use 1 conveyor, 10 wires, and 1 asphalt block. Yay or nay?
     
    Neojin likes this.
  4. Neojin

    Neojin Terrarian

    It's pretty easy to do, if I understand your question correctly.

    If I make a custom tile called 'Base'. And I want an item from my mod to use 'Base' as the crafting station, I just make the recipe for the item have 'Base' as the requiredTile.

    If you want 'Base' to act like it's a Furnace, Work Bench, Anvil, and every other crafting station tile, then in the Tiles JSON file use the 'adjTile' property like so...
    Code:
    {
        "displayName": "Base",
        "adjTile": [4, 17, 23, 60, 85, 221, 310] /* Each number is the Tile ID for the tile you want this to act like */
    }
    
    I like the idea of including chains in the recipe, and I really like the idea of the Express Conveyor using Asphalt!

    Thank you!
     
    TheBilateralGamer likes this.
  5. Roka Josh

    Roka Josh Skeletron Prime

    Thank you so much!
     
  6. neoselket

    neoselket Ice Queen

    it's minefactory re(logic)loaded
     
  7. TheBilateralGamer

    TheBilateralGamer Spazmatism

    No prob, Bob! :D
     
  8. Raulzus

    Raulzus Skeletron Prime

    Is this compatible with Shockah's mods? Once in awhile my game will crash and my character will get deleted.

    Now I'm afraid to play because I'm worried I might lose another character after hours of playing.
     
  9. Neojin

    Neojin Terrarian

    I use:
    • _ShockahBase r3
    • Accessory Slots+ r1
    • Enhanced Tooltip r2
    • FCM Base r2
    • FCM Standard r2
    • Inventory Tweaks r2
    While playing and testing my mods.
     
  10. Raulzus

    Raulzus Skeletron Prime

    Besides those, I use:

    • Item Suffixes r3
    • FCM Item Suffixes Bridge r2
    • Insight r2
    • NeoRecipeBook
    • NeoDraw
    Do you think you might know what the problem is? I don't want to start a new world unless I know my characters are safe from deletion.

    EDIT: I also had GRealm and Base Mod in my mods folder but I deleted them because I thought that they might've been the source of the problem but that isn't the case.
     
  11. Neojin

    Neojin Terrarian

    It's probably Item Suffixes.

    If you read Shockah's thread you'll see it has a few things being worked out. The version available from Shockah's Github page may work better though.
     
  12. Raulzus

    Raulzus Skeletron Prime

    I removed Item Suffixes and the FCM Item Suffixes Bridge.

    So far so good. I am almost to hardmode and have not had one crash. I'll let you know if something happens. Thanks man!
     
    Neojin likes this.
  13. Neojin

    Neojin Terrarian

    Here's my latest creation using Neo Devices:
    [​IMG]
    It simulates a full adder.

    The far left lever activates the circuit. The next 3 levers turn the torches above On(1)/Off(0). The 3 'IF' Gates above the torches test whether the torches are lit or not. The sum of the torches is then output in binary at the Blinktubes to the far right.
     
  14. Esreadel

    Esreadel Pumpking

    Ive been encountering constant freezing when in draw mode , and when it freezes music continues but then it stops as well. After a short time from stopping it resumes and the game does too. But it seems as if when it freezes it waitd for the music to stop then it resumes , its odd.
     
  15. Neojin

    Neojin Terrarian

    Sorry for the delayed response.
    • 1) Does it freeze consistently after a particular action, or at random?
    • 2) Do you create a large number of structures or use the undo/redo actions a lot? (They may be consuming to much memory)
    • 3) Can you bring up the Task Manager and monitor your percentage of used RAM? It may be pausing until the garbage collection runs to free up more memory?
    • 4) Could you list the mods you are currently using in the order they appear in the mod menu. There may be a mod compatibility issue.

    Thank you for letting me know. I'll look in to this right away, and post a fix as soon as it's resolved.

    ================================================================================

    The next update for Devices is almost complete. I have one more bug to resolve. It will be adding IF Gates, Flip-Flops, Relays, Water/Lava/Honey Spouts, a Liquid Drain and a few others I can't remember at the moment. I'm excited to see what everyone thinks!
     
  16. Esreadel

    Esreadel Pumpking

    Randomly
    i dont create structures i only use undo/redo but it happens even when im not using them
    When i have it running im left with 70% free ram and when the freeze happened it was in 60% free ram , so i dont think its a memory issue.
    ShockahBase r3
    Accessory Slots+ r1
    Eikesters Decoration Pack
    Enhanced Tooltip r2.
    FCM Base r2
    FCM Standard r2
    Inventory Tweaks r2
    NeoDraw
    NeoMasterCrafter
    NeoTileDirection
    NeoUtilities
    Terraria+
    ThoriumMod+
    W1KPrimeNeeds
    These are my current ones but i will note that the freezes happened even before i had some of these , i used to have only these:

    ThoriumMod+
    Enhanced Tooltip r2.
    FCM Base r2
    FCM Standard r2
    Inventory Tweaks r2
    NeoDraw
    NeoMasterCrafter
    NeoTileDirection
    NeoUtilities
    ShockahBase r3

    ive tried disabling all of them but thorium mod and the freezes persisted , do you think it might be that one? Also , before the update to neodraw where you added painting , the freezes wouldnt occur so it used to work fine
     
    Last edited: Jun 16, 2015
  17. Neojin

    Neojin Terrarian

    It's definitely a compatibility issue with Thorium+. I downloaded the current version and after enabling it, I immediately started to have freezing issues.

    Have you updated Thorium+ recently?

    I'll look into the changes I made in the last update to see what changes I made may have caused this.

    Thank you for the info.
     
    Esreadel likes this.
  18. Elder Sign

    Elder Sign Terrarian

    Just wanted to thank you for the awesome mods, especially your recipe book mod, it is extremely helpful when I do my mod spotlight videos.
     
    Neojin and ShadowTiger like this.
  19. Esreadel

    Esreadel Pumpking

    Thanks for looking into it so fast C: and thorium hasnt been updated at all , Divermansam is waiting for 1.3 to release a big update for it.
    Ill wait for more news on the issue , thanks for the support.
     
  20. Neojin

    Neojin Terrarian

    I've done some more testing and found a few things out. I don't believe this to be a compatibility issue between Thorium+ and Neo Draw. The bug can be reproduced without Thorium+ enabled. It appears to be a memory issue. If I set the brush size to rather large, and start painting continuously, it has occasional freezes. When I watch my memory use while doing this the freeze always happens at 1.5gb of RAM used, even though my total RAM usage was only at 63%. The exact number this occurs at may be different for you, but it should consistently happen at the same amount of RAM usage. The memory limit for .Net apps seems to be 2gb, but a few pages have mentioned issues with game performance anywhere from 1.5gb - 1.7gb. If I exit the game entirely, then restart, the freezes never happen. If I then Reload Mods 8 or so times to get my RAM usage up to 1.4gb, I again start to have freezes. It's probably most noticable with Thorium+ simply because it loads so many textures, so the RAM usage climbs pretty fast. I don't think there's anything to fix the RAM usage limit. One alternative is to just exit and restart occasionally. I will look into making my Draw and Undo storage functions use less memory. Let me know if this doesn't sound like what's happening to you, or if you have any other thoughts.
     
    ShadowTiger and Esreadel like this.