• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

Mac NPC Glitch or maybe in-game issue

Alextrasza

Terrarian
Here is some background info:

So this is the second time I've ever played Terraria - the first time I was unable to pass the Skeletron boss (because it was on expert mode and I was a beginner). But now I am up to the Wall of Flesh. After building an NPC house near the edge of the underworld, I got the guide to move in. When I was about to drop the doll into the lava, the magma slime came so I killed it, forgetting it would burst into lava. The lava killed the guide before I could summon the Wall of Flesh.

Here is the issue:

After that, the guide wouldn't respawn at all (no goblin gang, no events, no corruption, valid house). I have tried everything but the thing it the guide is now removed from my housing list (see image1, my full housing list) so I can't even occupy a house with the Guide.
Furthermore, I did a test with the merchant by assigning him in the same house and pushing him into the lava and just like the guide he died, would not respawn and was removed from my housing list forever.

I also tested with the nurse and it is the same result: as soon as they die (only in the underworld), they will not respawn and will be removed from my housing list.
Because of this, I cannot progress as I need the guide to get to hardmode.
Can you please help?
 

Attachments

  • image1.png
    image1.png
    8.6 KB · Views: 66
  • image1.png
    image1.png
    8.6 KB · Views: 61

Wintar

Duke Fishron
Could you attach a screenshot of the house problem?
On PC you can take screenshots with PRT|SC or press F1 to open Camera Mode
 

Kazzymodus

Moderator
Staff member
Moderator
Can you try invalidating that Underworld house (through removing the furniture, for instance) whilst making sure you have valid houses available on the surface?

Perhaps NPCs are trying to spawn in a valid housing (i.e. the one in the Underworld), but can't because they can't spawn in the Underworld, blocking the respawning process.
 
Top Bottom