• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Official tModLoader Help Thread

Kiraa

Official Terrarian
i deleted config.json, but it still crash?
it says this

Terraria: Error (tModLoader v0.11.6.2)

System.InvalidOperationException: Begin has been called before calling End after the last call to Begin. Begin cannot be called again until End has been successfully called.
at Microsoft.Xna.Framework.Graphics.SpriteBatch.Begin (SpriteSortMode sortMode, BlendState blendState, SamplerState samplerState, DepthStencilState depthStencilState, RasterizerState rasterizerState, Effect effect, Matrix transformationMatrix) [0x00008] in FNA.dll
at Microsoft.Xna.Framework.Graphics.SpriteBatch.Begin () [0x0001c] in FNA.dll
at Terraria.Main.RenderBlack () [0x00040] in tModLoader.exe
at Terraria.Main.RenderTiles () [0x00008] in tModLoader.exe
at Terraria.Main.DoDraw (GameTime gameTime) [0x00b70] in tModLoader.exe
at Terraria.Main.Draw (GameTime gameTime) [0x0001c] in tModLoader.exe

Maybe is because i changed the native sprites before the texture pack update, so im going to put these in its normal state and see if its fixed
EDIT- nah i changed the native sprites to they normal form and is still crashing.
 
Last edited:

Kiraa

Official Terrarian
i just got the error when i play with mods, i played with all my mods disabled and it worked normally
 
Hey, so I've been having an issue with the game lately, where there are no tooltips on any buffs, vanilla or modded. I am running Tmod on 0.11.6.1 because I'm also running 64bit 0.11.6.1 and I'm waiting for an update on the latter. I recently realised I was running on Tmod 11.5 when I tried to install 64 11.6 and so when buffs expired, the game would freeze for 15 seconds or so, and would eventually crash after a half hour of gameplay, but I fixed that, and now it all works fine, except for missing tooltips for buffs. Any ideas? If removing tooltips is a config feature of any common mods let me know because I've probably not noticed but can't find one, either.
 
Also, I've noticed an.... oddity, shall we say. If I boot the Tmodloader program and let it boot up/load mods etc in the background, once it goes to the main menu and I'm doing something on say, my internet browser or another Steam game, if I click on something that is lined up with where the game window is behind it, Terraria will register the click as if it was the dominant program window. This will only occur until I actually change windows to the game, then it will stop.

Just thinking as I was typing this, it started happening once I installed the ModHelpers mod as it was required for another mod.
 

ArsN1ght

Terrarian
Pls can someone help? I need to do projectile that i can spawn under cursor at any place for a few seconds and it will deal damage on contact
I tried to summon projectile under cursor but nothing works!(
 

MrBlackNT66rus

Terrarian
Hello. I downloaded Steam Terraria, installed tmodloader 0.11.6.2 and this error crashes on startup. who knows how to solve?
всем привет. скачал в стиме террарию, установил tmodloader 0.11.6.2 и при запуске вылетает эта ошибка. кто знает как решить?

Screenshot_1.png
 
Top Bottom