PC 1.3.3 Changelog

Discussion in 'PC - Re-Logic' started by Safeman, Sep 6, 2016.

Thread Status:
Not open for further replies.
  1. Scutlix

    Scutlix Steampunker

    !!!!!! nICE !! I actually just got the new mount from the first baskilisk I killed!
     
  2. GumballTheScout

    GumballTheScout Terrarian

    Ohh, so that's what it means. Neat.

    Won't be surprised if it will be Starbound.
     
  3. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Worms giving venom?

    @azumarill64, if Dune Splicers or Tomb Crawlers are inflicting Venom, please let me know, because that's not intended. Only Sand Poachers (the Scorpions) are inflicting Venom, because they were rather mild and it was fitting to give them that debuff.
     
    Azu likes this.
  4. Eris Falling

    Eris Falling Lunatic Cultist

    Waited for a sandstorm, ended up with more intense combat than I was expecting, then a solar eclipse crashed the party, heh
     
    D-Town likes this.
  5. Skiphs

    Skiphs Programmer Staff Member Re-Logic Administrator

    Unfortunately it seems that while improving the network code I broke it for Mono (OS X / Linux) users. I know where the issue is, and I'm working on a fix right now. We will have something out as soon as possible.

    Sorry!
     
    Cowdoom, Bullseye55, D-Town and 3 others like this.
  6. Khaelis

    Khaelis Plantera

    Not really.
     
  7. MinerTurtle45

    MinerTurtle45 Plantera

    woot woot new update
     
  8. agrajag42

    agrajag42 Terrarian

    Thank you! Good to know you found out what the problem is. :)
     
  9. reptile_rhys

    reptile_rhys Terrarian

    hell yeah a desert expansion sorta
     
  10. nondescript

    nondescript Terrarian

    I am no longer able to host any sort of server on linux. "Host & Play" doesn't work for even my own system as of 1.3.3; connecting and getting world data was always instant in 1.3.2, but now is sluggish and hangs at "receiving world information".

    When I tried this, I noticed the server process was running and using CPU, but would close on its own after a few minutes. Since I couldn't see what it was doing, I downloaded and ran the dedicated server. Everything loaded fine, up until the end:

    Missing method ToPrime in assembly /home/snipe/Dedicated Server/Linux/System.Core.dll, type System.Collections.HashPrimeNumbers
    Load failed!

    Google only had one pertinent match for the error, which is a post nearly a year old: http://forums.terraria.org/index.php?threads/linux-server-wont-start-properly.35142/

    Single player seems to work fine, but I mostly play Terraria with friends and host our world.
     
  11. avarisc

    avarisc Skeletron Prime

    Just glad it wasn't my fault :3
     
    Cowdoom likes this.
  12. DexavioR

    DexavioR Terrarian

    Awesome! Just got on here and I'm like "Whaaat? It's out already?"
     
    Cowdoom likes this.
  13. felis

    felis Terrarian

    It's really surprising.

    A small problem (does anyone else met by the way?):
    it seems no longer support 1980X1080 resolution.
    1.png
    2.png
    It's completely blank at full screen window (no problem before updating) and the resolution on full screen mode is also low.
    Not sure whether it's my computer's problem.

    Edit:
    Drag the Windowed screen to Full Screen size is OK, but it will still become blank when hit the maximize button
     
    Last edited: Sep 9, 2016
  14. Explodingpineapple

    Explodingpineapple Terrarian

    hhow to craft the new armor set? wiki hasnt been updated
     
  15. Crimwolf

    Crimwolf Retinazer

    Thank you safeman finally!
     
  16. Tunnel King

    Tunnel King Administrator Staff Member Administrator

    Just look a few posts above yours - known issue, fix being worked on.

     
  17. KingOfPancakes

    KingOfPancakes Terrarian

    Update is decent. New mount is cool (got it in first 15 min) but unicorn mount is still better. New ancient vanity looks cool too. BUT, there are many more bugs then they fixed. 'Quick stack to nearby chest' button is broken so you have to do it manualy. in coop some tombstones are broke as they say only your name. And that is pretty much everything that I noticed in first 20 min that I was playing it.
     
  18. nondescript

    nondescript Terrarian

    I did notice that, but my error(s) seemed different from the others mentioned, and decided to get it out there just in case. Fingers crossed.
     
    Tunnel King likes this.
  19. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Could you provide more details on the Quick Stack bug? I've been using this feature without any issue for the past two days on this version and I've had no issues at all.

    As for the co-op tombstones, how did the people in question die?
     
  20. Loki

    Loki Consigliere Staff Member Re-Logic Administrator

    You will be surprised then.

    UPDATE FOR MAC & LINUX USERS:

    We are aware of an issue with networking on Mac and Linux. Work is being done to correct the problem as quickly as possible! Hang in there!
     
    Bullseye55 likes this.
Thread Status:
Not open for further replies.