PS4 PLEASE HELP GAMEBREAKING GLITCH!!!!!

Discussion in 'Console Bug Reports' started by Strikefire, Jan 12, 2015.

  1. Strikefire

    Strikefire Terrarian

    So today i was playing terraria and having abgreat time then bam 1 of my friends said his game got corrupted and was gone. Then in about an hour 4 of my friends were. A couple hours after that. I left my somebodys game and it said terraria could not respond an error had occured. So i reloaded the game and i had to read the eula again and when i went to select my character, there were none! When i made a new one there were no worlds either. Also i cant download any from the cloud either. PLEASE HELP remember im on the PS4. So around 5 people today lost everything in terraria. Please help. Thanks!
     
  2. DFA_2Tricky

    DFA_2Tricky Spazmatism

    Same thing happened to my friends and I ONLY when we saved our games in someone elses world. I'm a PS Plus member so I had to download my last saved everything then go from there.
    Now I upload everything to the Terraria cloud just in case, that way I can download my character and world if they get lost.
     
  3. Nike Leon

    Nike Leon Moderator Staff Member Moderator

    This should definitely be reported directly to 505, please use the links in my signature to do so. In the meantime, DFA has provided the most applicable solution. Sorry about your saves :/
     
  4. Strikefire

    Strikefire Terrarian

    Thanks! Also for some reason a couple days later i put the disc in and everything was back to normal less than TEN minutes later it happend again!
    --- Double Post Merged, Jan 27, 2015 ---
    Yea i put my things in the cloud but when i tried to bring them down again they werent there!
     
  5. Nike Leon

    Nike Leon Moderator Staff Member Moderator

    That really sucks my friend :( hopefully 505 gets back to you ASAP
     
  6. PaladinRob

    PaladinRob Terrarian

    Is there any way to recover them back? I mean I put so much work into the game...
    Everything is gone besides the first character and that's it (Player 2's data is fine though).
    The saves are not corrupted as far as I'm concerned (no load failures or anything) the saves just all disappeared after I came back to play.

    I tried re-downloading the game, playing the tutorial, playing as second player (using first character) and none of that has worked. The game is also updated to the latest.

    I'm pretty frustrated and desperate.. Help? 505? Please??
     
  7. Nike Leon

    Nike Leon Moderator Staff Member Moderator

  8. PaladinRob

    PaladinRob Terrarian

    I sure hope that is the case, but what I would like to see is a definite fix.
    Do you have a way for the game to recognize the save??
    But I guess I'll probably wait it out, but I'm afraid of the answer... :mad:
     
  9. Nike Leon

    Nike Leon Moderator Staff Member Moderator

    Sadly I know of no such work around :(
     
    PaladinRob likes this.
  10. PaladinRob

    PaladinRob Terrarian

    -update1-
    Okay. From what I discovered... I tried creating a new world in a for sure empty spot and it mysteriously disappears after coming back 10~ minutes later.
    The Mb of my save data went from 10mb to 13mb. I think my stuff is still there, but I can't see it. Nothing seems to have come back either.
    The only character that went in the new world still had the items from the vanished world (called Testing World).

    I made another world to dump the items and deleted that test world (called Testing Bugs) and the save data went from 13mb back down to 10mb.

    Just some other important info I have 4/5 characters (2 main characters and the other two empty, but maxed HP and MP. I retained only one of the empty characters, which is slot 1) and 6/8 World slots (1 is a 50% corrupt world, 2 are main worlds and 2 are event worlds that are flat near the center and 1 world is a dungeon/ore farm. No world was retained).
    But it seems the Mb for my save data is pretty low... but I don't think one character=10mb. Must be a data leak? But my guess is my 6 worlds are 1.2~mb each and the 4 characters an unknown Kb value (50kb-600kb?).

    I'll wait until Tuesday to see if anything has changed (1 week). I've also contacted 505 games about this.

    I hope I get my characters in slot 2 and 3 back... and World slot 1 and 5... Please??
     
    Nike Leon likes this.
  11. PaladinRob

    PaladinRob Terrarian

    -update2-
    Just got a reply from 505 support and I've also tried copying the files and playing on another profile (Guest 3). It says the typical stuff when you play save data that is not your own, but the problem still persists... So it seems the save data is pretty messed up somehow. Haven't tried creating a world in a empty slot again (I assume it will vanish when I leave the game). Who knows. Here's the message:
    Well, seems automated... but I have forwarded this to Engine Software hopefully (my reply was [firm type 4.75] [firmware vers. 4] [Game vers. 1.2.3 Additions]). I really want to start a rant with big companies, but that is a different topic for another day.
    I've also started a conversation with a developer, but they have yet to reply, I don't expect them to though.

    I'll continue to post up updates when I have significant progress (one for sure on the following Tuesday next week to see if my files came back or not).
     
    Nike Leon likes this.
  12. xxterminatorxx5

    xxterminatorxx5 Terrarian

    Just upload to cloud that's the best workaround
     
  13. PaladinRob

    PaladinRob Terrarian

    @xxterminatorxx5

    You had this happen to you?
    So if I upload it to cloud and download it again, the data should return right?

    Unfortunately I don't have PS+ to use the cloud saving/upload feature.
    ---
    On a side note, I don't think it would work for "truly" corrupt data.
    Also by reading around it may be a multiplayer issue possibly?
     
  14. xxterminatorxx5

    xxterminatorxx5 Terrarian

    You don't need PS+ to use cloud just click L1 on any world or character and if anything gets corrupted download them back by pressing R1.
     
  15. PaladinRob

    PaladinRob Terrarian

    Sorry late reply. Playing card wars to soothe the wounds...

    -update 3-
    @xxterminatorxx5
    Just tried it on the empty slots (characters and world)... And I managed to get only 1 character (SLOT 2! YEAH!!) back except this character is not even wearing the right stuff. Worst thing is, this character also mysteriously vanishes after I leave the game. So I have no idea what is happening. Even worst I think I've also lost the original data doing this risky test.. I was able to upload Slot 1 fine and download it identically the same.

    Data size went to 12Mb (second attempt, but saving in the proxy world with slot characters 1 & 2) and seems to be staying there despite disappearing worlds and characters (up from 10Mb). Strange.
    Every time I do this downloading process (at least 3 times) and starting a new world in a empty slot... They both magically disappear. I can't explain the data memory increase.

    Though last time I tried to upload our characters and worlds it said that there was a error trying to upload it to cloud, but this new lead suggests something otherwise. It was not successful before, now it is?
    ... ...
    Help?
     
    Last edited: Aug 7, 2015
  16. Kola17_97

    Kola17_97 Spazmatism

    505: Game not found. Ooooh snap that was scalding.
     
    PuddingZebra and kageboushiKun like this.
  17. xxterminatorxx5

    xxterminatorxx5 Terrarian

    You might need to delete your save data if it keeps erasing itself. I know it sucks loosing your stuff but try to get your hands on an all items world and hopefully restore your progress.
     
    PaladinRob likes this.
  18. PaladinRob

    PaladinRob Terrarian

    Yikes. I think I'll leave that step for last though if it comes to it. I'm currently bypassing the mysterious disappearances with the seemingly working cloud saves and playing sparingly on a temporary world.

    Plus I'm stubborn as a mule. I refuse to lose my stuff. Hahaha. :cool:
    ---
    [Update 4]
    1 week later... the saves haven't returned. However, I went on player 2 and checked their save data and the memory is 6300~ Kb (6Mb). That save has 4/5 characters (most are well armed) and 3/8 Worlds (just empty ones). Comparing to player 1 data (4/5 Characters, 2 empty ones and 6/8 worlds, 3 mostly unaltered and currently an additional world mostly unaltered to pass the time) which is sitting at 12Mb up from 10Mb (maybe cause I saved in the new world)... The memory usage and storage is true I guess; as I play player 1 more and usually solo plus player 1's worlds are more loaded with items and structures. This does not match up as player 1 LOST EVERYTHING. This should've dropped the memory down to <750Kb if it were truly wiped (as player 1 was left with only 1/5 characters and that was it). This obviously doesn't make sense.

    Not to forget the mysterious vanishings of newly created worlds and characters, which makes this problem even more odd. Again, no sense whatsoever.

    This makes me believe that the data is still there, but for some reason are gone or aren't showing up. I have also been playing for the past 3-4 months up until the patch... there could be a bug in the patch that they haven't caught, which makes the way the game handles your data messed up. I mean looking back in time; 505 games had to release a patch that restored certain "corrupted" saves, but only if you haven't saved over the original data (EDIT1-This was said by a forum goer in the terrariaonline forums, but I can't access the information).

    Contact with 505 games and Engine software have ceased (no more addition responses or returned responses).
    However the message I sent now varies in accuracy as I learn more about this problem. Hopefully they care and look at the forums.

    Other then that I feel more hopeful and plan to wait in the mean time until the answer is more definite. I'll continue to update as I see fits or stop without warning.

    EDIT1- Here are the additional sources (can't seem to find the other ones or access them). It was all I can get within 10 minutes.
    http://www.playstationlifestyle.net...es-within-terraria-patch-1-2-is-in-the-works/
    http://www.gamefaqs.com/boards/709410-terraria/69047252
     
    Last edited: Jul 21, 2015
    Nike Leon likes this.
  19. Nike Leon

    Nike Leon Moderator Staff Member Moderator

    Yeah it sounds like a disconnect between your profile and its saves.
     
    PaladinRob likes this.
  20. PaladinRob

    PaladinRob Terrarian

    [Update 5]
    Edit2- Classified. -snip-
    ----
    And this is all for this update. It kind of sucks that we're alone at this. A developer should really come and address this... but they don't have to if they don't want too.
    At least we got news of 1.2.3 and 1.2.4, which I'm grateful for.

    Cheers.

    Edit1- I think I'm going to add the origin story. This all started when I was playing on character 4 and local multiplayer in World 4 (world 5 technically if it didn't start at 0).
    Split-screen to be precise. This was the world we have been playing for a week as a new fresh coop experience since we were bored.

    As soon as we were done on the last day, we saved and I loaded up our main world (world 0) to transfer items between world 4 and world 0 (just me, player 2 signed off). I think I may have done this 1-3 times (I also did this same procedure throughout the week). I did not take anything from world 0 during transferring, but added to the hoard of items we had on that world from world 4, after all it was our main world. After I was done transferring I loaded up character 2 to fool around for a bit in world 0.

    I soon exited and saved with no problems or crashes. Little did I know this was the last time I would see my characters and worlds. I returned to the XMB to play a different game and on the following day I discovered my stuff was gone. Player 2 was not affected by this either.

    There you have it ...-sigh-...
     
    Last edited: Aug 8, 2015