• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

tModLoader Portable Storage 2

Im getting a crash during mod loading it doesn't happen all the time but fairly often
Code:
[12:10:28] [1/INFO] [tML]: Starting tModLoader v0.11.6.2 Linux client (02/09/2020)
[12:10:29] [1/INFO] [tML]: Running on Mono 4.6.1
[12:10:29] [1/INFO] [tML]: Executable: /run/media/fred2104/Hard_Drive/Steam/steamapps/common/Terraria/tModLoader.exe
[12:10:29] [1/INFO] [tML]: Working Directory: /run/media/fred2104/Hard_Drive/Steam/steamapps/common/Terraria
[12:10:29] [1/INFO] [tML]: Launch Parameters:
[12:10:29] [1/WARN] [tML]: First-chance exception reporting is not implemented on Mono
[12:10:29] [1/DEBUG] [tML]: Assembly Resolve: Terraria, Version=1.3.5.1, Culture=neutral, PublicKeyToken=null -> MonoMod.RuntimeDetour, Version=19.12.19.1, Culture=neutral, PublicKeyToken=null
[12:10:29] [1/DEBUG] [tML]: Assembly Resolve: Terraria, Version=1.3.5.1, Culture=neutral, PublicKeyToken=null -> MonoMod.Utils, Version=19.12.19.1, Culture=neutral, PublicKeyToken=null
[12:10:29] [1/DEBUG] [tML]: Assembly Resolve: MonoMod.Utils, Version=19.12.19.1, Culture=neutral, PublicKeyToken=null -> Mono.Cecil, Version=0.11.1.0, Culture=neutral, PublicKeyToken=50cebf1cceb9d05e
[12:10:29] [1/DEBUG] [tML]: Assembly Resolve: Terraria, Version=1.3.5.1, Culture=neutral, PublicKeyToken=null -> Ionic.Zip.Reduced, Version=1.9.1.8, Culture=neutral, PublicKeyToken=edbe51ad942a3f5c
[12:10:29] [1/DEBUG] [tML]: Assembly Resolve: Terraria, Version=1.3.5.1, Culture=neutral, PublicKeyToken=null -> Newtonsoft.Json, Version=10.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed
[12:10:29] [1/DEBUG] [tML]: Hook IL.Ionic.Zip.ZipEntry::ValidateOutput(string, Stream, out string) modified by Terraria
[12:10:29] [1/DEBUG] [tML]: Assembly Resolve: Terraria, Version=1.3.5.1, Culture=neutral, PublicKeyToken=null -> Steamworks.NET, Version=9.1.0.0, Culture=neutral, PublicKeyToken=null
[12:10:30] [1/DEBUG] [Terraria]: Graphics Device: DELL E198WFP 19" {{Width:1440 Height:900 Format:Color}}
[12:10:36] [1/DEBUG] [tML]: Fallback synchronization context assigned
[12:10:40] [Threadpool worker/DEBUG] [tML]: Assembly Resolve: Terraria, Version=1.3.5.1, Culture=neutral, PublicKeyToken=null -> MP3Sharp, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
[12:10:40] [Threadpool worker/DEBUG] [tML]: Assembly Resolve: Terraria, Version=1.3.5.1, Culture=neutral, PublicKeyToken=null -> NVorbis, Version=0.8.4.0, Culture=neutral, PublicKeyToken=null
[12:10:40] [Threadpool worker/DEBUG] [tML]: Assembly Resolve: Terraria, Version=1.3.5.1, Culture=neutral, PublicKeyToken=null -> Mono.Cecil.Mdb, Version=0.11.1.0, Culture=neutral, PublicKeyToken=50cebf1cceb9d05e
[12:10:40] [Threadpool worker/INFO] [Terraria]: JIT loading finished
[12:10:40] [Threadpool worker/INFO] [tML]: Unloading mods
[12:10:41] [Threadpool worker/INFO] [tML]: Finding Mods...
[12:10:42] [Threadpool worker/INFO] [tML]: Sandboxing: BaseLibrary
[12:10:43] [Threadpool worker/INFO] [tML]: Sandboxing: FluidLibrary
[12:10:43] [Threadpool worker/INFO] [tML]: Sandboxing: ContainerLibrary
[12:10:43] [Threadpool worker/INFO] [tML]: Sandboxing: PortableStorage
[12:10:43] [Threadpool worker/INFO] [tML]: Instantiating Mods...
[12:10:43] [Threadpool worker/INFO] [tML]: Initializing: ModLoader v0.11.6.2
[12:10:45] [Threadpool worker/INFO] [tML]: Initializing: BaseLibrary v1.2.2
[12:10:47] [Threadpool worker/DEBUG] [tML]: Assembly Resolve: BaseLibrary_0, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null -> TerrariaHooks, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null
[12:10:47] [Threadpool worker/DEBUG] [tML]: Hook On.Terraria.UI.ItemSlot::LeftClick(Item[], int, int) added by BaseLibrary_0
[12:10:47] [Threadpool worker/DEBUG] [tML]: Hook On.Terraria.Player::DropSelectedItem() added by BaseLibrary_0
[12:10:47] [Threadpool worker/DEBUG] [tML]: Hook On.Terraria.UI.UIElement::GetElementAt(Vector2) added by BaseLibrary_0
[12:10:47] [Threadpool worker/DEBUG] [tML]: Hook IL.Terraria.Main::DrawInterface_36_Cursor() modified by BaseLibrary_0
[12:10:47] [Threadpool worker/DEBUG] [tML]: Hook On.Terraria.GameInput.PlayerInput::KeyboardInput() added by BaseLibrary_0
[12:10:47] [Threadpool worker/DEBUG] [tML]: Hook On.Terraria.GameInput.PlayerInput::MouseInput() added by BaseLibrary_0
[12:10:47] [Threadpool worker/DEBUG] [tML]: Hook On.Terraria.Main::DoUpdate_Enter_ToggleChat() added by BaseLibrary_0
[12:10:47] [Threadpool worker/DEBUG] [tML]: Hook On.Terraria.Player::ToggleInv() added by BaseLibrary_0
[12:10:47] [Threadpool worker/DEBUG] [tML]: Hook IL.Terraria.Player::Update(int) modified by BaseLibrary_0
[12:10:48] [Threadpool worker/DEBUG] [tML]: Hook On.Terraria.Main::DoUpdate(GameTime) added by BaseLibrary_0
[12:10:48] [1/ERROR] [Terraria]: System.Exception: Chain<Terraria.Main::DoUpdate>?-1723573986 should've been detoured!
  at (wrapper dynamic-method) MonoMod.Utils.DynamicMethodDefinition:DMD<DMD<Chain<Terraria.Main::DoUpdate>?-1723573986>?1607409283::Chain<Terraria.Main::DoUpdate>?-1723573986> (Main,GameTime)
  at BaseLibrary.Hooking.Main_DoUpdate (orig_DoUpdate orig, Main self, GameTime gameTime) in BaseLibrary\Hooking\Hooking.cs:104
  at (wrapper dynamic-method) MonoMod.Utils.DynamicMethodDefinition:DMD<DMD<Hook<Terraria.Main::DoUpdate>?1785371703>?-882403818::Hook<Terraria.Main::DoUpdate>?1785371703> (Main,GameTime)
  at Terraria.Main.Update (GameTime gameTime) [0x00035] in tModLoader.exe
[12:10:48] [Threadpool worker/DEBUG] [tML]: Hook On.Terraria.GameInput.PlayerInput::UpdateInput() added by BaseLibrary_0

Im on linux if it helps mods Im using are just
base library
fluid library
container library
portable storage

I don't know if I had the exact same issue as you, but it was similar: Base Library crashing at "Finishing Resource Loading" on Linux. It seems like enabling Developer mode in tModLoader and going through the steps to make sure it's enabled has fixed things for me. So, specifically, cancel the loading of your mods while Terraria is starting up, click the "Enable Developer Mode" at the bottom right of the main menu, and then do whatever the following screen tells you so that Developer mode is activated.
 

Blackraven6

Terrarian
Hi! I was wondering if you'll be updating this mod to 1.4. I absolutely love it, but sadly atm I doesn't work with 11.7 tModLauncher. It literally says "it was made for 11.6 while this is 11.7, so we are disabling this mod for you".
 

Itorius

Skeletron Prime
Hi! I was wondering if you'll be updating this mod to 1.4. I absolutely love it, but sadly atm I doesn't work with 11.7 tModLauncher. It literally says "it was made for 11.6 while this is 11.7, so we are disabling this mod for you".
Update is up on the mod browser and is definitely updating to 1.4.
 

FluffyKitsune

Terrarian
I really love this mod but I have been having issues with it ever since the update for it dropped a few days ago. The issues I was able to find with this mod so far has been:

1. My mouse positioning is way off for the main menu, but not the game itself.
2. My chat box vanishes, but I can still type.
3. I cannot manually click on anything in my accessory slots. I can swap out items with right-click but I cannot left-click on them.

The friends I have been playing with do not have this issue, so it's possible you may not be able to recreate it, but if it helps we are also using the tModLoader version from Steam. All three of us have fresh installs of tModLoader so no idea why I am the only one in my group to get this issue.
 

Blackraven6

Terrarian
Just found a bug, where when I open bag and click on item in it - it picks up as normal, but the bag ui sticks to the cursor. Never experience this before today. Pretty sure it's either a tMod bug and this needs to be restarted or it may conflict with MechTransfer I've just installed.
 

Circadian

Terrarian
Just found a bug, where when I open bag and click on item in it - it picks up as normal, but the bag ui sticks to the cursor. Never experience this before today. Pretty sure it's either a tMod bug and this needs to be restarted or it may conflict with MechTransfer I've just installed.

I'm having the same issue, and it still happens even on a new/world character with only portable storage installed. Here's some additional info for my specific problem:

1) Right Clicking on the bag/opening via hotbar opens the bag window as expected. The window also remains in the same position if the game is closed/reopened for the same character.
2) When left clicking anywhere within the bag window (whether it be on items, an empty cell, the actions on the top left of the box, or anywhere else) the window is instead grabbed in a (somewhat) arbitrary spot ~3 boxes to the right and 1 down from where is clicked (though it seems to slightly change over time). If an item happens to be in that spot, it'll be picked up.
3) Right clicking in the window will grab one item from the box ~3 boxes to the right and 1 down from where is clicked. Placing an item in the bag also places the item in a similar position.
4) While on a server, the bag ui kept sticking to my cursor, but I wasn't able to replicate the issue while testing with no other mods enabled.
5) While I was on my own server, all of the above issues occurred for myself, but not for anyone else on my server.

My friends and I all followed the same steps when downloading mods and joining my server, so it's strange how only I'm experiencing issues but they seem to be having no problems.
 

Blackraven6

Terrarian
My friends and I all followed the same steps when downloading mods and joining my server, so it's strange how only I'm experiencing issues but they seem to be having no problems.
I actually used the mod for a few days after update and everything was fine. Thinking of it now - something effed at the moment, when I got myself the second Builder's reserve. My original Builder's Reserve lost all of his icons in the ui, while still having the items in it. So I rushed to throw the second one in the trash bin ASAP and forget about it, cause I rarely use/change placing blocks from builder's reserve. But everything worked fine after that(I mean the bags worked fine. I use them a LOT in building my base) before what I've wrote above at that day, when I installed the MechTransfer. And a slight difference from your problem, Circadian, I grab the item from the bag I'm clicking on, and grab it by that exact place, haven't noticed any...eehhh... misshots?
 

xenogray

Terrarian
Hello,

Same issues as everyone, cursor si stuck to the window. However it also breaks JoJoStands mod : the mod adds a special slot that is unusable when Base Library is activated and Base Library is required by this mod and all mods requiring Container Library ...
 

Blackraven6

Terrarian
As it came, so it's gone. Had no issues today except for that of a missing icons in the Builder's reserve. 🙄
P.S. Literally changed nothing. Just another day and another start of a game.
 

Namesomething

Terrarian
Speaking of weird things, I've noticed a few of them as well:
- I can't write in-game commands, my character says them out loud instead of them being parsed
- Crafting costs of everything, for some reason, is halved
Disabling Base Library (and by consequence, Portable Storage as well) seems to fix those issues.
 

Blackraven6

Terrarian
Noting everyone, that there are some updates to this mod available atm. I only noticed them today. Maybe it will help someone.
 
ive come across a serious bug, whenever i select an item in the any of the bags it also selects the window for the bag so it moves with my cursor and i cant take anything out
 

GameFreak

Terrarian
The window dragging bug has been driving me crazy all day. I went and did some testing and it seems related to get triggered by reloading mods. I've included my testing steps and can PM you a dropbox link with the player, world, logs, and relevant config files if you want it. I have also been getting the halved(-ish?) material consumption but I haven't done any pointed testing with that one.

  1. Disabled all mods except the ones listed below
  2. Created new character and world.
  3. Started world
  4. Used Cheatsheet to spawn Capillary Bag
  5. Opened capillary bag
  6. Put item in bag and attempted to remove it via left click
    1. Result: Stuck dragging window
  7. Exited to main menu
  8. Disabled Cheat Sheet & Reloaded
  9. Reentered world
  10. Attempt to remove item from bag
    1. Result: Stuck dragging window
  11. Exit to menu and quit terraria
  12. Relaunch Terraria
  13. Enter Test world
  14. Attempt to remove item from bag
    1. Result: Item is properly removed
  15. Return item to bag
  16. Exit to main menu
  17. Reenter test world
  18. Attempt to remove item from bag
    1. Result: Item is properly removed
  19. Exit to main menu
  20. Reload mods
  21. Reenter test world
  22. Attempt to remove item from bag
    1. Result: Stuck dragging window
  23. Exit to menu and quit terraria
  24. Relaunch Terraria
  25. Reload mods
  26. Renter test world
  27. Attempt to remove item from bag
    1. Result: Stuck dragging window


Versions & stuff:

  • Windows 10 1903
  • Terraria 1.3.5.3
  • tModLoader 0.11.7.5 (steam)
  • Portable Storage 2.3
  • Fluid Library 1.1
  • Base Library 1.3.2
  • Container Library 1.1
 

Envade

Terrarian
Hi everyone,

I also have the issue with bags windows being dragged by the cursor no matter where I click (once).
Can someone please find a fix ? It's driving me insane... 😰
 

Roleplayer

Terrarian
idk if im dumb or not but is there an ability to take the bagged items and put them directly into a chest?
And if theres no such ability will there ever be one?
 

AquaticChaos

Terrarian
Having the same portable storage issue as everyone else. But even if I set my UI scale to 100% (Usually at 119%), it still grabs the ammo pouch's UI (In my example) and won't let go until I escape key out of my inventory. It's a shame this issue is still persistent over a month after the last comment.
 
Top Bottom