Working as Designed [PS4] Where's My Lava


Console Bug Priority
Lava just disappears, and my chamber to make more lava the outlet pump only pumps water even if the inlet pump is in lava or honey.
Hello KillerBee,

Outlets pumping out water instead of lava or honey if lava or honey were put in the respective inlet pump is an issue known by the Developers.

It should get fixed in a future hotfix update. :)
Ok, you fixed the pumps so that they produce what they are in. Honey if the inlet is in honey, lava if in lava. But it doesnt duplicate like it used to. I could drain the ocean and be able to fill it back up. I can't anymore, that's a big issue that I'm surprised that no one has mentioned yet. Will this ever get resolved?
Liquid simulation in Terraria is not volume-preserving and probably never will be because volume preserving simulations are extremely difficult.
It is still possible to duplicate liquids (though liquid duplication in itself is not intended behavior and was already remedied in the 1.4 update), though now its a lot less effective and requires more work. I believe that you could still somewhat duplicate liquids by spreading them out into thin streams and then letting them get diverted by a block.
I've tried the single bucket takes forever to do, the pumps were perfect. You could set it up go build something else while that works for you. Why would they take that out? You can farm everything else in the game, why not liquid? To take it away, after it's been part of the game since ps3 I don't understand the reasoning. Make's it hard to want to play when they keep changing crucial parts. So much time put in on building and setting up for it to just disappear. Very frustrating, it was hard enough when they screwed around with the controls. I know you can mod them go to classic, but still not the same. More difficult to build now then ever before, at least for me. Made it more for PC than console. Just bummed that one of my favorite games is now one of my least fav. Labor of Love ruined the way it plays.
Not gonna lie, in my opinion farming liquids are a lot more fun now. It is not simply just "build a staircase and put a pump on top of it", but instead you'll have to engineer your way to produce liquids, which makes it way more rewarding (speaking from someone who have actually built liquid duplicators in 1.4) (and also, I don't think that 1.4.4 ruined liquid duplication any more than 1.4 did, since the design still works in both 1.4.3 and 1.4.4)
I can send you the design if you want
Capture 2022-07-24 11_32_41.png

Ya!! I'll take any advice and pointers, that's awesome.
So, this is the design I used; I found it on Youtube by Rare Red it works pretty well from up to the last time I checked in Just put two pumps below and separate them as far as possible. (for the one second timers refer to the video linked above)
However, this design has a pretty big caveat: its not consistent until it starts working. Reset the machine if it starts voiding your liquids or if you are not satisfied with the output, and do that as many times as necessary until you are satisfied with its production speed (from my testing, it has been shown to produce water at up to 180 blocks per minute!) But once it starts working, it works pretty consistently regardless of whether or not you are near it.
(the big bowl of water up there is purely decorational and you dont need it)
Why would they take that out? You can farm everything else in the game, why not liquid?
Well for one you can still farm liquids, and for two there is rarely ever a need to create large artificial bodies of liquid outside of making small fishing ponds for which you can usually use existing liquid in the world, so its very reasonable to remove a behavior that is more of a bug than a feature.
Picture yourself as a new player accidentally creating a liquid duplicator and seeing your liquid amount rapidly increase with a few staircase blocks, would you think you have encountered a feature or a bug?
100% a feature!!! And it is very useful for all types of crafts from making honey block, crisp, obsidian, lava pits, and yes fishing holes where ever you want them. I never once thought it was a bug. Just part of the game, being able to terraform your world how ever you choose. Isn't that what this game is exactly about? Again for being part of the game since ps3, it should be a feature.
Thanks for the report! Because this matches the PC version, this is currently working as intended on mobile / console.
Still can't get the the liquid to multiply :/ does it only work in multi player?
In my testing I got it to duplicate in single player, but that might not be the case for all versions/platforms (it did say in the video that it needs hosting). Perhaps try starting a local host?
Top Bottom