Random Freeze (?)

Discussion in 'PC Bug Reports' started by Desperatio, Nov 23, 2016.

  1. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Its not random; its nearly 100% reliable for people who have it, and happens 0% of the time for people who don't have it.

    What "appears" random (but actually has some underlying pattern we haven't figured out) is why it happens to those who it happens to. Its something hardware/software related, but that doesn't mean its not Terraria's fault, just that its a conflict somewhere between a specific piece of hard/software and the game. However, we are pretty confident that it is related to the audio file, and we are pursuing various options to resolve that.
     
  2. Sylent :^)

    Sylent :^) Plantera

    Well, I was pretty far off then. Ah well. Glad they found the issue.
     
  3. KushWookee

    KushWookee Terrarian

    After seeing this I thought of a problem I had with Fallout 4 and Stardew Valley, where there were certain audio files that would crash the game. The fix for most people was that they had no external audio device plugged in. I had this same glitch that was repeatable everytime i entered the snow biome. Plugging headphones in to my computer solved the problem immediately.
     
  4. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    That's a weird solution.

    My guess would be that going through the headphone hard/software bypassed whatever issue was occuring with the speaker hard/software on your end and so resolved it for you. May not be a reliable fix for others, but we can try it out next time someone is running into it.
     
  5. jorlin

    jorlin Terrarian

    I'm using the GOG version on Ubuntu Linux 16.04 64 bit using a fully updated system and I'm also hit by this bug. I have an nVidia 640GT grpahics card and an Intel 82801JI ICH10-type Audio chip. It reports the following Terraria version: 1.3.5.3. 100% reproducable on my end by having a blizzard visible. As one of my worlds has a spawn point right in the ice biome, it's like playing Russian roulette every time I enter this world.

    This is my console output on a "frozen" blizzard session started with start.sh:
    Running Terraria
    IGLDevice: OpenGLDevice
    OpenGL Device: GeForce GT 640/PCIe/SSE2
    OpenGL Driver: 4.5.0 NVIDIA 375.66
    OpenGL Vendor: NVIDIA Corporation
    MojoShader Profile: glsl120
    Using EXT_swap_control_tear VSync!
    Using EXT_swap_control_tear VSync!
    Using EXT_swap_control_tear VSync!
    Using EXT_swap_control_tear VSync!
    Using EXT_swap_control_tear VSync!
    Resolution changed to: 1280x1024.
    WaveMaskData texture recreated. 1x1
    WaveMaskData texture recreated. 98x111
    WaveMaskData texture recreated. 98x111
    WaveMaskData texture recreated. 98x111
    Using EXT_swap_control_tear VSync!
    Using EXT_swap_control_tear VSync!
    Using EXT_swap_control_tear VSync!
    Using EXT_swap_control_tear VSync!

    I'm not sure if these output lines will help you along to solve this issue. Probably not, but it does not hurt your effort either.
    In the meanwhile my character is frozen but events do happen. I just had the "A meteorite has landed" message and the music still plays. Both enemies and neutral characters, like the goldfish and penguins still move about and enemies kill neutrals. This suggests that the game is in fact still running and has not really crashed in a strict sense, Also, a flaglike white image is bouncing up and down, which is probably the wings of my bell fairy. This fairy is in a layer below my character, though it's pink sparks seem to emanate from my character's belly. After the rain susbsides, my char. is activated once more, being vulnerable and fortunately: being able to move :)
    I'm looking forward to see this bug resolved.
    Leinfors and team: Good luck trying to squash this bug.
     
  6. Hybris41

    Hybris41 Terrarian

    I have this problem also and I may found a solution but i don't guarantee this will work for you.I'm usually play games without speakers or earphones and sometimes that causes problems with some directx massages saying that ''no sound card found'' which i don't know why.So when the blizzard came up and my character frozen, I put my earphones on pc and restarted the game after that i was able to move again.I wish that works for you too.
     
  7. heaven66

    heaven66 Terrarian

    Works for me, thank you!
     
  8. RedStorm1775

    RedStorm1775 Terrarian

    I have the freezing as well but it only happened after I killed Golem. I'm on the newest version of Terraria. This has never happened before I killed him. My inventory also messes up when I try to get one of an item.
     
    Last edited: Nov 20, 2017
  9. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    If you are suffering from the Blizzard freeze, it has nothing to do with Golem being defeated or not; that's likely just a coincidence.
     
  10. Swass

    Swass Terrarian

    Pretty sure the common thread here is not having an audio output. I came looking for a solution to this issue, and it is only happening on one of my computers, and it is the one without speakers. Tried plugging my headset in to resolve, but of course the blizzard ended just when I did it.
     
  11. Swass

    Swass Terrarian

    TO FOLLOW UP: Plugging in a USB headset on this computer totally resolves the freeze. Effected computer is running windows 8.1
     
  12. apenico

    apenico Steampunker

    I am positive it has to with audio as you have been mentioning. My game hasn't had any problems until my audio was corrupted.
     
  13. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Interesting findings guys. We've still been unable to replicate the problem on our end, though we are well aware that the audio is the most likely culprit. Keep posting any info you find. :)
     
  14. Skipper

    Skipper Terrarian

    Happened upon this bug/crash a couple of days ago. Through sheer diligence i've most likely narrowed down the possible reasons for the crash in my case to the use of discord whilst playing the game. No discord no problems. So... anyone else with this issue that's on discord aswell?
     
  15. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    That would be a very interesting connection if other individuals can chime in on that.
     
  16. TheSaggatiaLeaf

    TheSaggatiaLeaf Terrarian

    I have completely shut off everything that would take any sound, including discord, and I still am getting it. I can't even avoid it as I am in a hardmode world and my spawn is right in a snow biome
     
    Leinfors likes this.
  17. Alouette

    Alouette Terrarian

    Same problem. I don't run discord and I don't have any audio devices plugged in right now. My character is frozen in place and I can't use most controls, though the function keys (F1-F12) still work.
     
    Leinfors likes this.
  18. Zatherio

    Zatherio Terrarian

    For those of you still having this problem, I noticed it pop up for me when I removed one of the sounds files from the Terraria install path (\Steam\steamapps\common\Terraria\Content\Sounds) to mute The Axe. The bug stopped when I put it back.
     
  19. Sanastcz

    Sanastcz Terrarian

    Hi, i had same problem as everyone else. As i was reading some posts i found out that my problem was easily solved by pluging in my headphones. i have new PC so it is on my table only with mouse and keyboard, no speakers pluged in nothing. The freeze start apearing when i unpluged the headphones and stoped after i pluged them in. I have absolutly no idea if this will help but if you want i can sand you ma specs.

    Btw. sorry for grammar En is not my first language.
     
  20. YT-SW_CreeperKing

    YT-SW_CreeperKing Terrarian

    --- Double Post Merged, Apr 17, 2018, Original Post Date: Apr 17, 2018 ---
    go to steam -> right click Terraria -> properties -> local files -> verify integrity of game files, wait a little bit, then there you go! you fixed it, this worked for me