• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tAPI Shockah's tweak mods

Status
Not open for further replies.

Exabit

Terrarian
I have kind of a weird issue. FCM just.. isn't working. There's no error or anything shown to me, the menu just isn't there. Every mod except accessory slots is being used just fine on tAPI r16.
 
so i am having an issue with tAPI here's the log from the game launcher
11:24:50 PM Start() - Starting: tAPI.exe
11:24:50 PM Start() - Process started
11:24:58 PM Start() - Process exited
why is this happening, i tried removing the mods and starting it up and still no prevail... `:sigh:
 

codeman936

Terrarian
none of your mods show up on the ui.I try to use both fcm mods but the do not show up.They show to be loaded and everything.I also have the base mod installed.
 
Last edited:

Danger808

Steampunker
I get this when I try to run your mods, what do I do?

>>> Singleplayer: 12:38:50 <<<
TAPI.Mods+LoadException: Accessory Slots+ r1.tapi: System.TypeLoadException: Could not load type 'TAPI.ModItem' from assembly 'tAPI, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.
at System.Reflection.RuntimeAssembly.GetType(RuntimeAssembly assembly, String name, Boolean throwOnError, Boolean ignoreCase, ObjectHandleOnStack type)
at System.Reflection.RuntimeAssembly.GetType(String name, Boolean throwOnError, Boolean ignoreCase)
at System.Reflection.Assembly.GetType(String name)
at TAPI.ModJsonHandler.HandleItem(ModBase modBase, JsonData j, String fname) in x:\tAPI Core\tAPI\Mod\ModJsonHandler.cs:line 485
at TAPI.ModJsonHandler.Handle(ModBase modBase) in x:\tAPI Core\tAPI\Mod\ModJsonHandler.cs:line 54
at TAPI.Mod.<Load>b__0(BinBuffer bb) in x:\tAPI Core\tAPI\Mod\Mod.cs:line 276
at TAPI.Mods.HandleTapiModFile(FPath path, Action`1 action) in x:\tAPI Core\tAPI\Mod\Mods.cs:line 449
at TAPI.Mods.HandleModFile(FPath path, Action`1 action) in x:\tAPI Core\tAPI\Mod\Mods.cs:line 427
at TAPI.Mod.Load() in x:\tAPI Core\tAPI\Mod\Mod.cs:line 107
at TAPI.Mods.Load() in x:\tAPI Core\tAPI\Mod\Mods.cs:line 539
at Mods.Load()

Mods used:
Shockah.Base (Shockah's base r2 by Shockah)
Shockah.AccSlots (Accessory Slots+ r1 by Shockah)
 

obsidiantoolz

Terrarian
For those who can't get Accessory Slots+ to load in r16, it worked for me after I decompiled the mod and removed the bit of code on line 57 of MBase.cs
The code looked like
Code:
SBase.EventMenuStateChange += (menu) =>
{
    counterSlot = 0;
};
(To decompile the mod just extract it to your Sources folder with WinRAR or something, then use the tAPI Builder)

Hope this helps some people
 

Zanthor

Cultist
To anyone wondering if Shockah's gonna update this for 1.3, I wrote a message on his profile asking about it, to which he replied with the following: "I'm not modding anymore, so I most likely won't update anything for 1.3. Also, I don't really like how tModLoader does some things, so I'm not really willing to either. Same goes for Prism."
 
Status
Not open for further replies.
Top Bottom