• PC 1.4.3: An eye for an eye, the Terraria x Don't Starve Together Crossover Update! Get all the details here. Found some bugs? Report them with as much detail as possible here.
  • Journey's End on Xbox and PlayStation!: Get all the info by clicking here. Click here for Known Issues and FAQ. For any other bugs, report them (with as much detail as possible) here.
  • SWITCH 1.4: Journey's End will launch on Switch January 4, 2022! More details here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

tModLoader Stuck on Syncing Mods Screen when joining friends

CloudsInMind

Terrarian
This is unusual since I haven't seen anyone have this issue whatsoever so far, hoping for some help with this.
My friends have been playing a multiplayer game, not server, and I've been having difficulty joining them. Whenever I join them, I type in the password set up, it attempts to join, then gets stuck on the Syncing Mods portion of the loading process. It's not frozen, I can still hear music, and the menu is actively moving, but after 1 minute of waiting it boots me out saying "Lost Connection."
I would try to host the world, but when I try to host a world, it gets stuck on "Found Server", and does nothing. I can cancel anytime, but never has it let me host a world.
I've tried alot of various things, double checking & triple checking mods, it's all on the right versions. Reinstalling tModLoader does not fix the issue. Disabling firewall as well does not work. With steam, I've tried to verify the integrity of the files, but nothing is wrong, although there is an issue with the base game with the integrity of the files, but it refuses to fix itself.
I dont know if this is some sort of weird bug within tModLoader, or if it's a connection issue with my end. I'm hoping for help with this, anything helps at this point, I've been trying to figure this out for almost a week now.
Screenshot (9).png
 
Top Bottom