• Switch 1.4: Journey's End on Switch released January 4, 2022! More details here. Report bugs here.

Mobile Switch from local to cloud worlds = crash when Moga game controller is connected


Empress of Light
Hello, all. I've been playing Terraria on the PC since the Humble Bundle included it. Haven't got around to playing any of the other titles in that bundle, either.

A few days ago I put it on my phone and tablet as well, and because I find the on-screen controls difficult to use I got a Moga Pro Power, an XBox-style Bluetooth game controller for Android. When it works it's great, or will be soon as I get the hang of it.

The problem comes when I try to use, or to create, a world stored in the cloud. If the Moga isn't connected via its "Moga Pivot" app, I have no trouble selecting the cloud when it's time to choose a world. Things work as expected. However, if the Moga is up (as shown by a bar of controller button definitions at the bottom of the display) trying to switch from local to cloud world storage causes an immediate crash. The task manager shows Terraria still running, though of course switching to it loads the program anew. If I force-close Terraria, force-close Moga Pivot, then restart Terraria, the button definition bar is no longer visible and I'm able to switch between local and cloud world storage.

I am able to create characters to be stored on the cloud, and load them from the cloud. It's just when time comes to load a world that the crash always occurs.

This is on a Samsung Galaxy Note 10.1 2014 Edition running KitKat, stock device, not rooted or otherwise stressed, 32 gig internal storage + 64 gig micro SD. I've tried it with and without a Jawbone Mini Jambox Bluetooth speaker connected with the same results. I've tried rebooting after a power-down, switching to another user and back, no change.

Anyone else using a Moga Pro Power controller on a tablet, and if so, do you have this problem too?


Top Bottom