• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

Tool TEdit - Terraria Map Editor

Flor3nce2456

Duke Fishron
I've been trying to use TEdit to convert my world to Journey mode after realising how nice Journey mode actually is. Problem is, every time I try to load my world that contains a build I'm proud of so far, the loading just stops at "Calculating Colors...". I've waited for an hour+ to see if anything changes, but no, it's just stopped. The program isn't frozen. I can load fresh worlds, but the world I have a base on just stops mid load.

I tried making another build on a Journey mode world, which loaded into TEdit just fine after generation, but after I finished my main structure, I wanted to import some nice landscape features in because the surface of that world was flat and boring. When I tried to load that into TEdit, I got the same refusal to load past "Calculating Colors...". It seems as though the more you modify the world in-game, the less likely it is to load in TEdit. Is anyone else having this problem? Am I doing something wrong, or is this just a result of the utility being in beta?
Update to build 5. Build 4 cannot open 1.4.0.3 version worlds.
 

The Atroxious

Terrarian
Update to build 5. Build 4 cannot open 1.4.0.3 version worlds.
I'm using 4.0 Beta 5. Downloaded and tested it out shortly after its release. I've had this problem since Beta 2 with Terraria version 1.4.0.2. The problem isn't the version I'm using, it's either my computer/game, or it's a bug in the software. I'm just trying to figure out which one so I know if there's a fix I can implement on my end, or if I need to wait it out for a later version.
 

Samalas

Terrarian
Just double checking, all the files that are created automatically by TEdit are just backup worlds correct? If I'm making my own backups every time before opening up my world, I can just delete the all the extras?
 

TheMagicSteak

Terrarian
Hey! Whenever I try to open a world save that has been modified using TEdit, it only says:


"Load failed!"
"No backup found"

The only thing I did is changing the difficulty from Master to Expert mode. Any idea why this is happening?
 

Tomkeen

Terrarian
Hey! Whenever I try to open a world save that has been modified using TEdit, it only says:


"Load failed!"
"No backup found"

The only thing I did is changing the difficulty from Master to Expert mode. Any idea why this is happening?
Same problem and somehow cant fix it. Tried every single beta version, but seems like it corrupting the world files.
 

Ottana

Terrarian
Personally, it's when i try to purify my world, it didn't seem to save anything, tried by saving directly on a second world, it didn't purify anything, and by "saving as", which should create another world, but the world don't appear in the file. Anyone can tell me if the purify option work for them ? that would be nice, thanks
 

Samalas

Terrarian
Personally, it's when i try to purify my world, it didn't seem to save anything, tried by saving directly on a second world, it didn't purify anything, and by "saving as", which should create another world, but the world don't appear in the file. Anyone can tell me if the purify option work for them ? that would be nice, thanks
It worked for me, but I did it a few versions ago and one in game patch ago.
 

The Atroxious

Terrarian
I upgraded to Beta 6 and I'm still having the issue of loading stopping at "Calculating Colors..." on my worlds. Just an FYI.

As long as I load a fresh world into TEdit it's fine, but once I have a few hours played on that same world, it won't load fully.
 

Samalas

Terrarian
I upgraded to Beta 6 and I'm still having the issue of loading stopping at "Calculating Colors..." on my worlds. Just an FYI.

As long as I load a fresh world into TEdit it's fine, but once I have a few hours played on that same world, it won't load fully.
Any chance you've used a lot of newer blocks or have placed mannequins anywhere? On github the notes state that mannequins are still causing trouble, and any time I try adding in a new block in Tedit it's just blank, nothing shows up, could be an issue there.
 

The Atroxious

Terrarian
Any chance you've used a lot of newer blocks or have placed mannequins anywhere? On github the notes state that mannequins are still causing trouble, and any time I try adding in a new block in Tedit it's just blank, nothing shows up, could be an issue there.
...

When they mentioned that mannequins were causing trouble I thought they meant that mannequins were not useable sprites in TEdit.

I...may have started having trouble with my worlds after I put mannequins in them. Maybe.

I just didn't make the connection.

LOL I feel so dumb.

Thanks man! I really appreciate it.
 

Jaredo27

Terrarian
I was working on a 1.4 world in TEdit 4.0 beta but Everytime I save it turns into a .tmp and Terraria won't detect it in game what to I do to stop TEdit from doing this
 

The Atroxious

Terrarian
Okay, so I did some testing, and apparently it's not the mannequins. I put mannequins in an empty world, and it had no trouble loading.

I did some more testing, and I found out that it's the Illuminant Paint that causes this. I had used Illuminant Paint on some things, and once I painted them, the world was unusable. I went back and removed the blocks and items I had painted with this paint in my old unusable worlds, and I was able to get them to load.

Just a heads up to anyone else who can't load their worlds: Take out anything that you've used Illuminant Paint on, and try again.
 
Last edited:

RN_FADED

Terrarian
If I click yes, Tedit soon crashes. Is there any way to fix this or do I have to wait for a newer version of Tedit? My world was newly created on release of terraria 1.4.0

1590368162562.png


Edit: My world isn't corrupt, I've tested it and it works fine in game.

I fixed it
 
Last edited:
This tool needs some serious TLC for the most basic of features.

The zoom is really bad. When you're zooming in and out, there is a point where certain blocks will disappear due to resolution. That's expected. However, the issue is when you try to zoom in to avoid that, the zoom goes too far in, making it near impossible to do large-scale copy and pasting.

Why can you not "Fill" with sprites? This makes no sense because the Platforms are sprites, making it so I have to do copy/pasting in order to make world-spanning platform structures.

The copy and paste mechanic is really bad for one simple reason: Leftmost Mouse Positioning. Either I'm doing it wrong, or Copy/Paste is done by pasting down with the pasting point being at the top left corner of whatever you copied. This means if you try to Copy/Paste something that spans the entirety of the screen from left to right (like the previously mentioned platform), you have to paste at the left-side of the screen. This becomes an issue due to the zooming issues because if you are zoomed too far out then the blocks you want to line up with vanish, but the moment you try to zoom in you are suddenly zoomed too far in to be efficient. You also can't undo a paste, at least mine is not working. THAT is no good.

ALWAYS make your copied items paste down with their center being oriented on your mouse-point, and fix the zoom increment to have more refined zooming. Jumping from 100% to 50% with nothing between covers too much ground.

Also, the whole tool is not very intuitive at all. Why is there such a divide between the Sprites and Tiles? If they need to be separated because of system limitations then fine, but move the stuff at the top of the screen to a space in the right to be with the Sprites. These things need to be organized. Keep the fruit with the fruit and the meat with the meat. Don't set an apple way off in the distance and the oranges in another place.
And why are they called "Sprites" anyways? At least, why are things like the Platforms in the Sprites tab? Even if they are not considered a tile in the system (I don't know since I haven't delved into the code like you have" like the wood blocks are, you can still make it so we see them like that as the users. I would have NEVER considered those to be a "Sprite" because "Sprite" is a term more generally reserved for the more complex images, like character models or items (even though sprite is really just an image).
 
I downloaded the latest version of tedit that works with the 1.4 update, I did this because I´m tired of the crimson and I just wanted to purify my world but for some reason when I try to load the current world that im playing it doesn´t load completely updated in TEdit, it seems like it´s on pre-hardmode for some reason, I tried opnening my 1.3 world and it´s perfectly fine I can even purify it then go to Terraria and play it but for some reason the only world I need to play is the only one that doesn´t seem to work, I´m a doing something wrong?
 

JRuhl09

Terrarian
Personally, it's when i try to purify my world, it didn't seem to save anything, tried by saving directly on a second world, it didn't purify anything, and by "saving as", which should create another world, but the world don't appear in the file. Anyone can tell me if the purify option work for them ? that would be nice, thanks
I can't save either after purifying. It sucks because I don't wanna play until I can guarantee that my jungle won't be destroyed :/
 
Top Bottom