Tool TerraCustom for 1.3

Meowerdoom

Terrarian
Okay so I have the copied exe in my Terraria folder. I run it. It open, starts compatibilizing mods, closes. I open Terraria, nothing is different. TF do I do? I've opened the exe from the Terraria folder (opens, compatibilizes, closes) and from the desktop (crashes)
 

jopojelly

Retinazer
tModLoader
Okay so I have the copied exe in my Terraria folder. I run it. It open, starts compatibilizing mods, closes. I open Terraria, nothing is different. TF do I do? I've opened the exe from the Terraria folder (opens, compatibilizes, closes) and from the desktop (crashes)
Well, you have to open it in the Terraria install folder. Usually C:\Program Files (x86)\Steam\steamapps\common\Terraria. I'm not sure why it is randomly closing on you.
 

LogiWanKanobi

Terrarian
So I have a problem... I did everything correctly, and nothing crashes, but when I click the create button on my world no matter how small or big it is or even if its set to default. The loading just kinda stops when it reaches the hardmode ores part and just goes back to the screen where you click create... Any ideas?
 

Lionhart

Terrarian
Do I need to do something special to make this work for multiplayer? I made a new map and the only change I made was so that there was corruption and crimson. When my bother tries to connect it just sits on the loading screen forever and he never connects. We are using some mods like calamity, spirit, and others.
 

LinaNfinE

Steampunker
Do I need to do something special to make this work for multiplayer? I made a new map and the only change I made was so that there was corruption and crimson. When my bother tries to connect it just sits on the loading screen forever and he never connects. We are using some mods like calamity, spirit, and others.
Nope. Nothing spatial is required.
I'm playing on vanilla, but I don't have any problem for multiplayer on terracustom.
Did you already try that on a world created by the original terraria?
I think the problem isn't caused by terracustom.
 
Last edited:

Lionhart

Terrarian
Do I need to do something special to make this work for multiplayer? I made a new map and the only change I made was so that there was corruption and crimson. When my bother tries to connect it just sits on the loading screen forever and he never connects. We are using some mods like calamity, spirit, and others.

I actually re-hosted with a password and it worked. I don't know if that was the problem or if it was some weird coincidence.
 

Marcus101RR

Master of Ravens
@jopojelly I don't think you managed to get the Sky Island Generator manipulated, but looking at your code, you need to set skyLakes on the compare value to (subtract) - skyLakes + amountofLakes you want.

Code:
if (k < skyLakes - (skyLakes + 2))

eg:

Because value K will cycle through and as long as it never reached over that threshhold it will always generate lakes instead. Once you fix that I think you have it done. I did this in assembly.
 

Talamar1

Terrarian
Can you compile for the new version of Tmod? Can't create worlds for Overhaul because of version incompatibility.
 

jopojelly

Retinazer
tModLoader
Can you compile for the new version of Tmod? Can't create worlds for Overhaul because of version incompatibility.
You can disable Overhaul and then launch TerraCustom
[doublepost=1531017563,1531017535][/doublepost]
Is there an option to disable the spread of the Corruption/Crimson/Hollow?
No, that happens in game, this only affects the generated world, not how it behaves after that.
 

Talamar1

Terrarian
It does disable Overhaul during the boot (says overhaul was compiled for .14 and TerraCustom was for .13), I'm just concerned there is content not being generated in the world since the mod isn't loaded.
 

jopojelly

Retinazer
tModLoader
Hey, could you add a command line version for Linux? That would be much appreciated
No, making all the settings on the command line interface would be a pain. Just copy the world over if you are using a host or use the regular Linux Client version.
[doublepost=1531158938,1531158919][/doublepost]
It does disable Overhaul during the boot (says overhaul was compiled for .14 and TerraCustom was for .13), I'm just concerned there is content not being generated in the world since the mod isn't loaded.
Overhaul doesn't add anything to worldgen afaik
 
So I've created a new world, using your tool, and the only two problems I have is that the moon is type 3, while I selected type 2 (no biggy really), and that I selected both for all ores options (including hardmode ores), but when I smashed like 15 altars, I've only got the cobalt, mythrill and adamantite ores. I used terrafirma to check the map and there were only these 3 ores on the map. May I ask how does the both option work on hardmode ores?
Love your tool (mod?) by the way.
 

jopojelly

Retinazer
tModLoader
So I've created a new world, using your tool, and the only two problems I have is that the moon is type 3, while I selected type 2 (no biggy really), and that I selected both for all ores options (including hardmode ores), but when I smashed like 15 altars, I've only got the cobalt, mythrill and adamantite ores. I used terrafirma to check the map and there were only these 3 ores on the map. May I ask how does the both option work on hardmode ores?
Love your tool (mod?) by the way.
Did you smash ores in game or in TerraCustom. both ores only works for pre smashing altars.
 
I made an account to post this, but honestly, this tool blows. More than half the time it gets stuck on 'generating corruptin pits' or 'spreading grass'.

Here are the settings:
Selected Ores
Dungeon on Right Side

That's it. Tested it 20 times, got stuck 14 of those times, and those 14 times, it didn't resume even after letting it sit for 5 minutes. The times it did work, it finished in less than 30 seconds.

Fix it.
 
Top Bottom