• PC NEWS: 1.4.2.3 update is out! More info here. Report bugs here
  • CONSOLE 1.4 LAUNCHES SEP 30: The official launch date for Journey's End to arrive on Xbox and PlayStation is September 30th! Click here for more info. The plan is to have the update on Switch out later this year. Stay up to date with console news here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

Tool TerraCustom for 1.3

Suzunaan

Terrarian
afaik the 64 bit version changes a lot of files that terracustom tries to open, so there are those conflicts. I won't know unless I try and I won't try since I don't have time to do that.
Eh, guess it wouldn't be worth it if it was that easy. Thanks for the explanation.
 
No you're not, but it does take extra steps. You need 2 copies of Terraria installed, a vanilla copy and a modded copy using TMod 64bit. Easiest way to do this is just make a copy of the entire unmodded Terraria folder and then install TMod into that copy. You put TerraCustom into the unmodded Terraria folder and run it. Make the world you want and save it. Then quit TerraCustom and go to the copy folder where you installed TMod. When you run the modded version it should find the world that you created.
Thanks for the advice, but the Tmod 64 bit keeps causing me issues, I have however CAN get the Extra Large World to work, but I need to make serious compramises, as in disable the majority of expansion mods I have, like Thorium, Calamity and Spirit. I can only make the Extra Large Worlds work if I have only one expansion mod enabled like the ones I just named and even then I can't double the world size with one of these mods installed, I can only go as far as about a 50% increase of a large world, oh well I guess 8gb of ram just isn't that sufficient. Once the Tmod64bit is more stable I'll try out your idea. Thanks though I greatly appreciate it.
 

nek0master

Terrarian
Thanks for the advice, but the Tmod 64 bit keeps causing me issues, I have however CAN get the Extra Large World to work, but I need to make serious compramises, as in disable the majority of expansion mods I have, like Thorium, Calamity and Spirit. I can only make the Extra Large Worlds work if I have only one expansion mod enabled like the ones I just named and even then I can't double the world size with one of these mods installed, I can only go as far as about a 50% increase of a large world, oh well I guess 8gb of ram just isn't that sufficient. Once the Tmod64bit is more stable I'll try out your idea. Thanks though I greatly appreciate it.

Actually no, 8GB is more then enough its just that since Terria and TerraCustom are 32-bit applications they can only access about 3-4GB of RAM which is shared across ALL 32-bit programs that are running (For example, if TerraCustom takes up 2.8GB while generating with mods and theres already other programs like Discord, Steam, ThunderBird, etc taking up memory, that leaves little extra and can cause crashes).

Where as 64-bit programs can access all your memory and they dont share a limited memory space either (so you could have several 64-bit programs taking up like 8GB each if you had enough ram :D )

I get buy with Spirit, Calamity, and Thorium all together by disabling non-essential mods during map generation of a 10,000 tile wide map with 2400 tile height. Its not that much bigger then the default LARGE size, but it allows for a bit more like larger beaches, slightly bigger dungeons, and more space around the spawn to build a little town if one wishes to do so.

============================================================

Too bad there wasn't a way to "Place" things during generation or something like that so that one just puts the general area where they want something so that you dont get corruption/crimson messing with the jungle or snow biomes and could perhaps place the snow, desert, and jungle biomes in what ever area of the map one wishes.

I'm a bit picky with how my maps look and are laid out, and I dont like having corruption spawning inside another biome except on its own in "Forest" area's
 

StealthBravo2

Terrarian
I'm having trouble figuring this out even reading through 20 pages of this thing I'm doing everything that it says and it's still not even acknowledging that I added it to the installer
 

StealthBravo2

Terrarian
Simple version:
  1. Click on the link in the OP that matches the OS you use.
  2. Download the .zip file it leads to.
  3. Unzip that file, which should have a "README.txt" file and a "TerraCustom v0.5.4.exe" file.
  4. Place the "TerraCustom v0.5.4.exe" file inside your Terraria installation folder. My copy by default in Steam was placed in C:\Program Files (x86)\Steam\steamapps\common\Terraria
  5. Run "TerraCustom v0.5.4.exe" from inside the Terraria install folder
It should be self explanatory from that point on.
Thanks i thought i just had to launch terraria normaly
 
So I decided to start a new world full of various mods this past weekend. Looked up my favorite tool, TerraCustom, to find out it still works like a charm. There were some updates that happened today, and a new version of TMod, and everything still worked so whatever. But tonight I thought I would create a new world to mass mine some sand, and loaded up TerraCustom to play with the world gen details, and the first sign things weren't working is the worldgen previewer didn't show. But it finished generating, and when I went into the game to load up the world it wasn't on the list of worlds to choose from. I double checked that it generated the file in the worlds folder, and it did. I tried it about half a dozen more times to no avail, even disabling all the mods at one point.

Anyone else facing a similar issue after updating Tmod?
 

jopojelly

Retinazer
tModLoader
So I decided to start a new world full of various mods this past weekend. Looked up my favorite tool, TerraCustom, to find out it still works like a charm. There were some updates that happened today, and a new version of TMod, and everything still worked so whatever. But tonight I thought I would create a new world to mass mine some sand, and loaded up TerraCustom to play with the world gen details, and the first sign things weren't working is the worldgen previewer didn't show. But it finished generating, and when I went into the game to load up the world it wasn't on the list of worlds to choose from. I double checked that it generated the file in the worlds folder, and it did. I tried it about half a dozen more times to no avail, even disabling all the mods at one point.

Anyone else facing a similar issue after updating Tmod?
TerraCustom needs to update to 0.11 to load the 0.11 tmod format. An update will come soon
 

Nightmare3711

The Destroyer
What if you could start the world with celestial pillars, and maybe choose which ones will spawn upon world creation. That and /or maybe have a system that allows the player to choose which pillars will spawn, and which ones might spawn, like let them set the chances that the Nebula pillar will spawn or the Solar pillar. It'd be fun to see a world with a dozen Vortex pillars and you have to progress with the pillar in your way, or something.

Why you would want this, I don't know
 

TheBrightOne7

Terrarian
it's already updated to 0.11.3

Edit: oh, 0.11.2.2 actually, but I don't think it should matter

Checked.
0.6v doesn't support latest mods. (didn't screenshot the list, but mods I remember were: Calamity (+music), Thorium, Recipe browser, etc.)
Asks to go with the latest tmod.

[A bug I suppose from 0.6v]
When pressing 'Exit' rather then 'Exit and disable mods', doesn't make a difference - relaunch automatically disables mods, leaving available ones.
 
I've installed everything correctly, and put everything in the right folder, but when I run the .exe (even with admin privileges), it just gives me the loading wheel and nothing else.

I have a problem with your large world enabler mod too, I've placed the downloaded .tmod file into the C:/Users/My User/Documents/My Games/Terraria/Modloader/Mods folder, but can't find it in the mods folder when ingame for TModLoader, nor can I find it in the browser.

EDIT: Disregard, TerraCustom DOES run, but doesn't load anything. It just opens two 32-bit Terraria processes in the background.

EDIT2: Got it to work, had to completely delete and reinstall Terraria, but I got it to load, just don't know how to integrate Large World Enabler with it.

EDIT3: Found that as soon as TModLoader is installed into the Terraria folder, the TerraCustom .exe file no longer works
 
Last edited:

jopojelly

Retinazer
tModLoader
EDIT3: Found that as soon as TModLoader is installed into the Terraria folder, the TerraCustom .exe file no longer works
As long as you have the official 0.11.3 (not 64 bit), terraCustom 0.6 should work. The logs file would help diagnose the issue. My Game/Terraia/TerraCustom/Logs/client.log
 
As long as you have the official 0.11.3 (not 64 bit), terraCustom 0.6 should work. The logs file would help diagnose the issue. My Game/Terraia/TerraCustom/Logs/client.log
I think i figured out the bug.
For some reason when I run terraCustom 0.6, it runs tmodloader 0.11.2.2. However if i run terraria normally, it runs 0.11.3. Im not exactly sure why though. Ive never installed 11.2.2, unless terraCustom 0.6 emulates an older version of the modloader.
This is why mods say that they dont work through TerraCustom though.


edit: Looking back a bit through the thread =w=
It does look like it matters. Either the mods see that its 0.11.2.2, and kick it back, or theres some key part of the code that 11.3 mods need.
I'll look through the logs real fast and see if i can isolate the issue.

edit2:
l;khfsdblkjsdfvkgbuilcvasd.PNG
They all seem to have this error string. Its almost like its the mods that are reaching for something that isnt there.
Log added as attachment.


Edit3:
I reinstalled tmodloader over the terraCustom to see if this changed anything, which it seemed to. I didnt get the same errors as last time.
I seem to have isolated the issue down to the recipe mod im using (which functions fine on 11.3)
Once it sees that the mod doesnt work, it kills the rest of the mods, instead of just the offending one. Disabling the Recipe mod before running TerraCustom fixes it though, and the rest of the mods i have run fine in Terra Custom.
Looking through the logs, it looks like its hanging up on a callback. If im reading this right, i think its doing a check to see if its on the right modloader.
Added updated log (Client2) and removed previous one (Client1) since that log was based on an improper install.

=======================

Merged Edit:
Since im poking on here though, Is it possible to increase the size of the desert biome?
I was wanting to build stuff in the desert, but its such a tiny surface biome :T
 

Attachments

  • client2.log
    5.4 KB · Views: 61
Last edited:

jopojelly

Retinazer
tModLoader
I think i figured out the bug.
For some reason when I run terraCustom 0.6, it runs tmodloader 0.11.2.2. However if i run terraria normally, it runs 0.11.3. Im not exactly sure why though. Ive never installed 11.2.2, unless terraCustom 0.6 emulates an older version of the modloader.
This is why mods say that they dont work through TerraCustom though.


edit: Looking back a bit through the thread =w=
It does look like it matters. Either the mods see that its 0.11.2.2, and kick it back, or theres some key part of the code that 11.3 mods need.
I'll look through the logs real fast and see if i can isolate the issue.

edit2:
They all seem to have this error string. Its almost like its the mods that are reaching for something that isnt there.
Log added as attachment.


Edit3:
I reinstalled tmodloader over the terraCustom to see if this changed anything, which it seemed to. I didnt get the same errors as last time.
I seem to have isolated the issue down to the recipe mod im using (which functions fine on 11.3)
Once it sees that the mod doesnt work, it kills the rest of the mods, instead of just the offending one. Disabling the Recipe mod before running TerraCustom fixes it though, and the rest of the mods i have run fine in Terra Custom.
Looking through the logs, it looks like its hanging up on a callback. If im reading this right, i think its doing a check to see if its on the right modloader.
Added updated log (Client2) and removed previous one (Client1) since that log was based on an improper install.

=======================

Merged Edit:
Since im poking on here though, Is it possible to increase the size of the desert biome?
I was wanting to build stuff in the desert, but its such a tiny surface biome :T
Hm, disabling other mods is a 0.11.3 fix, so maybe I'll release an update when I have some times.

I don't think there are any current options on increasing the desert size. Desert is a little frustrating to work with without making it look really wonky. It's a good idea though, worth adding a slider for.
 
Hm, disabling other mods is a 0.11.3 fix, so maybe I'll release an update when I have some times.

I don't think there are any current options on increasing the desert size. Desert is a little frustrating to work with without making it look really wonky. It's a good idea though, worth adding a slider for.
Yeah, after getting back into it, the primary desert seems to revolve around the underground desert size, which makes me wonder if that has its own value vs the mini desert biomes you see dotting many maps.

Also is there a way to add an exception rule to the snow biome for crimson/corruption, much like the jungle?
 
Top Bottom