Tool TerraCustom for 1.3

Why it's doing this?

How do I solve this? Should I just wait? I just finally got the perfect world after a dozen of trials and this happened..

EDIT: Just had to wait it finally loaded
Last edited:
When will jopojelly update this to the current tmodloader version and put it on the Mod Browser?
@jopojelly Any plans to update TerraCustom soon? The latest version (that I can find at least) is for Tmod 11.5. I am running Tmod 11.6.1 (Waiting until 6.2 is out of Beta) and while I am running the 64 bit patch, which TerraCustom doesn't like, I use a trick where I run TerraCustom from a backup Vanilla folder, and it works just fine. While I can get TerraCustom to run normally it disabled the Furniture, Food, Fun (CosmeticVariety) mod because it's built for Tmod 11.6.2 (Just updated today, actually, as I recall). It doesn't mind the Calamity, Thorium, Spirit, Shadows of Abaddon, Joost, Chad's Furniture & Fargo's Mutant/Souls mods, which are the only ones I have on when doing Worldgen, but it seems to dislike Furniture, Food, Fun. I reckon other people may start seeing this issue with soon-to-be updated mods.

Minor gripe, as well, but I'm looking for a way around it, worldgen tends to freeze on Corruption Pits if I have both evils enabled and try to make them avoid the Jungle. It seems that no matter what, Worldgen only goes smoothly if it plasters the Evil biomes over the Jungle, otherwise generation grinds to a halt when putting Corruption in.

Edit: I forgot that you can simply turn off Corruption/Crimson generation, so I tried that and now I'm having no issue generating worlds, and Furniture, Food, Fun is now working again... somehow. I might try and see if I can make larger worlds this way, because I never could go larger than 9000 blocks, it would always freeze and crash on Evil generation. Having to build the biome manually is a small price to pay.

I've found you can actually edit the tMod files and change the tModLoader version in them. Ideally you'd want to use a hex editor, but notepad++ actually still works as the version number is right at the beginning and shows up as normal text:

screenshot - notepad++ terraria mod editing.jpg

Per the picture, just replace the "6.2" with a "5" for any mods that TerraCustom is having trouble loading (I needed to do this for Calamity and Sacred Tools out of the 18 mods I had set to load for world gen). Then, after generating your world just change them back and you should be good to go.

Regarding the "stuck generating corruption pits" thing, which I get a lot, I've found the most helpful thing is closing my internet browser ahead of time, as it is a huge memory hog. I've tried waiting it out at least a couple times for a good 10-15 minutes or longer, as one commenter had suggested, however despite the process continuing to use 70-80% CPU it never progresses.
So I have the 64x version of TModloader and Terracustom tells me the Vanilla Executable was modified. I luckily saved a copy of the old one, but swapping it out doesn't work?

I basically have the same problem as @DiviineXpF but I guess in my case it i entirely possible my executable was modded, just I thought it wasn't.

I thought Terracustom worked with modded? Or was that support removed?
Can someone help me I just want to install terra custom

Hmm, I've had that error before but I've forgetten what caused it. I will say though, that is not the correct icon for the normal terraria executable (terraria.exe if you have "show file extensions" enabled in windows). That might be a sign as to your underlying problem? For reference, here is my install folder, and that is actually the 64 bit tModLoader executable (renamed), not the default terraria executable:

screenshot - terraria install folder.jpg
i've recently updated to the latest version of tmodloader because of calamity, but terracustom is still using the earlier version meaning i can't use calamity worldgen
See me post above for a work around
Ive already tried using notepad++ and I keep getting the mod (calamity) recognised as built for the 11.6 version, wich automatically shuts down on the terracustom client while the mod itself is being loaded. Desperately need an extra wide and short, crimson normal mode calamity map to forget the quarantine.
Last edited:
Will this work when 1.4 is released, or will it have to be updated? Now that we know about the release date, I'd hope that this would be updated sometime after 1.4 releases.
Will this work when 1.4 is released, or will it have to be updated? Now that we know about the release date, I'd hope that this would be updated sometime after 1.4 releases.
Everything will need to be updated once 1.4 comes out. Expect TerraCustom to take longer, as many changes are being made to world-gen in 1.4, and Jopojelly will likely want to update TModLoader first.
Top Bottom